aboutsummaryrefslogtreecommitdiff
path: root/astro/celestia
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-12-14 13:23:35 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-12-14 13:23:35 +0000
commitf8f7ecd59017fa3b1c68a043afec677d581339d5 (patch)
tree04bdcea19a4545200eebb811f69ac1de04128701 /astro/celestia
parent54a3291db21c0e4837a36baa18500f34a21007ea (diff)
downloadports-f8f7ecd59017fa3b1c68a043afec677d581339d5.tar.gz
ports-f8f7ecd59017fa3b1c68a043afec677d581339d5.zip
Pull another patch from Red Hat, to fix a runtime crash:
PANIC: unprotected error in call to Lua API (attempt to index a nil value) PR: 195240 Red Hat bug: https://bugzilla.redhat.com/show_bug.cgi?id=1045632 Patch by: Chris Rankin (Comments 13-16) Obtained from: celestia-1.6.1-15.fc20.src.rpm
Notes
Notes: svn path=/head/; revision=374703
Diffstat (limited to 'astro/celestia')
-rw-r--r--astro/celestia/Makefile3
-rw-r--r--astro/celestia/files/celestia-lua-52-fix.patch16
2 files changed, 18 insertions, 1 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 6746c5d6e50c..3541bd50ab19 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -3,7 +3,7 @@
PORTNAME= celestia
PORTVERSION= 1.6.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= astro
MASTER_SITES= SF/${PORTNAME}/Celestia-source/${PORTVERSION}
PKGNAMESUFFIX= -${CELESTIA_UI}
@@ -20,6 +20,7 @@ USES= gettext gmake libtool lua pkgconfig
USE_GL= gl
GNU_CONFIGURE= yes
EXTRA_PATCHES= ${FILESDIR}/celestia-1.6.1-lua-5.2.patch:-p1 \
+ ${FILESDIR}/celestia-lua-52-fix.patch:-p1 \
${FILESDIR}/celestia-1.6.1-gcc47.patch:-p1 \
${FILESDIR}/celestia-1.6.1-gcc48.patch:-p1
diff --git a/astro/celestia/files/celestia-lua-52-fix.patch b/astro/celestia/files/celestia-lua-52-fix.patch
new file mode 100644
index 000000000000..62e26ce073d7
--- /dev/null
+++ b/astro/celestia/files/celestia-lua-52-fix.patch
@@ -0,0 +1,16 @@
+--- celestia-1.6.1.orig/src/celestia/celx.cpp 2014-02-09 23:23:10.308810741 +0000
++++ celestia-1.6.1/src/celestia/celx.cpp 2014-02-09 23:24:57.627017784 +0000
+@@ -272,9 +272,13 @@
+ const char* name,
+ lua_CFunction func)
+ {
++#if LUA_VER >= 0x050200
++ luaL_requiref(l, name, func, 1);
++#else
+ lua_pushcfunction(l, func);
+ lua_pushstring(l, name);
+ lua_call(l, 1, 0);
++#endif
+ }
+ #endif
+