aboutsummaryrefslogtreecommitdiff
path: root/astro/cfitsio/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-07-04 22:29:13 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-07-04 22:29:13 +0000
commitd76d0bd2f73b103e21d4606a03f25b1246084268 (patch)
treef07eaf52ede3fd307ffbe11997f5e4abd510852f /astro/cfitsio/Makefile
parentf610f4415b82c80fc445fb8eff99dd367d5d6a80 (diff)
downloadports-d76d0bd2f73b103e21d4606a03f25b1246084268.tar.gz
ports-d76d0bd2f73b103e21d4606a03f25b1246084268.zip
Notes
Diffstat (limited to 'astro/cfitsio/Makefile')
-rw-r--r--astro/cfitsio/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index 48bc710be971..749c40a52355 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cfitsio
-PORTVERSION= 3.060
+PORTVERSION= 3.090
CATEGORIES= astro
MASTER_SITES= ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/ \
ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/oldvers/
@@ -15,23 +15,20 @@ DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library for reading and writing files in FITS data format
+LIB_DEPENDS= f2c.2:${PORTSDIR}/lang/f2c
+
WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GNOME= gnometarget pkgconfig
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-
-USE_FORTRAN= yes
-
-LIB_DEPENDS+= f2c.2:${PORTSDIR}/lang/f2c
+CONFIGURE_ARGS= ac_cv_prog_FC="f2c"
ALL_TARGET= shared
+USE_LDCONFIG= yes
post-patch:
- ${ECHO_CMD} ${FC}
@${GREP} -lR "<malloc.\h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|<malloc\.h>|<stdlib.h>|g'
@${REINPLACE_CMD} -e 's|="\.so"|=".so.0"|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|%%FC%%|${FC}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|%%FC%%|${FC}|g' ${WRKSRC}/configure.in
do-install:
.for file in drvrsmem.h fitsio.h fitsio2.h longnam.h
@@ -41,6 +38,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/lib
.endfor
@${LN} -sf libcfitsio.so.0 ${PREFIX}/lib/libcfitsio.so
+.for f in cfitsio.pc
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/libdata/pkgconfig
+.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.doc ${DOCSDIR}