aboutsummaryrefslogtreecommitdiff
path: root/astro/fowsr
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2016-09-19 10:15:56 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2016-09-19 10:15:56 +0000
commitb9b3c42940a2e8d1b43cc1f3459b189ef586f17f (patch)
treef650e3f5d1e181dc08f487714911f0a3108ccd5e /astro/fowsr
parent32923391024f2d66c95cc68c3aeff370b85b83b1 (diff)
downloadports-b9b3c42940a2e8d1b43cc1f3459b189ef586f17f.tar.gz
ports-b9b3c42940a2e8d1b43cc1f3459b189ef586f17f.zip
- Update to 2.0.
- project moved to github PR: 212737, 212738 Submitted by: shun.fbsd.pr@dropcut.net
Notes
Notes: svn path=/head/; revision=422421
Diffstat (limited to 'astro/fowsr')
-rw-r--r--astro/fowsr/Makefile17
-rw-r--r--astro/fowsr/distinfo5
-rw-r--r--astro/fowsr/files/patch-fowsr.c49
-rw-r--r--astro/fowsr/pkg-descr2
4 files changed, 25 insertions, 48 deletions
diff --git a/astro/fowsr/Makefile b/astro/fowsr/Makefile
index 307f1609d01f..b85f05bfb92e 100644
--- a/astro/fowsr/Makefile
+++ b/astro/fowsr/Makefile
@@ -2,21 +2,20 @@
# $FreeBSD$
PORTNAME= fowsr
-PORTVERSION= ${FILEVER}.${FILEDATE}
+PORTVERSION= ${FILEVER}
CATEGORIES= astro
-MASTER_SITES= GOOGLE_CODE
-DISTNAME= fowsr-${FILEVER}-${FILEDATE}
-
+DISTNAME= fowsr-${FILEVER}
+USE_GITHUB= yes
+GH_ACCOUNT= apachler
+GH_PROJECT= fowsr
+GH_TAGNAME= 571db38
MAINTAINER= netchild@FreeBSD.org
COMMENT= Fine Offset Weather Station Reader
LICENSE= GPLv3
-BROKEN= Unfetchable (google code has gone away)
-
-FILEVER= 1.0
-FILEDATE= 20100718
-WRKSRC= ${WRKDIR}/${PORTNAME}-${FILEVER}
+FILEVER= 2.0
+WRKSRC= ${WRKDIR}/${PORTNAME}-${GH_TAGNAME}/${PORTNAME}.src
USES= gmake dos2unix
diff --git a/astro/fowsr/distinfo b/astro/fowsr/distinfo
index fdcaca28e17a..a45e209e299b 100644
--- a/astro/fowsr/distinfo
+++ b/astro/fowsr/distinfo
@@ -1,2 +1,3 @@
-SHA256 (fowsr-1.0-20100718.tar.gz) = ec43baea6bfe4523f8b5badd62c0adea239012a9bdd4c0d4d0c3fbc1a3e6ecbb
-SIZE (fowsr-1.0-20100718.tar.gz) = 35716
+TIMESTAMP = 1474280139
+SHA256 (fowsr-2.0_GH0.tar.gz) = ae18078b948037576217f83cbb86287f38e30e4f3a425b6cf8e6f891b43e0623
+SIZE (fowsr-2.0_GH0.tar.gz) = 24288
diff --git a/astro/fowsr/files/patch-fowsr.c b/astro/fowsr/files/patch-fowsr.c
index 9e312de81977..d669ffc97906 100644
--- a/astro/fowsr/files/patch-fowsr.c
+++ b/astro/fowsr/files/patch-fowsr.c
@@ -1,43 +1,18 @@
---- fowsr.c.orig 2016-07-26 12:57:00 UTC
+--- fowsr.c.orig 2016-09-18 13:31:19 UTC
+++ fowsr.c
-@@ -110,13 +110,17 @@ int CUSB_Open(int vendor, int product)
-
- signal(SIGTERM, release_usb_device);
-
-+#ifdef LIBUSB_HAS_GET_DRIVER_NP
- ret = usb_get_driver_np(devh, 0, buf, sizeof(buf));
- printf("usb_get_driver_np returned %d\n", ret);
- if (ret == 0) {
- printf("interface 0 already claimed by driver \\'%s\\', attempting to detach it\n", buf);
-+#ifdef LIBUSB_HAS_DETACH_KERNEL_DRIVER_NP
- ret = usb_detach_kernel_driver_np(devh, 0);
- printf("usb_detach_kernel_driver_np returned %d\n", ret);
-+#endif
- }
-+#endif
- ret = usb_claim_interface(devh, 0);
- if (ret != 0) {
- printf("claim failed with error %d\n", ret);
-@@ -159,12 +163,14 @@ void CWS_Cache(char isStoring)
- FILE* f;
- if (isStoring == ISREADING) {
+@@ -321,6 +321,7 @@ void CWS_Cache(char isStoring)
+
+ if (isStoring == WS_CACHE_READ) {
if (f=fopen(fname,"rb")) {
-+ printf("using cache file %s\n", fname);
++ printf("using cache file %s\n", fname);
n=fread(&m_previous_timestamp,sizeof(m_previous_timestamp),1,f);
n=fread(m_buf,sizeof(m_buf[0]),WS_BUFFER_SIZE,f);
}
- print_bytes((char *)&m_previous_timestamp, sizeof(time_t));
- } else { // ISWRITING
- if (f=fopen(fname,"wb")) {
-+ printf("updating cache file %s\n", fname);
- n=fwrite(&m_timestamp,sizeof(m_timestamp),1,f);
- n=fwrite(m_buf,sizeof(m_buf[0]),WS_BUFFER_SIZE,f);
- }
-@@ -566,6 +572,7 @@ int CWF_Write(char arg,char* fname)
-
- FILE* f;
- if (f=fopen(fname,"a+s")) {
-+ printf("writing to %s\n", fname);
+@@ -691,6 +692,7 @@ int CWF_Write(char arg, const char* fnam
+ f = fopen(s1,"a+t");
+ if(!f)
+ return -1;
++ printf("writing to %s\n", s1);
+ }
- // Header
- switch (arg) {
+ if((old_pos==0)||(old_pos==0xFFFF)) //cachefile empty or empty eeprom was read
diff --git a/astro/fowsr/pkg-descr b/astro/fowsr/pkg-descr
index 355d637cc69b..e647cc4f0844 100644
--- a/astro/fowsr/pkg-descr
+++ b/astro/fowsr/pkg-descr
@@ -21,3 +21,5 @@ Rain data is then calculated per hour, day, week and month if data for these
periods exist. No further data processing is performed. This makes fowsr
very small and well suited for running in embedded devices at remote
locations.
+
+WWW: https://github.com/apachler/fowsr