aboutsummaryrefslogtreecommitdiff
path: root/astro/foxtrotgps
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-01-29 06:20:52 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-01-29 06:20:52 +0000
commit1a0e916b11b870660a51ab40a878b5cd376ad754 (patch)
tree547eba73f882e6cab86be6dae6f69e5e44a8cfe7 /astro/foxtrotgps
parent3fa339bc17ddb3989ea3a3031b578fbe4ba54031 (diff)
downloadports-1a0e916b11b870660a51ab40a878b5cd376ad754.tar.gz
ports-1a0e916b11b870660a51ab40a878b5cd376ad754.zip
FoxtrotGPS is a fork of Marcus Bauer's TangoGPS project, with a focus on
cooperation and fostering community innovation. It is a lightweight moving map application that can be used with or without a gps unit. By default, maps tiles are downloaded from the OpenStreetMap project, but other sources are available, and new ones may be added. Map areas may be downloaded and cached for use while offline. WWW: http://www.foxtrotgps.org PR: ports/154052 Submitted by: Craig Whipp <crwhipp@gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=268361
Diffstat (limited to 'astro/foxtrotgps')
-rw-r--r--astro/foxtrotgps/Makefile33
-rw-r--r--astro/foxtrotgps/distinfo2
-rw-r--r--astro/foxtrotgps/pkg-descr9
-rw-r--r--astro/foxtrotgps/pkg-plist53
4 files changed, 97 insertions, 0 deletions
diff --git a/astro/foxtrotgps/Makefile b/astro/foxtrotgps/Makefile
new file mode 100644
index 000000000000..aeabf03ce9ce
--- /dev/null
+++ b/astro/foxtrotgps/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: foxtrotgps
+# Date created: 15 January 2011
+# Whom: crwhipp
+#
+# $FreeBSD$
+#
+
+PORTNAME= foxtrotgps
+PORTVERSION= 1.0.0
+CATEGORIES= astro geography
+MASTER_SITES= http://www.foxtrotgps.org/releases/
+
+MAINTAINER= crwhipp@gmail.com
+COMMENT= A lightweight opensource gps moving map application
+
+LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
+ exif.12:${PORTSDIR}/graphics/libexif \
+ soup-2.4.1:${PORTSDIR}/devel/libsoup \
+ gps.19:${PORTSDIR}/astro/gpsd
+
+USE_AUTOTOOLS= automake aclocal libtool autoconf
+ACLOCAL_ARGS= --force
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+
+USE_GNOME= gtk20 gconf2 libxml2 intltool pkgconfig libglade2
+USE_SQLITE= 3
+INSTALLS_ICONS= yes
+
+MAN1= foxtrotgps.1 convert2gpx.1 convert2osm.1
+
+.include <bsd.port.mk>
diff --git a/astro/foxtrotgps/distinfo b/astro/foxtrotgps/distinfo
new file mode 100644
index 000000000000..8df7f9060f9d
--- /dev/null
+++ b/astro/foxtrotgps/distinfo
@@ -0,0 +1,2 @@
+SHA256 (foxtrotgps-1.0.0.tar.gz) = 24f789294ae4f4251adccdb5f0c677b3fd6dea9bce2b6a17497f87a0dc3d056a
+SIZE (foxtrotgps-1.0.0.tar.gz) = 521774
diff --git a/astro/foxtrotgps/pkg-descr b/astro/foxtrotgps/pkg-descr
new file mode 100644
index 000000000000..ab79bb82c822
--- /dev/null
+++ b/astro/foxtrotgps/pkg-descr
@@ -0,0 +1,9 @@
+FoxtrotGPS is a fork of Marcus Bauer's TangoGPS project, with a focus on
+cooperation and fostering community innovation. It is a lightweight moving
+map application that can be used with or without a gps unit. By default,
+maps tiles are downloaded from the OpenStreetMap project, but other sources
+are available, and new ones may be added.
+
+Map areas may be downloaded and cached for use while offline.
+
+WWW: http://www.foxtrotgps.org
diff --git a/astro/foxtrotgps/pkg-plist b/astro/foxtrotgps/pkg-plist
new file mode 100644
index 000000000000..fc32fbdb81c8
--- /dev/null
+++ b/astro/foxtrotgps/pkg-plist
@@ -0,0 +1,53 @@
+bin/convert2gpx
+bin/convert2osm
+bin/foxtrotgps
+bin/georss2foxtrotgps-poi
+lib/locale/bg/LC_MESSAGES/foxtrotgps.mo
+lib/locale/cs/LC_MESSAGES/foxtrotgps.mo
+lib/locale/de/LC_MESSAGES/foxtrotgps.mo
+lib/locale/es/LC_MESSAGES/foxtrotgps.mo
+lib/locale/fi/LC_MESSAGES/foxtrotgps.mo
+lib/locale/fr/LC_MESSAGES/foxtrotgps.mo
+lib/locale/hu/LC_MESSAGES/foxtrotgps.mo
+lib/locale/nl/LC_MESSAGES/foxtrotgps.mo
+lib/locale/ru/LC_MESSAGES/foxtrotgps.mo
+lib/locale/sk/LC_MESSAGES/foxtrotgps.mo
+share/applications/foxtrotgps.desktop
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/ChangeLog
+%%DOCSDIR%%/INSTALL
+%%DOCSDIR%%/NEWS
+%%DOCSDIR%%/README
+%%DOCSDIR%%/TODO
+%%DATADIR%%/foxtrotgps.glade
+share/pixmaps/foxtrotgps-friend.png
+share/pixmaps/foxtrotgps-myposition.png
+share/pixmaps/foxtrotgps-photo.png
+share/pixmaps/foxtrotgps-poi.png
+share/pixmaps/foxtrotgps-wp.png
+share/pixmaps/foxtrotgps.png
+@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%
+@dirrmtry share/applications
+@dirrmtry lib/locale/sk/LC_MESSAGES
+@dirrmtry lib/locale/sk
+@dirrmtry lib/locale/ru/LC_MESSAGES
+@dirrmtry lib/locale/ru
+@dirrmtry lib/locale/nl/LC_MESSAGES
+@dirrmtry lib/locale/nl
+@dirrmtry lib/locale/hu/LC_MESSAGES
+@dirrmtry lib/locale/hu
+@dirrmtry lib/locale/fr/LC_MESSAGES
+@dirrmtry lib/locale/fr
+@dirrmtry lib/locale/fi/LC_MESSAGES
+@dirrmtry lib/locale/fi
+@dirrmtry lib/locale/es/LC_MESSAGES
+@dirrmtry lib/locale/es
+@dirrmtry lib/locale/de/LC_MESSAGES
+@dirrmtry lib/locale/de
+@dirrmtry lib/locale/cs/LC_MESSAGES
+@dirrmtry lib/locale/cs
+@dirrmtry lib/locale/bg/LC_MESSAGES
+@dirrmtry lib/locale/bg
+@dirrmtry lib/locale