aboutsummaryrefslogtreecommitdiff
path: root/astro/foxtrotgps
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-03-11 08:26:04 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-03-11 08:26:04 +0000
commit6bc7a46bf8d2cc7e2f336823c855cc84bd13d3a1 (patch)
tree1cd4ecc9e4a792d7203d5289e52d93e4d4eb7735 /astro/foxtrotgps
parent7544f5b40b76a74241e33c9a4df93a9bdf1a5441 (diff)
downloadports-6bc7a46bf8d2cc7e2f336823c855cc84bd13d3a1.tar.gz
ports-6bc7a46bf8d2cc7e2f336823c855cc84bd13d3a1.zip
astro/gpsd: Update to 3.20
- Update to 3.20 (welcome ubxtool and gpsrinex!) - Fix SConstruct per python3 [1] - Replace spaces by tabs (pet portlint) - Fixes astro/foxtrotgps, astro/gpxloggerd and comms/direwolf Changelog: - https://gitlab.com/gpsd/gpsd/-/blob/master/NEWS#L16 [1] scons is py27 only and check py27 packages for a py37 port. I commented these tests in SConstruct since we already do it in our Makefile. PR: 243980 Reviewed by: tcberner (mentor) Approved by: tcberner (mentor), maintainer timeout (z7dr6ut7gs@snkmail.com, > 2 weeks) Differential Revision: https://reviews.freebsd.org/D23920
Notes
Notes: svn path=/head/; revision=528219
Diffstat (limited to 'astro/foxtrotgps')
-rw-r--r--astro/foxtrotgps/Makefile2
-rw-r--r--astro/foxtrotgps/files/patch-src_gps__functions.c32
2 files changed, 33 insertions, 1 deletions
diff --git a/astro/foxtrotgps/Makefile b/astro/foxtrotgps/Makefile
index d6821cfe1e4c..c305e9df01cc 100644
--- a/astro/foxtrotgps/Makefile
+++ b/astro/foxtrotgps/Makefile
@@ -3,7 +3,7 @@
PORTNAME= foxtrotgps
PORTVERSION= 1.2.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= astro geography
MASTER_SITES= http://www.foxtrotgps.org/releases/
diff --git a/astro/foxtrotgps/files/patch-src_gps__functions.c b/astro/foxtrotgps/files/patch-src_gps__functions.c
new file mode 100644
index 000000000000..66c22bcacfea
--- /dev/null
+++ b/astro/foxtrotgps/files/patch-src_gps__functions.c
@@ -0,0 +1,32 @@
+--- src/gps_functions.c.orig 2020-03-05 17:21:38 UTC
++++ src/gps_functions.c
+@@ -735,6 +735,11 @@ cb_gpsd_io_error(GIOChannel *src, GIOCondition conditi
+ }
+
+
++static double
++timespec_to_double(struct timespec ts)
++{
++ return ((double)(ts.tv_sec) + ((double)(ts.tv_nsec) / 1e9));
++}
+
+ static gboolean
+ cb_gpsd_data(GIOChannel *src, GIOCondition condition, gpointer data)
+@@ -744,7 +749,7 @@ cb_gpsd_data(GIOChannel *src, GIOCondition condition,
+ if (!libgps_initialized)
+ return FALSE;
+
+- ret = gps_read(&libgps_gpsdata);
++ ret = gps_read(&libgps_gpsdata, NULL, 0);
+ /* Note that gps_read() will never actually return 0
+ (zero-length reads are converted internally to a -1 return,
+ since they mean that the connection to the daemon has closed),
+@@ -755,7 +760,7 @@ cb_gpsd_data(GIOChannel *src, GIOCondition condition,
+ {
+ gpsdata->satellites_used = libgps_gpsdata.satellites_used;
+ gpsdata->hdop = libgps_gpsdata.dop.hdop;
+- gpsdata->fix.time = libgps_gpsdata.fix.time;
++ gpsdata->fix.time = timespec_to_double(libgps_gpsdata.fix.time);
+ if (isnan(gpsdata->fix.time))
+ {
+ gpsdata->fix.time = (time_t) 0;