aboutsummaryrefslogtreecommitdiff
path: root/astro/geographiclib/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-15 14:57:01 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-15 14:57:01 +0000
commitc19baf495c7ef1df13aa0cd50296fb3779e509c7 (patch)
tree3396214af4728d6e495a322cdd5ebbb8f2aa9ba6 /astro/geographiclib/Makefile
parent7f0f664d7e0d5fbb1fd0e1cc45d4b413f66c97ae (diff)
downloadports-c19baf495c7ef1df13aa0cd50296fb3779e509c7.tar.gz
ports-c19baf495c7ef1df13aa0cd50296fb3779e509c7.zip
Notes
Diffstat (limited to 'astro/geographiclib/Makefile')
-rw-r--r--astro/geographiclib/Makefile28
1 files changed, 12 insertions, 16 deletions
diff --git a/astro/geographiclib/Makefile b/astro/geographiclib/Makefile
index 30e3c7a6761e..0f43d0601801 100644
--- a/astro/geographiclib/Makefile
+++ b/astro/geographiclib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= geographiclib
-PORTVERSION= 1.44
+PORTVERSION= 1.45
CATEGORIES= astro
MASTER_SITES= SF/geographiclib/distrib\
SF/geographiclib:geoids,gravity,magnetic
@@ -14,6 +14,7 @@ MAINTAINER= tatsuki_makino@hotmail.com
COMMENT= Library for geographic projections
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/ax_check_compile_flag.m4:${PORTSDIR}/devel/autoconf-archive
@@ -50,21 +51,18 @@ MAGNETIC_NAMES= wmm2010 wmm2015 igrf11 igrf12 emm2010 emm2015
GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} geoid dataset
OPTIONS_GROUP_DATASETS+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= geoids-distrib/${n}.tar.bz2:geoids
-MAKESUM_DISTFILES+= geoids-distrib/${n}.tar.bz2:geoids
MAKESUM_OPTIONS_DEFAULT+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
.endfor
.for n in ${GRAVITY_NAMES}
GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} gravity model
OPTIONS_GROUP_DATASETS+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= gravity-distrib/${n}.tar.bz2:gravity
-MAKESUM_DISTFILES+= gravity-distrib/${n}.tar.bz2:gravity
MAKESUM_OPTIONS_DEFAULT+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
.endfor
.for n in ${MAGNETIC_NAMES}
MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} magnetic model
OPTIONS_GROUP_DATASETS+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= magnetic-distrib/${n}.tar.bz2:magnetic
-MAKESUM_DISTFILES+= magnetic-distrib/${n}.tar.bz2:magnetic
MAKESUM_OPTIONS_DEFAULT+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
.endfor
@@ -73,12 +71,20 @@ MAKESUM_OPTIONS_DEFAULT+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
OPTIONS_DEFAULT= ${MAKESUM_OPTIONS_DEFAULT}
.endif
-.include <bsd.port.options.mk>
-
post-patch:
${REINPLACE_CMD} -e '/wget/s/wget -O/fetch -o /'\
${WRKSRC}/tools/geographiclib-get-*.sh
+.for n in ${GEOID_NAMES}
+post-install-GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}-on: install-datasets-geoids
+.endfor
+.for n in ${GRAVITY_NAMES}
+post-install-GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}-on: install-datasets-gravity
+.endfor
+.for n in ${MAGNETIC_NAMES}
+post-install-MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}-on: install-datasets-magnetic
+.endfor
+
.for n in geoids gravity magnetic
install-datasets-${n}: .NOTMAIN
${MKDIR} ${STAGEDIR}${DATADIR}/${n}
@@ -87,16 +93,6 @@ install-datasets-${n}: .NOTMAIN
.PHONY: install-datasets-${n}
.endfor
-.if ${PORT_OPTIONS:MGEOID_*}
-post-install: install-datasets-geoids
-.endif
-.if ${PORT_OPTIONS:MGRAVITY_*}
-post-install: install-datasets-gravity
-.endif
-.if ${PORT_OPTIONS:MMAGNETIC_*}
-post-install: install-datasets-magnetic
-.endif
-
.PHONY: x-tool-plist
x-tool-plist: ${PLIST} .NOTMAIN
${REINPLACE_CMD}\