aboutsummaryrefslogtreecommitdiff
path: root/astro/geographiclib
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-10-22 16:54:06 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-10-22 16:54:06 +0000
commit667b36b3c0e7d9676ad4a362a158acb48bfe0592 (patch)
tree5aaa0569dd95112c142e52843429bc50602d9fff /astro/geographiclib
parent290391b45393585948bea1bd490d347cfbf68de2 (diff)
downloadports-667b36b3c0e7d9676ad4a362a158acb48bfe0592.tar.gz
ports-667b36b3c0e7d9676ad4a362a158acb48bfe0592.zip
astro/geographiclib: Add IGRF-13 dataset
PR: 250445 Submitted by: Tatsuki Makino <tatsuki_makino@hotmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=552996
Diffstat (limited to 'astro/geographiclib')
-rw-r--r--astro/geographiclib/Makefile35
-rw-r--r--astro/geographiclib/distinfo4
-rw-r--r--astro/geographiclib/pkg-plist2
3 files changed, 29 insertions, 12 deletions
diff --git a/astro/geographiclib/Makefile b/astro/geographiclib/Makefile
index 0f7ecf2b1bc5..4fa6e0408b41 100644
--- a/astro/geographiclib/Makefile
+++ b/astro/geographiclib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= geographiclib
DISTVERSION= 1.50.1
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= SF/geographiclib/distrib\
SF/geographiclib/distrib/archive\
@@ -26,9 +27,7 @@ CMAKE_ARGS= -DGEOGRAPHICLIB_DATA:STRING=${DATADIR:Q}\
-DINSTALL_DOC_DIR:STRING=${DOCSDIR:Q}
OPTIONS_DEFINE= DOCS DOXYGEN PERL
-OPTIONS_DEFAULT= DOXYGEN PERL\
- GEOID_EGM96_5 GRAVITY_EGM96 GRAVITY_WGS84\
- MAGNETIC_WMM2020 MAGNETIC_IGRF12
+OPTIONS_DEFAULT= DOXYGEN PERL
PERL_DESC= Build documentation with pod2man and pod2html
OPTIONS_GROUP= DATASETS
OPTIONS_SUB= yes
@@ -45,8 +44,11 @@ GEOID_NAMES= egm84-30 egm84-15 egm96-15 egm96-5\
egm2008-5 egm2008-2_5 egm2008-1
GRAVITY_NAMES= egm84 egm96 egm2008 wgs84 grs80
MAGNETIC_NAMES= wmm2010 wmm2015 wmm2015v2 wmm2020\
- igrf11 igrf12\
+ igrf11 igrf12 igrf13\
emm2010 emm2015 emm2017
+DEFAULT_GEOID_NAMES= egm96-5
+DEFAULT_GRAVITY_NAMES= egm96 wgs84
+DEFAULT_MAGNETIC_NAMES= wmm2020 igrf12
DEPRECATED_NAMES= wmm2015
.for n in ${GEOID_NAMES}
@@ -54,25 +56,37 @@ GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} geoid dataset\
${"${DEPRECATED_NAMES:M${n}}"!="":?(deprecated):}
OPTIONS_GROUP_DATASETS+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= geoids-distrib/${n}.tar.bz2:geoids
-MAKESUM_OPTIONS_DEFAULT+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+ALL_DATASETS_OPTIONS+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+. if !empty(DEFAULT_GEOID_NAMES:M${n})
+DEF_DATASETS_OPTIONS+= GEOID_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+. endif
.endfor
.for n in ${GRAVITY_NAMES}
GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} gravity model\
${"${DEPRECATED_NAMES:M${n}}"!="":?(deprecated):}
OPTIONS_GROUP_DATASETS+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= gravity-distrib/${n}.tar.bz2:gravity
-MAKESUM_OPTIONS_DEFAULT+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+ALL_DATASETS_OPTIONS+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+. if !empty(DEFAULT_GRAVITY_NAMES:M${n})
+DEF_DATASETS_OPTIONS+= GRAVITY_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+. endif
.endfor
.for n in ${MAGNETIC_NAMES}
MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DESC= Install ${n} magnetic model\
${"${DEPRECATED_NAMES:M${n}}"!="":?(deprecated):}
OPTIONS_GROUP_DATASETS+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}_DISTFILES= magnetic-distrib/${n}.tar.bz2:magnetic
-MAKESUM_OPTIONS_DEFAULT+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+ALL_DATASETS_OPTIONS+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+. if !empty(DEFAULT_MAGNETIC_NAMES:M${n})
+DEF_DATASETS_OPTIONS+= MAGNETIC_${n:C/[^0-9A-Z_a-z]/_/g:tu}
+. endif
.endfor
-.ifmake makesum || distclean
-OPTIONS_DEFAULT= ${MAKESUM_OPTIONS_DEFAULT}
+.ifmake makesum || makeplist || distclean
+OPTIONS_DEFAULT+= ${ALL_DATASETS_OPTIONS}
+_OPTIONS_OK= yes # to prevent recursive execution
+.else
+OPTIONS_DEFAULT+= ${DEF_DATASETS_OPTIONS}
.endif
post-patch:
@@ -100,8 +114,7 @@ install-datasets-${n}: .NOTMAIN
.PHONY: install-datasets-${n}
.endfor
-.PHONY: x-tool-plist
-x-tool-plist: ${PLIST} .NOTMAIN
+x-tool-plist: .NOTMAIN .PHONY ${PLIST}
${REINPLACE_CMD}\
-e '/^%%PORTDOCS%%/d'\
-e '/^%%DATADIR%%\/geoids\/[^.]/{\
diff --git a/astro/geographiclib/distinfo b/astro/geographiclib/distinfo
index 0327f4374542..8aead291686b 100644
--- a/astro/geographiclib/distinfo
+++ b/astro/geographiclib/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1581822000
+TIMESTAMP = 1603076400
SHA256 (GeographicLib/GeographicLib-1.50.1.tar.gz) = d1765009e068b8cc5e76957e5d6be45ce6cff08c4aad8e5995e84a28354385f1
SIZE (GeographicLib/GeographicLib-1.50.1.tar.gz) = 2463854
SHA256 (GeographicLib/geoids-distrib/egm2008-1.tar.bz2) = bdb382d0be7ece9142450eacc24b7b7f0889ee3e0ba4f535b04ec383f94c0fb5
@@ -35,6 +35,8 @@ SHA256 (GeographicLib/magnetic-distrib/igrf11.tar.bz2) = 1289557fe660052c8fb42eb
SIZE (GeographicLib/magnetic-distrib/igrf11.tar.bz2) = 6011
SHA256 (GeographicLib/magnetic-distrib/igrf12.tar.bz2) = fbad03ea24d9aa87e2fbc0179ea7f8a4787f235a2ec360abe42cd312000cba3f
SIZE (GeographicLib/magnetic-distrib/igrf12.tar.bz2) = 6640
+SHA256 (GeographicLib/magnetic-distrib/igrf13.tar.bz2) = 74a9467fcdb2f210903221fe9d780ac0eed39dd3c87e4995e537a382cbe4daee
+SIZE (GeographicLib/magnetic-distrib/igrf13.tar.bz2) = 7210
SHA256 (GeographicLib/magnetic-distrib/wmm2010.tar.bz2) = a40aced2d5d36b3183f3efc759820d16a7daab81a33a0b81db0510e8d17dbb5e
SIZE (GeographicLib/magnetic-distrib/wmm2010.tar.bz2) = 1442
SHA256 (GeographicLib/magnetic-distrib/wmm2015.tar.bz2) = 4c3fddb09955bbb556a955d81580af89172d8b630b54b45e1b2fabc194ec474f
diff --git a/astro/geographiclib/pkg-plist b/astro/geographiclib/pkg-plist
index e758216b6f43..f06d21127c7f 100644
--- a/astro/geographiclib/pkg-plist
+++ b/astro/geographiclib/pkg-plist
@@ -142,6 +142,8 @@ sbin/geographiclib-get-magnetic
%%MAGNETIC_IGRF11%%%%DATADIR%%/magnetic/igrf11.wmm.cof
%%MAGNETIC_IGRF12%%%%DATADIR%%/magnetic/igrf12.wmm
%%MAGNETIC_IGRF12%%%%DATADIR%%/magnetic/igrf12.wmm.cof
+%%MAGNETIC_IGRF13%%%%DATADIR%%/magnetic/igrf13.wmm
+%%MAGNETIC_IGRF13%%%%DATADIR%%/magnetic/igrf13.wmm.cof
%%MAGNETIC_WMM2010%%%%DATADIR%%/magnetic/wmm2010.wmm
%%MAGNETIC_WMM2010%%%%DATADIR%%/magnetic/wmm2010.wmm.cof
%%MAGNETIC_WMM2015%%%%DATADIR%%/magnetic/wmm2015.wmm