aboutsummaryrefslogtreecommitdiff
path: root/astro/gnuastro
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-04-01 15:13:05 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-04-01 15:13:05 +0000
commit1f7a89fb46151ab836c8c12f387e4132c2c2ef72 (patch)
treefa8409c24399aa3bb2305e01bbbf4c9f2edcf574 /astro/gnuastro
parent99ca906e3038a3c8bf1c468e9c2ae459907aaed5 (diff)
downloadports-1f7a89fb46151ab836c8c12f387e4132c2c2ef72.tar.gz
ports-1f7a89fb46151ab836c8c12f387e4132c2c2ef72.zip
The GNU Astronomy Utilities (Gnuastro) is an official GNU software package
consisting of various programs and library functions for the manipulation and analysis of astronomical data. WWW: http://www.gnu.org/software/gnuastro/
Notes
Notes: svn path=/head/; revision=497484
Diffstat (limited to 'astro/gnuastro')
-rw-r--r--astro/gnuastro/Makefile45
-rw-r--r--astro/gnuastro/distinfo3
-rw-r--r--astro/gnuastro/pkg-descr8
-rw-r--r--astro/gnuastro/pkg-plist104
4 files changed, 160 insertions, 0 deletions
diff --git a/astro/gnuastro/Makefile b/astro/gnuastro/Makefile
new file mode 100644
index 000000000000..6bcc7b7bc7fc
--- /dev/null
+++ b/astro/gnuastro/Makefile
@@ -0,0 +1,45 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gnuastro
+PORTVERSION= 0.8
+CATEGORIES= astro
+MASTER_SITES= GNU
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= GNU astronomy utilities and library
+
+LICENSE= GPLv3+
+
+LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
+ libwcs.so:astro/wcslib \
+ libcurl.so:ftp/curl \
+ libgsl.so:math/gsl \
+ libpng.so:graphics/png \
+ libtiff.so:graphics/tiff
+
+USES= gmake jpeg libtool:build localbase
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+TEST_TARGET= check
+
+INFO= ${PORTNAME}
+PORTDOCS= AUTHORS ChangeLog NEWS README THANKS
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,gcc,${CC},' ${WRKSRC}/bin/buildprog/buildprog.c
+ @${REINPLACE_CMD} -e 's,/bash,/sh,' ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e '31s,^,#include <time.h>,' \
+ ${WRKSRC}/lib/gnuastro/table.h
+
+post-install:
+ @${FIND} ${STAGEDIR}${PREFIX}/etc -name \*.conf \
+ -exec ${MV} '{}' '{}.sample' \;
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/astro/gnuastro/distinfo b/astro/gnuastro/distinfo
new file mode 100644
index 000000000000..31717fd1db06
--- /dev/null
+++ b/astro/gnuastro/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1553427026
+SHA256 (gnuastro-0.8.tar.gz) = 3a8070f9dd896a463f1d898be82b1fe5abcd39e6407be9162f4dbea7fe9caed4
+SIZE (gnuastro-0.8.tar.gz) = 5140848
diff --git a/astro/gnuastro/pkg-descr b/astro/gnuastro/pkg-descr
new file mode 100644
index 000000000000..fd4c497f37d7
--- /dev/null
+++ b/astro/gnuastro/pkg-descr
@@ -0,0 +1,8 @@
+The GNU Astronomy Utilities (Gnuastro) is an official GNU software package
+consisting of various programs and library functions for the manipulation
+and analysis of astronomical data. All the programs share the same basic
+command-line user interface enabling easy and efficient operation combined
+with other installed programs in shell scripts or Makefiles; the libraries
+are also usable in C and C++ programs.
+
+WWW: http://www.gnu.org/software/gnuastro/
diff --git a/astro/gnuastro/pkg-plist b/astro/gnuastro/pkg-plist
new file mode 100644
index 000000000000..940bad135a4d
--- /dev/null
+++ b/astro/gnuastro/pkg-plist
@@ -0,0 +1,104 @@
+bin/astarithmetic
+bin/astbuildprog
+bin/astconvertt
+bin/astconvolve
+bin/astcosmiccal
+bin/astcrop
+bin/astfits
+bin/astmatch
+bin/astmkcatalog
+bin/astmknoise
+bin/astmkprof
+bin/astnoisechisel
+bin/astsegment
+bin/aststatistics
+bin/asttable
+bin/astwarp
+@sample etc/astarithmetic.conf.sample
+@sample etc/astbuildprog.conf.sample
+@sample etc/astconvertt.conf.sample
+@sample etc/astconvolve.conf.sample
+@sample etc/astcosmiccal.conf.sample
+@sample etc/astcrop.conf.sample
+@sample etc/astfits.conf.sample
+@sample etc/astmatch.conf.sample
+@sample etc/astmkcatalog.conf.sample
+@sample etc/astmknoise.conf.sample
+@sample etc/astmkprof.conf.sample
+@sample etc/astnoisechisel.conf.sample
+@sample etc/astsegment.conf.sample
+@sample etc/aststatistics.conf.sample
+@sample etc/asttable.conf.sample
+@sample etc/astwarp.conf.sample
+@sample etc/gnuastro.conf.sample
+include/gnuastro/arithmetic.h
+include/gnuastro/array.h
+include/gnuastro/binary.h
+include/gnuastro/blank.h
+include/gnuastro/box.h
+include/gnuastro/config.h
+include/gnuastro/convolve.h
+include/gnuastro/cosmology.h
+include/gnuastro/data.h
+include/gnuastro/dimension.h
+include/gnuastro/eps.h
+include/gnuastro/fits.h
+include/gnuastro/git.h
+include/gnuastro/interpolate.h
+include/gnuastro/jpeg.h
+include/gnuastro/label.h
+include/gnuastro/list.h
+include/gnuastro/match.h
+include/gnuastro/pdf.h
+include/gnuastro/permutation.h
+include/gnuastro/pointer.h
+include/gnuastro/polygon.h
+include/gnuastro/qsort.h
+include/gnuastro/statistics.h
+include/gnuastro/table.h
+include/gnuastro/threads.h
+include/gnuastro/tiff.h
+include/gnuastro/tile.h
+include/gnuastro/txt.h
+include/gnuastro/type.h
+include/gnuastro/wcs.h
+lib/libgnuastro.a
+lib/libgnuastro.so
+lib/libgnuastro.so.6
+lib/libgnuastro.so.6.0.0
+libdata/pkgconfig/gnuastro.pc
+man/man1/astarithmetic.1.gz
+man/man1/astbuildprog.1.gz
+man/man1/astconvertt.1.gz
+man/man1/astconvolve.1.gz
+man/man1/astcosmiccal.1.gz
+man/man1/astcrop.1.gz
+man/man1/astfits.1.gz
+man/man1/astmatch.1.gz
+man/man1/astmkcatalog.1.gz
+man/man1/astmknoise.1.gz
+man/man1/astmkprof.1.gz
+man/man1/astnoisechisel.1.gz
+man/man1/astsegment.1.gz
+man/man1/aststatistics.1.gz
+man/man1/asttable.1.gz
+man/man1/astwarp.1.gz
+share/info/gnuastro-figures/epicycles.eps
+share/info/gnuastro-figures/epicycles.png
+share/info/gnuastro-figures/epicycles.txt
+share/info/gnuastro-figures/flatplane.eps
+share/info/gnuastro-figures/flatplane.pdf
+share/info/gnuastro-figures/flatplane.png
+share/info/gnuastro-figures/flatplane.txt
+share/info/gnuastro-figures/iandtime.eps
+share/info/gnuastro-figures/iandtime.pdf
+share/info/gnuastro-figures/iandtime.png
+share/info/gnuastro-figures/iandtime.txt
+share/info/gnuastro-figures/samplingfreq.eps
+share/info/gnuastro-figures/samplingfreq.pdf
+share/info/gnuastro-figures/samplingfreq.png
+share/info/gnuastro-figures/samplingfreq.txt
+share/info/gnuastro-figures/sphereandplane.eps
+share/info/gnuastro-figures/sphereandplane.pdf
+share/info/gnuastro-figures/sphereandplane.png
+share/info/gnuastro-figures/sphereandplane.txt