aboutsummaryrefslogtreecommitdiff
path: root/astro/gpstk
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2007-01-11 18:16:27 +0000
committerMax Khon <fjoe@FreeBSD.org>2007-01-11 18:16:27 +0000
commit5498a056d3e4d97fda1b1198cf8dc6f0614ae5f0 (patch)
treeaf3b10204fe838bf7332d01ae034e39a43a9f8ab /astro/gpstk
parent48617e032a8bb5bf2fc2700173fb43221935917f (diff)
downloadports-5498a056d3e4d97fda1b1198cf8dc6f0614ae5f0.tar.gz
ports-5498a056d3e4d97fda1b1198cf8dc6f0614ae5f0.zip
Remove strict dependency on gcc version (USE_GCC=3.4+).
Approved by: MAINTAINER
Notes
Notes: svn path=/head/; revision=182115
Diffstat (limited to 'astro/gpstk')
-rw-r--r--astro/gpstk/Makefile2
-rw-r--r--astro/gpstk/files/patch-apps-ionosphere-VTECMap.hpp18
-rw-r--r--astro/gpstk/files/patch-src-EpochClockModel.hpp20
-rw-r--r--astro/gpstk/files/patch-src-MatrixImplementation.hpp24
-rw-r--r--astro/gpstk/files/patch-src-MiscMath.hpp12
-rw-r--r--astro/gpstk/files/patch-src-getopt.c11
6 files changed, 86 insertions, 1 deletions
diff --git a/astro/gpstk/Makefile b/astro/gpstk/Makefile
index 6f90f0c21c6d..e7460251235d 100644
--- a/astro/gpstk/Makefile
+++ b/astro/gpstk/Makefile
@@ -17,7 +17,7 @@ COMMENT= Toolkit for developing GPS applications
BUILD_DEPENDS= ${LOCALBASE}/bin/jam:${PORTSDIR}/devel/jam
-USE_GCC= 3.4
+USE_GCC= 3.4+
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/astro/gpstk/files/patch-apps-ionosphere-VTECMap.hpp b/astro/gpstk/files/patch-apps-ionosphere-VTECMap.hpp
new file mode 100644
index 000000000000..625622c89655
--- /dev/null
+++ b/astro/gpstk/files/patch-apps-ionosphere-VTECMap.hpp
@@ -0,0 +1,18 @@
+--- apps/ionosphere/VTECMap.hpp.orig Thu Jan 11 21:38:35 2007
++++ apps/ionosphere/VTECMap.hpp Thu Jan 11 21:38:51 2007
+@@ -193,13 +193,13 @@
+ /// Compute the obliquity at a given elevation
+ /// @param el elevation in degrees
+ /// @return obliquity factor
+- double VTECMap::Obliquity(double el);
++ double Obliquity(double el);
+
+ protected:
+ /// Allocate the grid array and fill it.
+ /// @param refStation reference station
+ /// @param factor : 1 for VTEC maps, 2 for MUF maps
+- void VTECMap::reallyMakeGrid(Station& refStation, int factor)
++ void reallyMakeGrid(Station& refStation, int factor)
+ throw(Exception);
+
+ /// Compute one grid value, using all the data. Called by ComputeMap.
diff --git a/astro/gpstk/files/patch-src-EpochClockModel.hpp b/astro/gpstk/files/patch-src-EpochClockModel.hpp
new file mode 100644
index 000000000000..714308057750
--- /dev/null
+++ b/astro/gpstk/files/patch-src-EpochClockModel.hpp
@@ -0,0 +1,20 @@
+--- src/EpochClockModel.hpp.orig Thu Jan 11 21:39:06 2007
++++ src/EpochClockModel.hpp Thu Jan 11 21:39:26 2007
+@@ -67,7 +67,7 @@
+ PRNMode mode = ALWAYS)
+ :ObsClockModel(sigma, elmask, mode){}
+
+- virtual double EpochClockModel::getOffset(const gpstk::DayTime& t) const
++ virtual double getOffset(const gpstk::DayTime& t) const
+ throw(gpstk::InvalidArgumentException)
+ {
+ if (t!=time)
+@@ -92,7 +92,7 @@
+
+ // An unchecked accessor for programs that don't need the generic
+ // interface
+- double EpochClockModel::getOffset() const
++ double getOffset() const
+ throw() {return clkc;};
+
+ bool isOffsetValid() const
diff --git a/astro/gpstk/files/patch-src-MatrixImplementation.hpp b/astro/gpstk/files/patch-src-MatrixImplementation.hpp
new file mode 100644
index 000000000000..27cda0b1d923
--- /dev/null
+++ b/astro/gpstk/files/patch-src-MatrixImplementation.hpp
@@ -0,0 +1,24 @@
+--- src/MatrixImplementation.hpp.orig Thu Jan 11 21:31:51 2007
++++ src/MatrixImplementation.hpp Thu Jan 11 21:33:18 2007
+@@ -37,18 +37,18 @@
+ //@{
+
+ template <class T>
+- Matrix<T>::Matrix<T>()
++ Matrix<T>::Matrix()
+ : v((size_t)0), r(0), c(0), s(0)
+ {}
+
+
+ template <class T>
+- Matrix<T>::Matrix<T>(size_t rows, size_t cols)
++ Matrix<T>::Matrix(size_t rows, size_t cols)
+ : v(rows * cols), r(rows), c(cols), s(rows * cols)
+ {}
+
+ template <class T>
+- Matrix<T>::Matrix<T>(size_t rows, size_t cols,
++ Matrix<T>::Matrix(size_t rows, size_t cols,
+ T initialValue)
+ : v(rows * cols, initialValue), r(rows), c(cols), s(rows * cols)
+ {}
diff --git a/astro/gpstk/files/patch-src-MiscMath.hpp b/astro/gpstk/files/patch-src-MiscMath.hpp
new file mode 100644
index 000000000000..676594d022b3
--- /dev/null
+++ b/astro/gpstk/files/patch-src-MiscMath.hpp
@@ -0,0 +1,12 @@
+--- src/MiscMath.hpp.orig Thu Jan 11 21:29:49 2007
++++ src/MiscMath.hpp Thu Jan 11 21:30:37 2007
+@@ -145,6 +145,9 @@
+ }
+ } // end void LagrangeInterpolation(vector, vector, const T, T&, T&)
+
++ template <class T>
++ T RSS (T aa, T bb, T cc);
++
+ /// Perform the root sum square of aa, bb
+ template <class T>
+ T RSS (T aa, T bb)
diff --git a/astro/gpstk/files/patch-src-getopt.c b/astro/gpstk/files/patch-src-getopt.c
new file mode 100644
index 000000000000..36e3f6b2354e
--- /dev/null
+++ b/astro/gpstk/files/patch-src-getopt.c
@@ -0,0 +1,11 @@
+--- src/getopt.c.orig Thu Jan 11 21:34:50 2007
++++ src/getopt.c Thu Jan 11 21:36:24 2007
+@@ -31,7 +31,7 @@
+ # include <config.h>
+ #endif
+
+-#if defined(WIN32) || defined(_WIN32)
++#if defined(WIN32) || defined(_WIN32) || defined(__FreeBSD__)
+ #define HAVE_STRING_H 1
+ #endif
+