aboutsummaryrefslogtreecommitdiff
path: root/astro/gpstk
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-07-23 05:17:15 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-07-23 05:17:15 +0000
commit54d2419f770d22ea217e71357eeb15f7f2ac8342 (patch)
treee3be1fe14110541a6f895c74cc98fa462250df56 /astro/gpstk
parent316e3dbeed91ce2a7269c2f5093201e4e4f0869c (diff)
downloadports-54d2419f770d22ea217e71357eeb15f7f2ac8342.tar.gz
ports-54d2419f770d22ea217e71357eeb15f7f2ac8342.zip
- Stagify; unbreak the against Clang
- Allow for parallel (-jX) builds - Cleanup Makefile while I'm at here - Augment port description, fix WWW N.b., there's version 2.4 available.
Notes
Notes: svn path=/head/; revision=362621
Diffstat (limited to 'astro/gpstk')
-rw-r--r--astro/gpstk/Makefile39
-rw-r--r--astro/gpstk/files/patch-apps-swrx-IQStream.hpp12
-rw-r--r--astro/gpstk/pkg-descr10
3 files changed, 46 insertions, 15 deletions
diff --git a/astro/gpstk/Makefile b/astro/gpstk/Makefile
index b8e85cfc2ac4..f864ae72f868 100644
--- a/astro/gpstk/Makefile
+++ b/astro/gpstk/Makefile
@@ -1,4 +1,4 @@
-# Created by: bms@FreeBSD.org
+# Created by: Bruce M Simpson <bms@FreeBSD.org>
# $FreeBSD$
PORTNAME= gpstk
@@ -10,38 +10,51 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= ports@FreeBSD.org
COMMENT= Toolkit for developing GPS applications
-BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
+LICENSE= LGPL21
-WRKSRC= ${WRKDIR}/${PORTNAME}
+BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
USES= dos2unix
-NO_STAGE= yes
USE_PYTHON_RUN= yes
USE_LDCONFIG= yes
DOS2UNIX_FILES= ${WRKSRC}/Jamrules
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
JAM= jam
-JAM_ENV= PREFIX="${PREFIX}" \
- BINDIR="${PREFIX}/bin" \
- INCDIR="${PREFIX}/include/${PORTNAME}" \
- LIBDIR="${PREFIX}/lib" \
+JAM_ENV= PREFIX="${STAGEDIR}${PREFIX}" \
CC="${CC}" CCFLAGS="${CFLAGS}" \
C++="${CXX}" C++FLAGS="${CXXFLAGS}"
+post-patch:
+# Unbreak with modern C++ compilers (notably, Clang)
+ @${REINPLACE_CMD} -e 's,assignFrom(,this->&,' \
+ ${WRKSRC}/src/Vector.hpp ${WRKSRC}/src/Matrix.hpp
+ @${REINPLACE_CMD} -e 's,matSliceCheck(,this->&,' \
+ ${WRKSRC}/src/Matrix.hpp
+ @${REINPLACE_CMD} -e 's,addData(,this->&,' \
+ ${WRKSRC}/src/FileFilterFrame.hpp
+ @${REINPLACE_CMD} -e 's,float,double,' \
+ ${WRKSRC}/apps/swrx/gpsSim.cpp
+ @${REINPLACE_CMD} -e '/GPSEllipsoid gm/s,const ,,' \
+ ${WRKSRC}/apps/reszilla/ddGen.cpp
+
do-build:
- cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM}
+ cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM} ${_MAKE_JOBS}
NOSTRIPFILES= ddPlot|ordPlot # don't strip scripts
SHLIBS= geodyn geomatics gpstk procframe rxio vdraw vplot
-SHLIBVER= ${PORTVERSION:C/\.//g}
+SHLIBVER= ${PORTVERSION:S/.//g}
+
do-install:
- @${MKDIR} ${PREFIX}/include/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/${PORTNAME}
cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM} install
.for shlib in ${SHLIBS}
- @${LN} -sf lib${shlib}.so.${SHLIBVER} ${PREFIX}/lib/lib${shlib}.so
+ ${LN} -sf lib${shlib}.so.${SHLIBVER} \
+ ${STAGEDIR}${PREFIX}/lib/lib${shlib}.so
.endfor
@${STRIP_CMD} `${GREP} '^bin/' ${PLIST} | \
${GREP} -E -v '^bin/(${NOSTRIPFILES})$$' | \
- ${SED} 's:^:${PREFIX}/:g'`
+ ${SED} 's,^,${STAGEDIR}${PREFIX}/,'`
.include <bsd.port.mk>
diff --git a/astro/gpstk/files/patch-apps-swrx-IQStream.hpp b/astro/gpstk/files/patch-apps-swrx-IQStream.hpp
new file mode 100644
index 000000000000..779ab9c4c5ce
--- /dev/null
+++ b/astro/gpstk/files/patch-apps-swrx-IQStream.hpp
@@ -0,0 +1,12 @@
+--- apps/swrx/IQStream.hpp.orig 2012-06-27 22:22:33 +0800
++++ apps/swrx/IQStream.hpp
+@@ -130,6 +130,9 @@ namespace gpstk
+ inline IQStream& operator<<(IQStream& s, const std::complex<float>& v)
+ { s.writeComplex(v); return s; };
+
++ inline IQStream& operator<<(IQStream& s, const std::complex<double>& v)
++ { s.writeComplex(v); return s; };
++
+
+ class IQ1Stream : public IQStream
+ {
diff --git a/astro/gpstk/pkg-descr b/astro/gpstk/pkg-descr
index 71f5f483a40a..74a3b6ac7715 100644
--- a/astro/gpstk/pkg-descr
+++ b/astro/gpstk/pkg-descr
@@ -1,3 +1,9 @@
-The GPSTk is a C++ library for developing GPS applications.
+The GPSTk is an open source C++ library for developing GPS applications.
-WWW: http://gpstk.sourceforge.net/
+The GPSTk suite consists of a core library, auxiliary libraries, and a set
+of applications. The GPSTk provides a wide array of functions that solve
+processing problems associated with GNSS such as processing or using
+standard formats such as RINEX. The libraries are the basis for the more
+advanced applications distributed as part of the GPSTk suite.
+
+WWW: http://www.gpstk.org/