aboutsummaryrefslogtreecommitdiff
path: root/astro/gpstk
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2006-11-05 09:36:22 +0000
committerBruce M Simpson <bms@FreeBSD.org>2006-11-05 09:36:22 +0000
commit55b334e13d1926f1b31fdec17c47479d7dd2f2a5 (patch)
tree8e3142c56b4a11ecf05329d55a03c1d0f4b90f3a /astro/gpstk
parent892505fb2f9a623c29e29d49f7e442db4d220273 (diff)
downloadports-55b334e13d1926f1b31fdec17c47479d7dd2f2a5.tar.gz
ports-55b334e13d1926f1b31fdec17c47479d7dd2f2a5.zip
Fix include file installation.
Notes
Notes: svn path=/head/; revision=176453
Diffstat (limited to 'astro/gpstk')
-rw-r--r--astro/gpstk/Makefile1
-rw-r--r--astro/gpstk/files/patch-Jamrules19
-rw-r--r--astro/gpstk/pkg-plist226
3 files changed, 128 insertions, 118 deletions
diff --git a/astro/gpstk/Makefile b/astro/gpstk/Makefile
index a11283445a4c..3190a709338c 100644
--- a/astro/gpstk/Makefile
+++ b/astro/gpstk/Makefile
@@ -29,6 +29,7 @@ do-build:
cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM}
do-install:
+ ${MKDIR} ${PREFIX}/include/gpstk
cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM} install
.include <bsd.port.mk>
diff --git a/astro/gpstk/files/patch-Jamrules b/astro/gpstk/files/patch-Jamrules
index cf6ae9b2dbb6..b2af4fae9dee 100644
--- a/astro/gpstk/files/patch-Jamrules
+++ b/astro/gpstk/files/patch-Jamrules
@@ -1,5 +1,5 @@
--- Jamrules.orig Wed Jan 19 19:36:30 2005
-+++ Jamrules Thu May 12 15:29:05 2005
++++ Jamrules Sun Nov 5 09:33:26 2006
@@ -9,7 +9,7 @@
KEEPOBJS = true ;
@@ -9,14 +9,23 @@
# override the built-in EXEMODE
EXEMODE = 755 ;
-@@ -29,6 +29,10 @@
- {
+@@ -30,6 +30,10 @@
case CYGWIN :
LINKLIBS += -lstdc++ ;
-+
+
+ case FREEBSD :
+ LINKLIBS += -lstdc++ ;
+ CCSHARE_FLAGS = -fPIC ;
-
++
case LINUX :
LINKLIBS += -lstdc++ ;
+ CCSHARE_FLAGS = -fPIC ;
+@@ -81,7 +85,7 @@
+ # fix does this need to be forward/backslash independent? darn windows.
+ BINDIR = [ FDirName $(PREFIX) bin ] ;
+ LIBDIR = [ FDirName $(PREFIX) lib ] ;
+- INCDIR = [ FDirName $(PREFIX) include ] ;
++ INCDIR = [ FDirName $(PREFIX) include/gpstk ] ;
+ }
+
+ # debug - edit this as needed.
diff --git a/astro/gpstk/pkg-plist b/astro/gpstk/pkg-plist
index f313bf52ef32..5857442e8de3 100644
--- a/astro/gpstk/pkg-plist
+++ b/astro/gpstk/pkg-plist
@@ -1,118 +1,118 @@
lib/libgpstk.so
lib/libgpstk.a
-include/stl_helpers.hpp
-include/icd_200_constants.hpp
-include/gpstk/
-include/gps_constants.hpp
-include/getopt.h
-include/geometry.hpp
-include/convhelp.hpp
-include/Xvt.hpp
-include/X2Sequence.hpp
-include/X1Sequence.hpp
-include/WGS84Geoid.hpp
-include/VectorOperators.hpp
-include/VectorBaseOperators.hpp
-include/VectorBase.hpp
-include/Vector.hpp
-include/ValidType.hpp
-include/TropModel.hpp
-include/Triple.hpp
-include/TabularEphemerisStore.hpp
-include/StringUtils.hpp
-include/Stats.hpp
-include/SatID.hpp
-include/SVPCodeGen.hpp
-include/SP3Stream.hpp
-include/SP3Header.hpp
-include/SP3EphemerisStore.hpp
-include/SP3Data.hpp
-include/SP3Base.hpp
-include/SMODFStream.hpp
-include/SMODFData.hpp
-include/RungeKutta4.hpp
-include/RinexObsStream.hpp
-include/RinexObsHeader.hpp
-include/RinexObsFilterOperators.hpp
-include/RinexObsData.hpp
-include/RinexObsBase.hpp
-include/RinexNavStream.hpp
-include/RinexNavHeader.hpp
-include/RinexNavFilterOperators.hpp
-include/RinexNavData.hpp
-include/RinexNavBase.hpp
-include/RinexMetStream.hpp
-include/RinexMetHeader.hpp
-include/RinexMetFilterOperators.hpp
-include/RinexMetData.hpp
-include/RinexMetBase.hpp
-include/RinexEphemerisStore.hpp
-include/RTFileFrame.hpp
-include/RAIMSolution.hpp
-include/Position.hpp
-include/PolyFit.hpp
-include/PCodeConst.hpp
-include/ObservationStore.hpp
-include/ObsRngDev.hpp
-include/ObsClockModel.hpp
-include/ORDEpoch.hpp
-include/MiscMath.hpp
-include/MatrixOperators.hpp
-include/MatrixImplementation.hpp
-include/MatrixFunctors.hpp
-include/MatrixBaseOperators.hpp
-include/MatrixBase.hpp
-include/Matrix.hpp
-include/MathBase.hpp
-include/MSCStream.hpp
-include/MSCData.hpp
-include/LoopedFramework.hpp
-include/LinearClockModel.hpp
-include/IonoModelStore.hpp
-include/IonoModel.hpp
-include/GeoidModel.hpp
-include/Geodetic.hpp
-include/GenXSequence.hpp
-include/GPSZcount.hpp
-include/GPSGeoid.hpp
-include/FileUtils.hpp
-include/FileStore.hpp
-include/FileSpec.hpp
-include/FileHunter.hpp
-include/FileFilterFrameWithHeader.hpp
-include/FileFilterFrame.hpp
-include/FileFilter.hpp
-include/FICStreamBase.hpp
-include/FICStream.hpp
-include/FICHeader.hpp
-include/FICFilterOperators.hpp
-include/FICData.hpp
-include/FICBase.hpp
-include/FICAStream.hpp
-include/FFTextStream.hpp
-include/FFStreamError.hpp
-include/FFStream.hpp
-include/FFData.hpp
-include/FFBinaryStream.hpp
-include/Exception.hpp
-include/EpochClockModel.hpp
-include/EphemerisStore.hpp
-include/EphemerisRange.hpp
-include/EngNav.hpp
-include/EngEphemeris.hpp
-include/EngAlmanac.hpp
-include/ECEF.hpp
-include/DayTime.hpp
-include/CommandOptionWithTimeArg.hpp
-include/CommandOptionParser.hpp
-include/CommandOption.hpp
-include/CodeBuffer.hpp
-include/ClockModel.hpp
-include/BinUtils.hpp
-include/BasicFramework.hpp
-include/BCEphemerisStore.hpp
-include/AlmanacStore.hpp
-include/AlmOrbit.hpp
+include/gpstk/stl_helpers.hpp
+include/gpstk/icd_200_constants.hpp
+include/gpstk/gps_constants.hpp
+include/gpstk/getopt.h
+include/gpstk/geometry.hpp
+include/gpstk/convhelp.hpp
+include/gpstk/Xvt.hpp
+include/gpstk/X2Sequence.hpp
+include/gpstk/X1Sequence.hpp
+include/gpstk/WGS84Geoid.hpp
+include/gpstk/VectorOperators.hpp
+include/gpstk/VectorBaseOperators.hpp
+include/gpstk/VectorBase.hpp
+include/gpstk/Vector.hpp
+include/gpstk/ValidType.hpp
+include/gpstk/TropModel.hpp
+include/gpstk/Triple.hpp
+include/gpstk/TabularEphemerisStore.hpp
+include/gpstk/StringUtils.hpp
+include/gpstk/Stats.hpp
+include/gpstk/SatID.hpp
+include/gpstk/SVPCodeGen.hpp
+include/gpstk/SP3Stream.hpp
+include/gpstk/SP3Header.hpp
+include/gpstk/SP3EphemerisStore.hpp
+include/gpstk/SP3Data.hpp
+include/gpstk/SP3Base.hpp
+include/gpstk/SMODFStream.hpp
+include/gpstk/SMODFData.hpp
+include/gpstk/RungeKutta4.hpp
+include/gpstk/RinexObsStream.hpp
+include/gpstk/RinexObsHeader.hpp
+include/gpstk/RinexObsFilterOperators.hpp
+include/gpstk/RinexObsData.hpp
+include/gpstk/RinexObsBase.hpp
+include/gpstk/RinexNavStream.hpp
+include/gpstk/RinexNavHeader.hpp
+include/gpstk/RinexNavFilterOperators.hpp
+include/gpstk/RinexNavData.hpp
+include/gpstk/RinexNavBase.hpp
+include/gpstk/RinexMetStream.hpp
+include/gpstk/RinexMetHeader.hpp
+include/gpstk/RinexMetFilterOperators.hpp
+include/gpstk/RinexMetData.hpp
+include/gpstk/RinexMetBase.hpp
+include/gpstk/RinexEphemerisStore.hpp
+include/gpstk/RTFileFrame.hpp
+include/gpstk/RAIMSolution.hpp
+include/gpstk/Position.hpp
+include/gpstk/PolyFit.hpp
+include/gpstk/PCodeConst.hpp
+include/gpstk/ObservationStore.hpp
+include/gpstk/ObsRngDev.hpp
+include/gpstk/ObsClockModel.hpp
+include/gpstk/ORDEpoch.hpp
+include/gpstk/MiscMath.hpp
+include/gpstk/MatrixOperators.hpp
+include/gpstk/MatrixImplementation.hpp
+include/gpstk/MatrixFunctors.hpp
+include/gpstk/MatrixBaseOperators.hpp
+include/gpstk/MatrixBase.hpp
+include/gpstk/Matrix.hpp
+include/gpstk/MathBase.hpp
+include/gpstk/MSCStream.hpp
+include/gpstk/MSCData.hpp
+include/gpstk/LoopedFramework.hpp
+include/gpstk/LinearClockModel.hpp
+include/gpstk/IonoModelStore.hpp
+include/gpstk/IonoModel.hpp
+include/gpstk/GeoidModel.hpp
+include/gpstk/Geodetic.hpp
+include/gpstk/GenXSequence.hpp
+include/gpstk/GPSZcount.hpp
+include/gpstk/GPSGeoid.hpp
+include/gpstk/FileUtils.hpp
+include/gpstk/FileStore.hpp
+include/gpstk/FileSpec.hpp
+include/gpstk/FileHunter.hpp
+include/gpstk/FileFilterFrameWithHeader.hpp
+include/gpstk/FileFilterFrame.hpp
+include/gpstk/FileFilter.hpp
+include/gpstk/FICStreamBase.hpp
+include/gpstk/FICStream.hpp
+include/gpstk/FICHeader.hpp
+include/gpstk/FICFilterOperators.hpp
+include/gpstk/FICData.hpp
+include/gpstk/FICBase.hpp
+include/gpstk/FICAStream.hpp
+include/gpstk/FFTextStream.hpp
+include/gpstk/FFStreamError.hpp
+include/gpstk/FFStream.hpp
+include/gpstk/FFData.hpp
+include/gpstk/FFBinaryStream.hpp
+include/gpstk/Exception.hpp
+include/gpstk/EpochClockModel.hpp
+include/gpstk/EphemerisStore.hpp
+include/gpstk/EphemerisRange.hpp
+include/gpstk/EngNav.hpp
+include/gpstk/EngEphemeris.hpp
+include/gpstk/EngAlmanac.hpp
+include/gpstk/ECEF.hpp
+include/gpstk/DayTime.hpp
+include/gpstk/CommandOptionWithTimeArg.hpp
+include/gpstk/CommandOptionParser.hpp
+include/gpstk/CommandOption.hpp
+include/gpstk/CodeBuffer.hpp
+include/gpstk/ClockModel.hpp
+include/gpstk/BinUtils.hpp
+include/gpstk/BasicFramework.hpp
+include/gpstk/BCEphemerisStore.hpp
+include/gpstk/AlmanacStore.hpp
+include/gpstk/AlmOrbit.hpp
+@dirrm include/gpstk
bin/timcvt
bin/stringutiltest
bin/rowdiff