aboutsummaryrefslogtreecommitdiff
path: root/astro/gpstk
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2007-01-10 20:02:08 +0000
committerBruce M Simpson <bms@FreeBSD.org>2007-01-10 20:02:08 +0000
commita975d59953c4734c09432e15f54821d96939a96f (patch)
treedf9448cb9347f4f0a456578737883f4935d5db4a /astro/gpstk
parentb108b01c92248629632eb92856b6e82bfdcb6b44 (diff)
downloadports-a975d59953c4734c09432e15f54821d96939a96f.tar.gz
ports-a975d59953c4734c09432e15f54821d96939a96f.zip
Mark as requiring gcc 3.4.x; 4.x is not supported by gpstk.
Pass CC and CXX into Jam environment as appropriate.
Notes
Notes: svn path=/head/; revision=182010
Diffstat (limited to 'astro/gpstk')
-rw-r--r--astro/gpstk/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/astro/gpstk/Makefile b/astro/gpstk/Makefile
index 0f037164a89d..6f90f0c21c6d 100644
--- a/astro/gpstk/Makefile
+++ b/astro/gpstk/Makefile
@@ -17,14 +17,15 @@ COMMENT= Toolkit for developing GPS applications
BUILD_DEPENDS= ${LOCALBASE}/bin/jam:${PORTSDIR}/devel/jam
-USE_GCC= 3.4+
+USE_GCC= 3.4
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
JAM= ${LOCALBASE}/bin/jam
JAM_ENV= BINDIR=${PREFIX}/bin \
INCDIR=${PREFIX}/include/$(PORTNAME) \
- LIBDIR=${PREFIX}/lib
+ LIBDIR=${PREFIX}/lib \
+ CC=${CC} C++=${CXX}
do-build:
cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM}