aboutsummaryrefslogtreecommitdiff
path: root/astro/kstars/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-28 20:32:37 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-28 20:32:37 +0000
commit84513d278866991342845f57c5218e5125731944 (patch)
treeb832e8aa1ae1edaf5471921b48ddc1690b48e542 /astro/kstars/Makefile
parentddb2f5c35da048da7c0970157e3de685c82b6c02 (diff)
downloadports-84513d278866991342845f57c5218e5125731944.tar.gz
ports-84513d278866991342845f57c5218e5125731944.zip
New port: astro/kstars, current version of astro/kstars-kde4
Notes
Notes: svn path=/head/; revision=468592
Diffstat (limited to 'astro/kstars/Makefile')
-rw-r--r--astro/kstars/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/astro/kstars/Makefile b/astro/kstars/Makefile
new file mode 100644
index 000000000000..79f848e82e8f
--- /dev/null
+++ b/astro/kstars/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= kstars
+DISTVERSION= 2.8.9
+PORTEPOCH= 1
+CATEGORIES= astro kde
+MASTER_SITES= KDE/stable/${PORTNAME}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE desktop planetarium
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
+ libwcs.so:astro/wcslib
+BUILD_DEPENDS= xplanet:astro/xplanet
+RUN_DEPENDS= xplanet:astro/xplanet
+
+USES= cmake:outsource compiler:c++11-lib eigen:3 gettext kde:5 \
+ pkgconfig tar:xz
+USE_KDE= config dbusaddons doctools ecm guiaddons i18n iconthemes init \
+ jobwidgets kio newstuff notifications parts plotting \
+ texteditor widgetsaddons xmlgui
+USE_QT5= buildtools_build core gui multimedia network opengl \
+ printsupport qmake_build qml quick sql svg testlib widgets \
+ xml
+
+post-patch:
+# climits defines ULLONG_MAX and LLONG_MAX
+ ${REINPLACE_CMD} -e 's#ULONG_LONG_MAX#ULLONG_MAX#g' \
+ -e 's#LONG_LONG_MAX#LLONG_MAX#g' \
+ ${WRKSRC}/kstars/fitsviewer/fitsdata.cpp
+
+.include <bsd.port.mk>