aboutsummaryrefslogtreecommitdiff
path: root/astro/libosmium
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-19 11:18:45 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-19 11:18:45 +0000
commit13991743000a9ed181ad083d3452ed332b01a29a (patch)
tree1f3a8223fb973f36ef5b6640a2789a5806f2e2bd /astro/libosmium
parent7b5da0fa709e85dba305569418a07c035ea0bb58 (diff)
downloadports-13991743000a9ed181ad083d3452ed332b01a29a.tar.gz
ports-13991743000a9ed181ad083d3452ed332b01a29a.zip
- Install all required headers
These headers belong to third party libraries (gdalcpp, protozero, utfcpp), but since these are not in the ports yet, just install bundled ones for now. PR: 215391 Submitted by: mmd.osm+freebsd@gmail.com
Notes
Notes: svn path=/head/; revision=428919
Diffstat (limited to 'astro/libosmium')
-rw-r--r--astro/libosmium/Makefile6
-rw-r--r--astro/libosmium/pkg-plist16
2 files changed, 22 insertions, 0 deletions
diff --git a/astro/libosmium/Makefile b/astro/libosmium/Makefile
index a58067ea8baf..4f42d9420bcd 100644
--- a/astro/libosmium/Makefile
+++ b/astro/libosmium/Makefile
@@ -26,6 +26,12 @@ GH_ACCOUNT= osmcode
USES= cmake compiler:c++11-lib
CMAKE_ARGS= -DBUILD_EXAMPLES:BOOL=OFF
+# if/when corresponding ports appear in the tree, these will need to
+# be turned from depends
+CMAKE_ARGS+= -DINSTALL_GDALCPP:BOOL=ON \
+ -DINSTALL_PROTOZERO:BOOL=ON \
+ -DINSTALL_UTFCPP:BOOL=ON
+
# though it builds tests, the library itself is header-only
NO_ARCH= yes
diff --git a/astro/libosmium/pkg-plist b/astro/libosmium/pkg-plist
index 31c74a58bb3d..5244660f955b 100644
--- a/astro/libosmium/pkg-plist
+++ b/astro/libosmium/pkg-plist
@@ -1,3 +1,4 @@
+include/gdalcpp.hpp
include/osmium/area/assembler.hpp
include/osmium/area/detail/node_ref_segment.hpp
include/osmium/area/detail/proto_ring.hpp
@@ -175,3 +176,18 @@ include/osmium/util/timer.hpp
include/osmium/util/verbose_output.hpp
include/osmium/version.hpp
include/osmium/visitor.hpp
+include/protozero/byteswap.hpp
+include/protozero/config.hpp
+include/protozero/exception.hpp
+include/protozero/iterators.hpp
+include/protozero/pbf_builder.hpp
+include/protozero/pbf_message.hpp
+include/protozero/pbf_reader.hpp
+include/protozero/pbf_writer.hpp
+include/protozero/types.hpp
+include/protozero/varint.hpp
+include/protozero/version.hpp
+include/utf8.h
+include/utf8/checked.h
+include/utf8/core.h
+include/utf8/unchecked.h