aboutsummaryrefslogtreecommitdiff
path: root/astro/libosmium
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-04-12 12:40:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-04-12 12:40:46 +0000
commit459d99b378c284f9e182adfe48b4203afcc35b66 (patch)
treea5f836289b362d0496b7c58c5f47db1b13b660b9 /astro/libosmium
parent0ac22f8d9c2226481eef6dfa554665f7a885afcd (diff)
downloadports-459d99b378c284f9e182adfe48b4203afcc35b66.tar.gz
ports-459d99b378c284f9e182adfe48b4203afcc35b66.zip
- Update to 2.14.0
Notes
Notes: svn path=/head/; revision=467152
Diffstat (limited to 'astro/libosmium')
-rw-r--r--astro/libosmium/Makefile20
-rw-r--r--astro/libosmium/distinfo6
-rw-r--r--astro/libosmium/files/patch-include_osmium_util_endian.hpp11
-rw-r--r--astro/libosmium/pkg-plist14
4 files changed, 15 insertions, 36 deletions
diff --git a/astro/libosmium/Makefile b/astro/libosmium/Makefile
index bd5277b77a3a..f6eecc3631b5 100644
--- a/astro/libosmium/Makefile
+++ b/astro/libosmium/Makefile
@@ -2,16 +2,15 @@
# $FreeBSD$
PORTNAME= libosmium
-PORTVERSION= 2.13.1
+PORTVERSION= 2.14.0
DISTVERSIONPREFIX= v
-PORTREVISION= 4
CATEGORIES= astro geography devel
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Fast and flexible C++ library for working with OpenStreetMap data
LICENSE= BSL
-LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_powerpc64= fails to compile: types_from_string.hpp: error: 'strtoll' is not a member of 'std'
@@ -20,8 +19,10 @@ LIB_DEPENDS= libgdal.so:graphics/gdal \
libgeos.so:graphics/geos \
libexpat.so:textproc/expat2
BUILD_DEPENDS= sparsehash>=0:devel/sparsehash \
- ${LOCALBASE}/include/utf8.h:devel/utf8cpp
-RUN_DEPENDS= ${LOCALBASE}/include/utf8.h:devel/utf8cpp
+ ${LOCALBASE}/include/utf8.h:devel/utf8cpp \
+ ${LOCALBASE}/include/protozero/version.hpp:devel/protozero
+RUN_DEPENDS= ${LOCALBASE}/include/utf8.h:devel/utf8cpp \
+ ${LOCALBASE}/include/protozero/version.hpp:devel/protozero
USE_GITHUB= yes
GH_ACCOUNT= osmcode
@@ -29,12 +30,11 @@ GH_ACCOUNT= osmcode
USES= cmake compiler:c++11-lib
CMAKE_ARGS= -DBUILD_EXAMPLES:BOOL=OFF
-# if/when corresponding ports appear in the tree, these will need to
-# be turned from depends
-CMAKE_ARGS+= -DINSTALL_GDALCPP:BOOL=ON \
- -DINSTALL_PROTOZERO:BOOL=ON
+# if/when corresponding port appears in the tree, this will need to
+# be turned into dependency
+CMAKE_ARGS+= -DINSTALL_GDALCPP:BOOL=ON
-# though it builds tests, the library itself is header-only
+# although it builds tests the library itself is header-only
NO_ARCH= yes
PORTDOCS= *
diff --git a/astro/libosmium/distinfo b/astro/libosmium/distinfo
index a6f45382f2e4..394cbbf9c65a 100644
--- a/astro/libosmium/distinfo
+++ b/astro/libosmium/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1504088485
-SHA256 (osmcode-libosmium-v2.13.1_GH0.tar.gz) = a73cd56838a7438bd9ed208c9ce6794e2d55a1854039c4277a0c160d5071b909
-SIZE (osmcode-libosmium-v2.13.1_GH0.tar.gz) = 493918
+TIMESTAMP = 1522624701
+SHA256 (osmcode-libosmium-v2.14.0_GH0.tar.gz) = ac385c13b1989cf60f9f2e0395a9d8f73ea557fbe8a35cabb0e5f0b74cf43b49
+SIZE (osmcode-libosmium-v2.14.0_GH0.tar.gz) = 489137
diff --git a/astro/libosmium/files/patch-include_osmium_util_endian.hpp b/astro/libosmium/files/patch-include_osmium_util_endian.hpp
deleted file mode 100644
index e85a34c896c9..000000000000
--- a/astro/libosmium/files/patch-include_osmium_util_endian.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/osmium/util/endian.hpp.orig 2017-01-14 10:50:34 UTC
-+++ include/osmium/util/endian.hpp
-@@ -35,7 +35,7 @@ DEALINGS IN THE SOFTWARE.
-
- // Windows is only available for little endian architectures
- // http://stackoverflow.com/questions/6449468/can-i-safely-assume-that-windows-installations-will-always-be-little-endian
--#if defined(__FreeBSD__)
-+#if defined(__FreeBSD__) || defined(__DragonFly__)
- # include <sys/endian.h>
- #elif !defined(_WIN32) && !defined(__APPLE__)
- # include <endian.h>
diff --git a/astro/libosmium/pkg-plist b/astro/libosmium/pkg-plist
index 996f94524d84..4f5757062294 100644
--- a/astro/libosmium/pkg-plist
+++ b/astro/libosmium/pkg-plist
@@ -123,6 +123,7 @@ include/osmium/io/pbf_input.hpp
include/osmium/io/pbf_output.hpp
include/osmium/io/reader.hpp
include/osmium/io/reader_iterator.hpp
+include/osmium/io/reader_with_progress_bar.hpp
include/osmium/io/writer.hpp
include/osmium/io/writer_options.hpp
include/osmium/io/xml_input.hpp
@@ -144,6 +145,7 @@ include/osmium/osm/entity.hpp
include/osmium/osm/entity_bits.hpp
include/osmium/osm/item_type.hpp
include/osmium/osm/location.hpp
+include/osmium/osm/metadata_options.hpp
include/osmium/osm/node.hpp
include/osmium/osm/node_ref.hpp
include/osmium/osm/node_ref_list.hpp
@@ -180,7 +182,6 @@ include/osmium/util/config.hpp
include/osmium/util/delta.hpp
include/osmium/util/double.hpp
include/osmium/util/endian.hpp
-include/osmium/util/endian.hpp.orig
include/osmium/util/file.hpp
include/osmium/util/iterator.hpp
include/osmium/util/memory.hpp
@@ -195,14 +196,3 @@ include/osmium/util/timer.hpp
include/osmium/util/verbose_output.hpp
include/osmium/version.hpp
include/osmium/visitor.hpp
-include/protozero/byteswap.hpp
-include/protozero/config.hpp
-include/protozero/exception.hpp
-include/protozero/iterators.hpp
-include/protozero/pbf_builder.hpp
-include/protozero/pbf_message.hpp
-include/protozero/pbf_reader.hpp
-include/protozero/pbf_writer.hpp
-include/protozero/types.hpp
-include/protozero/varint.hpp
-include/protozero/version.hpp