aboutsummaryrefslogtreecommitdiff
path: root/astro/libosmium
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-25 17:19:32 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-25 17:19:32 +0000
commit75c08fe6647c9ab196c4b5f41c272fb4be4a8138 (patch)
treec11bd93f861432b082b747ad509e9dfde66c2661 /astro/libosmium
parentdfb7ea9e3f70948e138845ae7b159bae20bde1ba (diff)
downloadports-75c08fe6647c9ab196c4b5f41c272fb4be4a8138.tar.gz
ports-75c08fe6647c9ab196c4b5f41c272fb4be4a8138.zip
- Fix conflict with utf8cpp by using it as dependency
PR: 215391 Reported by: jbeich
Notes
Notes: svn path=/head/; revision=429443
Diffstat (limited to 'astro/libosmium')
-rw-r--r--astro/libosmium/Makefile11
-rw-r--r--astro/libosmium/pkg-plist4
2 files changed, 8 insertions, 7 deletions
diff --git a/astro/libosmium/Makefile b/astro/libosmium/Makefile
index 4f42d9420bcd..2e06467b61c6 100644
--- a/astro/libosmium/Makefile
+++ b/astro/libosmium/Makefile
@@ -4,6 +4,7 @@
PORTNAME= libosmium
PORTVERSION= 2.10.3
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= astro geography devel
MAINTAINER= amdmi3@FreeBSD.org
@@ -16,7 +17,9 @@ LIB_DEPENDS= libgdal.so:graphics/gdal \
libboost_regex.so:devel/boost-libs \
libgeos.so:graphics/geos \
libexpat.so:textproc/expat2
-BUILD_DEPENDS= sparsehash>=0:devel/sparsehash
+BUILD_DEPENDS= sparsehash>=0:devel/sparsehash \
+ ${LOCALBASE}/include/utf8.h:devel/utf8cpp
+RUN_DEPENDS= ${LOCALBASE}/include/utf8.h:devel/utf8cpp
BROKEN_FreeBSD_9= does not build (lack of c++11 support)
@@ -29,8 +32,7 @@ CMAKE_ARGS= -DBUILD_EXAMPLES:BOOL=OFF
# if/when corresponding ports appear in the tree, these will need to
# be turned from depends
CMAKE_ARGS+= -DINSTALL_GDALCPP:BOOL=ON \
- -DINSTALL_PROTOZERO:BOOL=ON \
- -DINSTALL_UTFCPP:BOOL=ON
+ -DINSTALL_PROTOZERO:BOOL=ON
# though it builds tests, the library itself is header-only
NO_ARCH= yes
@@ -42,6 +44,9 @@ OPTIONS_DEFAULT= TEST
TEST_TEST_TARGET= test
TEST_CMAKE_BOOL= BUILD_TESTING
+post-extract:
+ @${RM} -rf ${WRKSRC}/include/utf8*
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/CHANGELOG.md ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
diff --git a/astro/libosmium/pkg-plist b/astro/libosmium/pkg-plist
index 5244660f955b..005dac83f883 100644
--- a/astro/libosmium/pkg-plist
+++ b/astro/libosmium/pkg-plist
@@ -187,7 +187,3 @@ include/protozero/pbf_writer.hpp
include/protozero/types.hpp
include/protozero/varint.hpp
include/protozero/version.hpp
-include/utf8.h
-include/utf8/checked.h
-include/utf8/core.h
-include/utf8/unchecked.h