aboutsummaryrefslogtreecommitdiff
path: root/astro/libosmpbf
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-01-09 13:21:30 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-01-09 13:21:30 +0000
commit6c1cb568cd419c1934fdf2afe917d788b62aa2df (patch)
tree9ab7e71874408e8aaa57f7fca7b3740fb4c6a908 /astro/libosmpbf
parent0e58284d2efc98fbab679f529f7380bbc3ab0d83 (diff)
downloadports-6c1cb568cd419c1934fdf2afe917d788b62aa2df.tar.gz
ports-6c1cb568cd419c1934fdf2afe917d788b62aa2df.zip
- Update to 1.3.3
Notes
Notes: svn path=/head/; revision=405627
Diffstat (limited to 'astro/libosmpbf')
-rw-r--r--astro/libosmpbf/Makefile19
-rw-r--r--astro/libosmpbf/distinfo4
-rw-r--r--astro/libosmpbf/files/patch-src-Makefile30
-rw-r--r--astro/libosmpbf/files/patch-src_CMakeLists.txt10
-rw-r--r--astro/libosmpbf/files/patch-tools_CMakeLists.txt10
-rw-r--r--astro/libosmpbf/files/patch-tools_osmpbf-outline.cpp9
-rw-r--r--astro/libosmpbf/pkg-plist1
7 files changed, 35 insertions, 48 deletions
diff --git a/astro/libosmpbf/Makefile b/astro/libosmpbf/Makefile
index 442a041a757f..5b2748ea4d92 100644
--- a/astro/libosmpbf/Makefile
+++ b/astro/libosmpbf/Makefile
@@ -2,15 +2,14 @@
# $FreeBSD$
PORTNAME= libosmpbf
-PORTVERSION= 1.3.0
+PORTVERSION= 1.3.3
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= astro geography devel
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Library for handling binary OpenStreetMap data
-LICENSE= GPLv3
+LICENSE= LGPL3 # or later
LICENSE_FILE= ${WRKSRC}/COPYING.osmpbf
LIB_DEPENDS= libprotobuf.so:${PORTSDIR}/devel/protobuf
@@ -19,18 +18,6 @@ USE_GITHUB= yes
GH_ACCOUNT= scrosby
GH_PROJECT= OSM-binary
-USES= gmake
-BUILD_WRKSRC= ${WRKSRC}/src
-INSTALL_WRKSRC= ${WRKSRC}/src
-
-CXXFLAGS+= -I${LOCALBASE}/include
-
-PORTDOCS= *
-
-OPTIONS_DEFINE= DOCS
-
-post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
+USES= cmake
.include <bsd.port.mk>
diff --git a/astro/libosmpbf/distinfo b/astro/libosmpbf/distinfo
index b64934119cac..6d909ad71903 100644
--- a/astro/libosmpbf/distinfo
+++ b/astro/libosmpbf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (scrosby-OSM-binary-v1.3.0_GH0.tar.gz) = c4bb6de92ae52481775ba2a6e8b751eb39dade17a1ee6669d79b694cd5266ff8
-SIZE (scrosby-OSM-binary-v1.3.0_GH0.tar.gz) = 23768
+SHA256 (scrosby-OSM-binary-v1.3.3_GH0.tar.gz) = a109f338ce6a8438a8faae4627cd08599d0403b8977c185499de5c17b92d0798
+SIZE (scrosby-OSM-binary-v1.3.3_GH0.tar.gz) = 37273
diff --git a/astro/libosmpbf/files/patch-src-Makefile b/astro/libosmpbf/files/patch-src-Makefile
deleted file mode 100644
index 99a8a1bb0523..000000000000
--- a/astro/libosmpbf/files/patch-src-Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/Makefile.orig 2012-12-05 08:14:05.000000000 +0400
-+++ src/Makefile 2013-05-23 03:08:09.903921308 +0400
-@@ -1,6 +1,6 @@
-
--CXX = g++
--CXXFLAGS = -O3
-+CXX ?= g++
-+CXXFLAGS ?= -O3
- AR = ar
-
- all: libosmpbf.a ../include/osmpbf/fileformat.pb.h ../include/osmpbf/osmformat.pb.h
-@@ -16,12 +16,12 @@
- cp *.pb.h ../include/osmpbf/
-
- install:
-- install -m 755 -g root -o root -d $(DESTDIR)/usr/lib
-- install -m 644 -g root -o root libosmpbf.a $(DESTDIR)/usr/lib
-- install -m 755 -g root -o root -d $(DESTDIR)/usr/include/osmpbf
-- install -m 644 -g root -o root ../include/osmpbf/osmpbf.h $(DESTDIR)/usr/include/osmpbf
-- install -m 644 -g root -o root ../include/osmpbf/fileformat.pb.h $(DESTDIR)/usr/include/osmpbf
-- install -m 644 -g root -o root ../include/osmpbf/osmformat.pb.h $(DESTDIR)/usr/include/osmpbf
-+ install -m 755 -d $(DESTDIR)$(PREFIX)/lib
-+ install -m 644 libosmpbf.a $(DESTDIR)$(PREFIX)/lib
-+ install -m 755 -d $(DESTDIR)$(PREFIX)/include/osmpbf
-+ install -m 644 ../include/osmpbf/osmpbf.h $(DESTDIR)$(PREFIX)/include/osmpbf
-+ install -m 644 ../include/osmpbf/fileformat.pb.h $(DESTDIR)$(PREFIX)/include/osmpbf
-+ install -m 644 ../include/osmpbf/osmformat.pb.h $(DESTDIR)$(PREFIX)/include/osmpbf
-
- clean:
- rm -f *.pb.h *.pb.cc *.pb.o libosmpbf.a
diff --git a/astro/libosmpbf/files/patch-src_CMakeLists.txt b/astro/libosmpbf/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..46550ae61fdd
--- /dev/null
+++ b/astro/libosmpbf/files/patch-src_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- src/CMakeLists.txt.orig 2014-03-15 15:11:32 UTC
++++ src/CMakeLists.txt
+@@ -3,7 +3,6 @@ PROTOBUF_GENERATE_CPP(CPPS HS fileformat
+ if(MSVC)
+ set(CMAKE_CXX_FLAGS "/O3")
+ else()
+- set(CMAKE_CXX_FLAGS "-O3")
+ endif()
+
+ add_library(osmpbf STATIC ${CPPS})
diff --git a/astro/libosmpbf/files/patch-tools_CMakeLists.txt b/astro/libosmpbf/files/patch-tools_CMakeLists.txt
new file mode 100644
index 000000000000..c2b2d1c4f374
--- /dev/null
+++ b/astro/libosmpbf/files/patch-tools_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- tools/CMakeLists.txt.orig 2014-03-15 15:11:32 UTC
++++ tools/CMakeLists.txt
+@@ -4,7 +4,6 @@ PROJECT(${PROJECT})
+ if(MSVC)
+ set(CMAKE_CXX_FLAGS "/O3")
+ else()
+- set(CMAKE_CXX_FLAGS "-O3 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64")
+ endif()
+
+ SET(CPP_SRC osmpbf-outline.cpp)
diff --git a/astro/libosmpbf/files/patch-tools_osmpbf-outline.cpp b/astro/libosmpbf/files/patch-tools_osmpbf-outline.cpp
new file mode 100644
index 000000000000..275baa253c9a
--- /dev/null
+++ b/astro/libosmpbf/files/patch-tools_osmpbf-outline.cpp
@@ -0,0 +1,9 @@
+--- tools/osmpbf-outline.cpp.orig 2014-03-15 15:11:32 UTC
++++ tools/osmpbf-outline.cpp
+@@ -1,3 +1,6 @@
++// for isatty()
++#include <unistd.h>
++
+ // used for va_list in debug-print methods
+ #include <stdarg.h>
+
diff --git a/astro/libosmpbf/pkg-plist b/astro/libosmpbf/pkg-plist
index eb42b692bbed..dadcfe0d393f 100644
--- a/astro/libosmpbf/pkg-plist
+++ b/astro/libosmpbf/pkg-plist
@@ -1,3 +1,4 @@
+bin/osmpbf-outline
include/osmpbf/fileformat.pb.h
include/osmpbf/osmformat.pb.h
include/osmpbf/osmpbf.h