aboutsummaryrefslogtreecommitdiff
path: root/astro/luna
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2013-10-25 14:04:57 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2013-10-25 14:04:57 +0000
commited0fdb020abee50e793ab0f8b866414af56acb67 (patch)
tree9d0d4c2a5c18a3c4bfced2be59b148b2c0f95c4b /astro/luna
parent4e96f31450ebf099c466dd06ad99661fe0b9a8b3 (diff)
downloadports-ed0fdb020abee50e793ab0f8b866414af56acb67.tar.gz
ports-ed0fdb020abee50e793ab0f8b866414af56acb67.zip
support STAGEDIR.
Notes
Notes: svn path=/head/; revision=331586
Diffstat (limited to 'astro/luna')
-rw-r--r--astro/luna/Makefile1
-rw-r--r--astro/luna/files/patch-makefile (renamed from astro/luna/files/patch-ab)12
2 files changed, 6 insertions, 7 deletions
diff --git a/astro/luna/Makefile b/astro/luna/Makefile
index 524f8367b570..5b432fae1d6b 100644
--- a/astro/luna/Makefile
+++ b/astro/luna/Makefile
@@ -10,7 +10,6 @@ DISTNAME= luna19s
MAINTAINER= ports@FreeBSD.org
COMMENT= Display the moon's phase
-NO_STAGE= yes
USE_DOS2UNIX= yes
USE_LHA= yes
NO_WRKSUBDIR= yes
diff --git a/astro/luna/files/patch-ab b/astro/luna/files/patch-makefile
index 3566040f4cdc..39a3160d5029 100644
--- a/astro/luna/files/patch-ab
+++ b/astro/luna/files/patch-makefile
@@ -1,5 +1,5 @@
---- makefile.orig Sun May 24 03:57:22 1992
-+++ makefile Mon Feb 21 02:45:58 2000
+--- makefile.orig 2013-10-25 16:28:17.000000000 +0800
++++ makefile 2013-10-25 16:28:43.000000000 +0800
@@ -2,23 +2,24 @@
# Makefile for luna using BSD cc
#
@@ -38,7 +38,7 @@
# The program name
PROG = luna$(EXE)
-@@ -26,7 +27,8 @@
+@@ -26,7 +27,8 @@ PROG = luna$(EXE)
# All modules
SRCS = famplan.c luna.c pyramid.c
OBJS = famplan$(O) luna$(O) pyramid$(O)
@@ -48,12 +48,12 @@
HDRS = luna.h
HDRSPR = pyramid.h
HDRSIP = iprintf/iansilib.h iprintf/iprint.h
-@@ -35,13 +37,18 @@
+@@ -35,13 +37,18 @@ HDRSIP = iprintf/iansilib.h iprintf/ipri
#
all : $(PROG)
+install:
-+ ${BSD_INSTALL_PROGRAM} $(PROG) ${PREFIX}/bin
++ ${BSD_INSTALL_PROGRAM} $(PROG) ${DESTDIR}${PREFIX}/bin
+clean:
+ rm -fr $(OBJS) $(OBJSIP) $(PROG)
+
@@ -71,7 +71,7 @@
$(OBJS) : $(HDRS)
-@@ -50,13 +57,13 @@
+@@ -50,13 +57,13 @@ luna$(O) pyramid$(O) : $(HDRSPR)
$(OBJS) : $(MAKEFILE)
# UNIX