aboutsummaryrefslogtreecommitdiff
path: root/astro/merkaartor
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /astro/merkaartor
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'astro/merkaartor')
-rw-r--r--astro/merkaartor/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/astro/merkaartor/Makefile b/astro/merkaartor/Makefile
index 7a1bcbe19183..3b3a1279818c 100644
--- a/astro/merkaartor/Makefile
+++ b/astro/merkaartor/Makefile
@@ -18,11 +18,11 @@ LIB_DEPENDS= libgdal.so:graphics/gdal \
USE_GITHUB= yes
GH_ACCOUNT= openstreetmap
-USES= pkgconfig sqlite:3 qmake
+USES= pkgconfig qt:5 sqlite:3 qmake
USE_LDCONFIG= yes
QMAKE_ARGS= SYSTEM_QUAZIP=1
-USE_QT5= buildtools_build \
+USE_QT= buildtools_build \
concurrent core gui imageformats network printsupport svg \
webkit widgets xml
@@ -45,7 +45,8 @@ ZBAR_BROKEN= Does not build with option ZBAR selected
DEBUG_QMAKE_OFF= NODEBUG=1 RELEASE=1
-NLS_USE= QT5=linguisttools_build
+NLS_USES= qt:5
+NLS_USE= QT=linguisttools_build
INSTALLS_ICONS= yes