aboutsummaryrefslogtreecommitdiff
path: root/astro/mymoon
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-02-01 20:08:28 +0000
committerJohn Marino <marino@FreeBSD.org>2016-02-01 20:08:28 +0000
commit7e9c815bec13ba35c8a96d72171221a4fc82a8ba (patch)
tree37be27a709cf35dba24a35e4998bc0bac5d23592 /astro/mymoon
parent67839a72e6df90727659ebf1760b908dfe396fb9 (diff)
downloadports-7e9c815bec13ba35c8a96d72171221a4fc82a8ba.tar.gz
ports-7e9c815bec13ba35c8a96d72171221a4fc82a8ba.zip
astro/mymoon: USES+=ncurses, link with libncurses instead of libcurses
Notes
Notes: svn path=/head/; revision=407770
Diffstat (limited to 'astro/mymoon')
-rw-r--r--astro/mymoon/Makefile2
-rw-r--r--astro/mymoon/files/patch-Makefile.in11
2 files changed, 12 insertions, 1 deletions
diff --git a/astro/mymoon/Makefile b/astro/mymoon/Makefile
index d1e5152698f8..5da18fe7a343 100644
--- a/astro/mymoon/Makefile
+++ b/astro/mymoon/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libnova.so:${PORTSDIR}/astro/libnova
WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
-USES= gmake
+USES= gmake nurses
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/astro/mymoon/files/patch-Makefile.in b/astro/mymoon/files/patch-Makefile.in
new file mode 100644
index 000000000000..e36a0e076273
--- /dev/null
+++ b/astro/mymoon/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2003-05-23 20:09:56 UTC
++++ Makefile.in
+@@ -61,7 +61,7 @@ POST_UNINSTALL = :
+ bin_PROGRAMS = mymoon
+
+ mymoon_SOURCES = mymoon.c
+-mymoon_LDFLAGS = -lnova -lcurses
++mymoon_LDFLAGS = -lnova -lncurses
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_CLEAN_FILES =
+ PROGRAMS = $(bin_PROGRAMS)