aboutsummaryrefslogtreecommitdiff
path: root/astro/nightfall/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-05-25 10:48:46 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-05-25 10:48:46 +0000
commit91aae0c9777a78679d65c1880ac25ee7b5bd7c7f (patch)
treee207bdcce54c2f5ec64600684b0ac6fd07df69eb /astro/nightfall/Makefile
parenta2c2f55504b922257544b8d2521e8c3d46d68457 (diff)
downloadports-91aae0c9777a78679d65c1880ac25ee7b5bd7c7f.tar.gz
ports-91aae0c9777a78679d65c1880ac25ee7b5bd7c7f.zip
Add nightfall-1.1
Nghtfall can produce animated views of eclipsing binary stars, calculate synthetic lightcurves and radial velocity curves. Eventually it can determine the best-fit model for a given set of observational data of an eclipsing binary star system. Submitted by: Christian Brueffer <chris@unixpages.org> PR: ports/35193
Notes
Notes: svn path=/head/; revision=59969
Diffstat (limited to 'astro/nightfall/Makefile')
-rw-r--r--astro/nightfall/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/astro/nightfall/Makefile b/astro/nightfall/Makefile
new file mode 100644
index 000000000000..317a32856351
--- /dev/null
+++ b/astro/nightfall/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: nightfall
+# Date created: 21 February 2002
+# Whom: Christian Brueffer <chris@unixpages.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nightfall
+PORTVERSION= 1.1
+CATEGORIES= astro
+MASTER_SITES= http://www.lsw.uni-heidelberg.de/~rwichman/ \
+ http://unixpages.org/distfiles/
+
+MAINTAINER= chris@unixpages.org
+
+.if !defined(WITHOUT_GTK)
+USE_GTK= yes
+.endif
+.if !defined(WITHOUT_GNUPLOT)
+BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
+RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
+.endif
+USE_GMAKE= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= \
+ --with-doc-prefix=${DOCSDIR} \
+ --with-data-prefix=${PREFIX}/share/nightfall
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/nightfall ${PREFIX}/bin/nightfall
+ ${MKDIR} ${PREFIX}/share/nightfall/data
+ ${INSTALL_DATA} ${WRKSRC}/data/* ${PREFIX}/share/nightfall/data
+ ${MKDIR} ${DOCSDIR}/C
+ ${MKDIR} ${DOCSDIR}/de
+ ${INSTALL_DATA} ${WRKSRC}/doc/C/* ${DOCSDIR}/C
+ ${INSTALL_DATA} ${WRKSRC}/doc/de/* ${DOCSDIR}/de
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+
+.include <bsd.port.mk>