aboutsummaryrefslogtreecommitdiff
path: root/astro/nightfall/Makefile
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-01 11:47:08 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-01 11:47:08 +0000
commit9a914ceab4393745ea93e62e00f67f05208cccd5 (patch)
treee8168b0f705dabd6fac72b42c35b2288b4153a63 /astro/nightfall/Makefile
parent2054dca5172edeafebd9f908bb8e1cf37aa9bbb4 (diff)
downloadports-9a914ceab4393745ea93e62e00f67f05208cccd5.tar.gz
ports-9a914ceab4393745ea93e62e00f67f05208cccd5.zip
Notes
Diffstat (limited to 'astro/nightfall/Makefile')
-rw-r--r--astro/nightfall/Makefile66
1 files changed, 41 insertions, 25 deletions
diff --git a/astro/nightfall/Makefile b/astro/nightfall/Makefile
index 9d6008801188..9d51452b8dd3 100644
--- a/astro/nightfall/Makefile
+++ b/astro/nightfall/Makefile
@@ -6,36 +6,52 @@
#
PORTNAME= nightfall
-PORTVERSION= 1.1
+PORTVERSION= 1.32
CATEGORIES= astro
-MASTER_SITES= http://www.lsw.uni-heidelberg.de/~rwichman/ \
- http://unixpages.org/distfiles/
+MASTER_SITES= http://www.lsw.uni-heidelberg.de/~rwichman/
MAINTAINER= ports@FreeBSD.org
COMMENT= An interactive binary star application
-.if !defined(WITHOUT_GTK)
-USE_GNOME= gtk12
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
+
+USE_PERL5= yes
+USE_X_PREFIX= yes
+WANT_GNOME= yes
+USE_GNOME= gtk12 gnometarget
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-locale-prefix=${PREFIX}/share/locale
+
+MAN1= nightfall.1
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mgnomelibs}!=""
+PKGNAMESUFFIX= -gnome
+USE_GNOME+= gnomelibs gnomeprefix
+PLIST_SUB+= NFDATADIR="share/gnome"
+.else
+CONFIGURE_ARGS+= --disable-gnome
+PLIST_SUB+= NFDATADIR="share"
.endif
-.if !defined(WITHOUT_GNUPLOT)
-BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
-RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
+
+.if defined(WITHOUT_PGPLOT)
+RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
+CONFIGURE_ARGS+= --with-gnuplot
+.else
+LIB_DEPENDS+= pgplot.5:${PORTSDIR}/graphics/pgplot
+CONFIGURE_ARGS+= --with-pgplot-include=${LOCALBASE}/include \
+ --with-pgplot-lib=${LOCALBASE}/lib
.endif
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= \
- --with-doc-prefix=${DOCSDIR} \
- --with-data-prefix=${PREFIX}/share/nightfall
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/nightfall ${PREFIX}/bin/nightfall
- ${MKDIR} ${PREFIX}/share/nightfall/data
- ${INSTALL_DATA} ${WRKSRC}/data/* ${PREFIX}/share/nightfall/data
- ${MKDIR} ${DOCSDIR}/C
- ${MKDIR} ${DOCSDIR}/de
- ${INSTALL_DATA} ${WRKSRC}/doc/C/* ${DOCSDIR}/C
- ${INSTALL_DATA} ${WRKSRC}/doc/de/* ${DOCSDIR}/de
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-
-.include <bsd.port.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|CFLAGS -O3|CFLAGS|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|(GNOME_DATADIR)/gnome/|(GNOME_DATADIR)/|g' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.post.mk>