aboutsummaryrefslogtreecommitdiff
path: root/astro/nightfall/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-12-17 20:57:25 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-12-17 20:57:25 +0000
commitc132f4bef115bc236ba0ce77364b7784d88a1c2e (patch)
treed2654085c0f6bdd25e5328d04a60a944ccd9fb20 /astro/nightfall/Makefile
parentaad094a512bc12429dfda171e0895f32a9fbb7ca (diff)
downloadports-c132f4bef115bc236ba0ce77364b7784d88a1c2e.tar.gz
ports-c132f4bef115bc236ba0ce77364b7784d88a1c2e.zip
Notes
Diffstat (limited to 'astro/nightfall/Makefile')
-rw-r--r--astro/nightfall/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/astro/nightfall/Makefile b/astro/nightfall/Makefile
index 4721a99d0569..d1b3e8e22a2a 100644
--- a/astro/nightfall/Makefile
+++ b/astro/nightfall/Makefile
@@ -14,7 +14,6 @@ OPTIONS_DEFINE= GNOME PGPLOT OPENGL
OPTIONS_DEFAULT= PGPLOT OPENGL
PGPLOT_DESC= Enable PGPLOT support
-NO_STAGE= yes
USES= gmake pathfix gettext perl5
USE_GNOME= gnomehier gtk20
GNU_CONFIGURE= yes
@@ -22,8 +21,6 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-locale-prefix=${PREFIX}/share/locale
-MAN1= nightfall.1
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGNOMEUI}
@@ -38,7 +35,7 @@ PLIST_SUB+= GNOMEUI="@comment "
.if ${PORT_OPTIONS:MPGPLOT}
LIB_DEPENDS+= libpgplot.so:${PORTSDIR}/graphics/pgplot
-USE_FORTRAN= yes
+USES+= fortran
CONFIGURE_ARGS+= --with-pgplot-include=${LOCALBASE}/include \
--with-pgplot-lib=${LOCALBASE}/lib
.else
@@ -61,6 +58,6 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/nightfall.desktop \
- ${PREFIX}/share/applications
+ ${STAGEDIR}${PREFIX}/share/applications
.include <bsd.port.mk>