aboutsummaryrefslogtreecommitdiff
path: root/astro/nightfall
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-10-01 03:53:02 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-10-01 03:53:02 +0000
commit05a1225b3b49242b8da9d7c5dafb07b1eb03c8d6 (patch)
treedee3e377a28f90cd1ef63baf9c248255200db82b /astro/nightfall
parent48375c0b2a8c074d6a55f8f166887638e1e1527d (diff)
downloadports-05a1225b3b49242b8da9d7c5dafb07b1eb03c8d6.tar.gz
ports-05a1225b3b49242b8da9d7c5dafb07b1eb03c8d6.zip
Upgrade to 1.86, and regen patches.
Notes
Notes: svn path=/head/; revision=398247
Diffstat (limited to 'astro/nightfall')
-rw-r--r--astro/nightfall/Makefile3
-rw-r--r--astro/nightfall/distinfo4
-rw-r--r--astro/nightfall/files/patch-Light.c6
-rw-r--r--astro/nightfall/files/patch-Light.h6
-rw-r--r--astro/nightfall/files/patch-LightGLAnimate.c4
-rw-r--r--astro/nightfall/files/patch-LightGnome.c6
-rw-r--r--astro/nightfall/files/patch-distribute.c16
7 files changed, 30 insertions, 15 deletions
diff --git a/astro/nightfall/Makefile b/astro/nightfall/Makefile
index 26aacf404e52..f837b45cde4a 100644
--- a/astro/nightfall/Makefile
+++ b/astro/nightfall/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nightfall
-PORTVERSION= 1.70
-PORTREVISION= 12
+PORTVERSION= 1.86
CATEGORIES= astro
MASTER_SITES= http://www.la-samhna.de/nightfall/
diff --git a/astro/nightfall/distinfo b/astro/nightfall/distinfo
index 712d42e3a4af..0d7319ee7b9d 100644
--- a/astro/nightfall/distinfo
+++ b/astro/nightfall/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nightfall-1.70.tar.gz) = d282b3d5f90e51284cbfb1619ab54184549eb2a21422ee452d794cded58c14de
-SIZE (nightfall-1.70.tar.gz) = 1457748
+SHA256 (nightfall-1.86.tar.gz) = 2394133c77d512f048198da91a9bf9378887997c4df1a7283e6b91f08dd54e80
+SIZE (nightfall-1.86.tar.gz) = 1479521
diff --git a/astro/nightfall/files/patch-Light.c b/astro/nightfall/files/patch-Light.c
index b2f9217bed87..509591a83a40 100644
--- a/astro/nightfall/files/patch-Light.c
+++ b/astro/nightfall/files/patch-Light.c
@@ -1,6 +1,6 @@
---- Light.c.orig Thu Oct 20 22:54:11 2005
-+++ Light.c Wed Dec 7 02:43:38 2005
-@@ -275,8 +275,10 @@
+--- Light.c.orig 2014-09-25 08:03:26 UTC
++++ Light.c
+@@ -252,8 +252,10 @@ int main(int argc, char *argv[])
/* >>>>>>>>>>>>>>>> ALLOCATE MEMORY <<<<<<<<<<<<<<<<<<<<< */
diff --git a/astro/nightfall/files/patch-Light.h b/astro/nightfall/files/patch-Light.h
index ee425a24f47f..bd73f74cb55f 100644
--- a/astro/nightfall/files/patch-Light.h
+++ b/astro/nightfall/files/patch-Light.h
@@ -1,6 +1,6 @@
---- Light.h.orig Thu Oct 20 22:18:52 2005
-+++ Light.h Wed Dec 7 02:47:16 2005
-@@ -805,7 +805,9 @@
+--- Light.h.orig 2014-09-25 09:25:17 UTC
++++ Light.h
+@@ -935,7 +935,9 @@ void DefineAxis(double *Min, double *Max
/* */
/**************************************************************************/
diff --git a/astro/nightfall/files/patch-LightGLAnimate.c b/astro/nightfall/files/patch-LightGLAnimate.c
index 310eef55e86a..96a5b299da9b 100644
--- a/astro/nightfall/files/patch-LightGLAnimate.c
+++ b/astro/nightfall/files/patch-LightGLAnimate.c
@@ -1,5 +1,5 @@
---- LightGLAnimate.c.orig Tue Nov 25 00:21:36 2003
-+++ LightGLAnimate.c Tue Nov 25 00:24:22 2003
+--- LightGLAnimate.c.orig 2014-05-13 08:45:46 UTC
++++ LightGLAnimate.c
@@ -25,6 +25,7 @@
#include <stdio.h>
#include <stdlib.h>
diff --git a/astro/nightfall/files/patch-LightGnome.c b/astro/nightfall/files/patch-LightGnome.c
index fcbba3da3294..55c6ac5a1769 100644
--- a/astro/nightfall/files/patch-LightGnome.c
+++ b/astro/nightfall/files/patch-LightGnome.c
@@ -1,6 +1,6 @@
---- LightGnome.c.orig Thu Oct 27 21:46:52 2005
-+++ LightGnome.c Wed Dec 7 02:44:36 2005
-@@ -335,7 +335,11 @@
+--- LightGnome.c.orig 2011-11-18 12:47:36 UTC
++++ LightGnome.c
+@@ -333,7 +333,11 @@ gint
FileType *dataFile = FileList;
char path[256];
diff --git a/astro/nightfall/files/patch-distribute.c b/astro/nightfall/files/patch-distribute.c
new file mode 100644
index 000000000000..bed840d97aa4
--- /dev/null
+++ b/astro/nightfall/files/patch-distribute.c
@@ -0,0 +1,16 @@
+--- distribute.c.orig 2012-01-25 13:36:01 UTC
++++ distribute.c
+@@ -36,11 +36,11 @@ static char * build_cmdline(int full)
+ {
+ int i;
+ char temp[512];
+- size_t size = strlen(program_invocation_name) + 1;
++ size_t size = strlen(g_get_prgname()) + 1;
+ size_t len;
+ char * cmdline = malloc(size);
+
+- strncpy(cmdline, program_invocation_name, size);
++ strncpy(cmdline, g_get_prgname(), size);
+
+ if (full)
+ {