aboutsummaryrefslogtreecommitdiff
path: root/astro/opencpn/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-04-12 18:24:17 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-04-12 18:24:17 +0000
commit6626339318d7688223bc820cc00ebee0f4f2ba49 (patch)
tree5907ff97b84e59037e41f73efd857b4b3e85915e /astro/opencpn/Makefile
parentd2fa2ad4f8dc4bdced34e21accb10bf4af81c887 (diff)
downloadports-6626339318d7688223bc820cc00ebee0f4f2ba49.tar.gz
ports-6626339318d7688223bc820cc00ebee0f4f2ba49.zip
astro/opencpn: Update to 5.0.0
PR: 243447 Submitted by: ml@netfence.it (maintainer)
Notes
Notes: svn path=/head/; revision=531540
Diffstat (limited to 'astro/opencpn/Makefile')
-rw-r--r--astro/opencpn/Makefile34
1 files changed, 18 insertions, 16 deletions
diff --git a/astro/opencpn/Makefile b/astro/opencpn/Makefile
index aaac74d44819..ed8da29b0398 100644
--- a/astro/opencpn/Makefile
+++ b/astro/opencpn/Makefile
@@ -1,42 +1,41 @@
# $FreeBSD$
PORTNAME= opencpn
-PORTVERSION= 4.4.0
+PORTVERSION= 5.0.0
DISTVERSIONPREFIX= v
-PORTREVISION= 8
CATEGORIES= astro geography
MAINTAINER= ml@netfence.it
COMMENT= Concise ChartPlotter/Navigator
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2020-05-05
-
LICENSE= GPLv2+
LIB_DEPENDS= libportaudio.so:audio/portaudio \
libcurl.so:ftp/curl \
libexpat.so:textproc/expat2 \
- libtinyxml.so:textproc/tinyxml
+ libtinyxml.so:textproc/tinyxml \
+ liblz4.so:archivers/liblz4
+USES= cmake compiler:c++11-lang gettext-tools gl gnome \
+ localbase pkgconfig sqlite xorg
+USE_CXXSTD= c++11
USE_GITHUB= yes
GH_ACCOUNT= ${GH_PROJECT}
GH_PROJECT= OpenCPN
-
-USES= cmake compiler:c++11-lang gettext-tools gl gnome localbase xorg
-USE_CXXSTD= c++11
USE_GL= gl
-USE_GNOME= cairo gdkpixbuf2 gtk20
-USE_WX= 3.0+
-USE_XORG= x11
+USE_GNOME= cairo gdkpixbuf2 gtk30 pango
INSTALLS_ICONS= yes
+USE_LDCONFIG= ${PREFIX}/lib/opencpn
+USE_WX= 3.0+
+USE_XORG= ice sm x11 xext
-CMAKE_ARGS= -DBUNDLE_DOCS=ON -DBUNDLE_GSHHS=CRUDE -DBUNDLE_TCDATA=ON
-LDFLAGS+= -Wl,-E # plugins
-LDFLAGS+= -Wl,--as-needed # ICE, SM, Xext
+CMAKE_ARGS= -DBUNDLE_GSHHS=CRUDE
+CMAKE_ON= BUNDLE_TCDATA OCPN_FORCE_GTK3
+CMAKE_OFF= OCPN_NEW_SERIAL
OPTIONS_DEFINE= DOCS
+DOCS_CMAKE_ON= -DBUNDLE_DOCS:STRING="ON"
+DOCS_CMAKE_OFF= -DBUNDLE_DOCS:STRING="OFF"
.include <bsd.port.pre.mk>
@@ -50,4 +49,7 @@ post-patch:
-e '/-mavx2/d' ${WRKSRC}/CMakeLists.txt
.endif
+post-install:
+ ${GZIP_CMD} ${STAGEDIR}${PREFIX}/man/man1/opencpn.1
+
.include <bsd.port.post.mk>