aboutsummaryrefslogtreecommitdiff
path: root/astro/opencpn
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-02-18 01:41:18 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-02-18 01:41:18 +0000
commit57d5efa3aad415848df3347154bc5587d2191924 (patch)
tree4cce8925516a72de44f0b0094b12104cb906df03 /astro/opencpn
parent7a1e322eb4b27540a3ec3f6f9b18c47df19fb99b (diff)
downloadports-57d5efa3aad415848df3347154bc5587d2191924.tar.gz
ports-57d5efa3aad415848df3347154bc5587d2191924.zip
GCC architectures don't support SSE, SSSE or AVX. Don't use them on GCC-based
architectures to fix build. While here, set USES= gl gnome as per modern standards, and pet portlint. PR: 235294 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=493234
Diffstat (limited to 'astro/opencpn')
-rw-r--r--astro/opencpn/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/astro/opencpn/Makefile b/astro/opencpn/Makefile
index 3dd9560f879c..5b593b1c8058 100644
--- a/astro/opencpn/Makefile
+++ b/astro/opencpn/Makefile
@@ -11,6 +11,8 @@ COMMENT= Concise ChartPlotter/Navigator
LICENSE= GPLv2+
+BROKEN_aarch64= Fails to compile: use of undeclared identifier rand
+
LIB_DEPENDS= libportaudio.so:audio/portaudio \
libcurl.so:ftp/curl \
libexpat.so:textproc/expat2 \
@@ -20,7 +22,7 @@ USE_GITHUB= yes
GH_ACCOUNT= ${GH_PROJECT}
GH_PROJECT= OpenCPN
-USES= cmake compiler:c++11-lib gettext-tools localbase
+USES= cmake compiler:c++11-lib gettext-tools gl gnome localbase
USE_CXXSTD= c++11
USE_GL= gl
USE_GNOME= cairo gdkpixbuf2 gtk20
@@ -32,8 +34,6 @@ CMAKE_ARGS= -DBUNDLE_DOCS=ON -DBUNDLE_GSHHS=CRUDE -DBUNDLE_TCDATA=ON
LDFLAGS+= -Wl,-E # plugins
LDFLAGS+= -Wl,--as-needed # ICE, SM, Xext
-BROKEN_aarch64= Fails to compile: use of undeclared identifier rand
-
OPTIONS_DEFINE= DOCS
post-patch:
@@ -41,5 +41,9 @@ post-patch:
${WRKSRC}/src/mygdal/cpl_csv.cpp \
${WRKSRC}/src/mygdal/cpl_findfile.cpp \
${WRKSRC}/data/doc/help_en_US.html
+.if exists(/usr/lib/libstdc++.so)
+ @${REINPLACE_CMD} -e '/-msse/d' -e '/-mssse3/d' \
+ -e '/-mavx2/d' ${WRKSRC}/CMakeLists.txt
+.endif
.include <bsd.port.mk>