aboutsummaryrefslogtreecommitdiff
path: root/astro/opencpn
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-09-09 07:53:09 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-09-09 07:53:09 +0000
commite4455116afe78886e70436a31b5157d1a3534f7f (patch)
tree97ed02e82fa44c2354aa1d829a1339499cc7ba51 /astro/opencpn
parent55292ef0ee4d2fe54392137daa355fffb5732ed2 (diff)
downloadports-e4455116afe78886e70436a31b5157d1a3534f7f.tar.gz
ports-e4455116afe78886e70436a31b5157d1a3534f7f.zip
astro/opencpn: Update to 5.2.0
ChangeLog: https://opencpn.org/OpenCPN/about/ver520.html PR: 249195 Submitted by: ml@netfence.it (maintainer)
Notes
Notes: svn path=/head/; revision=548067
Diffstat (limited to 'astro/opencpn')
-rw-r--r--astro/opencpn/Makefile17
-rw-r--r--astro/opencpn/distinfo6
-rw-r--r--astro/opencpn/files/patch-CMakeLists.txt27
-rw-r--r--astro/opencpn/files/patch-cmake_TargetSetup.cmake20
-rw-r--r--astro/opencpn/files/patch-include_zeroconf-detail.hpp18
-rw-r--r--astro/opencpn/files/patch-libs_easywsclient_easywsclient.cpp10
-rw-r--r--astro/opencpn/files/patch-libs_wxservdisc_wxServDisc.cpp14
-rw-r--r--astro/opencpn/files/patch-src_chart1.cpp12
-rw-r--r--astro/opencpn/files/patch-src_routemanagerdialog.cpp68
-rw-r--r--astro/opencpn/pkg-plist32
10 files changed, 119 insertions, 105 deletions
diff --git a/astro/opencpn/Makefile b/astro/opencpn/Makefile
index 8e5326cc48c1..b045da8e98c5 100644
--- a/astro/opencpn/Makefile
+++ b/astro/opencpn/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= opencpn
-PORTVERSION= 5.0.0
-PORTREVISION= 1
+PORTVERSION= 5.2.0
DISTVERSIONPREFIX= v
CATEGORIES= astro geography
@@ -31,20 +30,20 @@ USE_LDCONFIG= ${PREFIX}/lib/opencpn
USE_WX= 3.0+
USE_XORG= ice sm x11 xext
-CMAKE_ARGS= -DBUNDLE_GSHHS=CRUDE
-CMAKE_ON= BUNDLE_TCDATA OCPN_FORCE_GTK3
-CMAKE_OFF= OCPN_NEW_SERIAL
+CMAKE_ARGS= -DOCPN_BUNDLE_GSHHS=CRUDE
+CMAKE_ON= OCPN_BUNDLE_TCDATA OCPN_FORCE_GTK3
+CMAKE_OFF= OCPN_USE_NEWSERIAL
OPTIONS_DEFINE= DOCS
-DOCS_CMAKE_ON= -DBUNDLE_DOCS:STRING="ON"
-DOCS_CMAKE_OFF= -DBUNDLE_DOCS:STRING="OFF"
+DOCS_CMAKE_ON= -DOCPN_BUNDLE_DOCS:STRING="ON"
+DOCS_CMAKE_OFF= -DOCPN_BUNDLE_DOCS:STRING="OFF"
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},' \
- ${WRKSRC}/src/mygdal/cpl_csv.cpp \
- ${WRKSRC}/src/mygdal/cpl_findfile.cpp \
+ ${WRKSRC}/libs/gdal/src/cpl_csv.cpp \
+ ${WRKSRC}/libs/gdal/src/cpl_findfile.cpp \
${WRKSRC}/data/doc/help_en_US.html
.if ${ARCH} != amd64 && ${ARCH} != i386
@${REINPLACE_CMD} -e '/-msse/d' -e '/-mssse3/d' \
diff --git a/astro/opencpn/distinfo b/astro/opencpn/distinfo
index 9584e4b37050..76de82eabd00 100644
--- a/astro/opencpn/distinfo
+++ b/astro/opencpn/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1578845682
-SHA256 (OpenCPN-OpenCPN-v5.0.0_GH0.tar.gz) = e58755fd9781c1a0f2da1244b75358c8d03d8f79ec2aa9633e5f6b5af98978b4
-SIZE (OpenCPN-OpenCPN-v5.0.0_GH0.tar.gz) = 67164574
+TIMESTAMP = 1599147212
+SHA256 (OpenCPN-OpenCPN-v5.2.0_GH0.tar.gz) = f6ec38989bc38f5a7f63234c5e0230adeb73f5626b4e3d3dfa680f0c240badc7
+SIZE (OpenCPN-OpenCPN-v5.2.0_GH0.tar.gz) = 78313969
diff --git a/astro/opencpn/files/patch-CMakeLists.txt b/astro/opencpn/files/patch-CMakeLists.txt
index e72e9c4fce08..1ef21bcfb897 100644
--- a/astro/opencpn/files/patch-CMakeLists.txt
+++ b/astro/opencpn/files/patch-CMakeLists.txt
@@ -1,20 +1,11 @@
---- CMakeLists.txt.orig 2019-03-23 01:25:59 UTC
+--- CMakeLists.txt.orig 2020-07-15 18:02:29 UTC
+++ CMakeLists.txt
-@@ -1053,7 +1053,7 @@ IF(NOT WIN32 AND NOT APPLE AND NOT QT_ANDROID)
- set(wxWidgets_CONFIG_OPTIONS ${wxWidgets_CONFIG_OPTIONS} --toolkit=gtk3)
- MESSAGE(STATUS "Building against GTK3...")
- ENDIF(GTK2_FOUND)
-- FIND_PACKAGE(wxWidgets)
-+ FIND_PACKAGE(wxWidgets COMPONENTS ${wxWidgets_USE_LIBS})
- if (wxWidgets_FOUND)
- message(STATUS "Found wxWidgets webview add-on")
- add_definitions(-DOCPN_USE_WEBVIEW)
-@@ -2422,7 +2422,7 @@ IF(NOT APPLE)
- INSTALL(FILES src/bitmaps/other_svg_src/opencpn.svg DESTINATION ${PREFIX_DATA}/icons/hicolor/scalable/apps PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ)
- INSTALL(FILES data/opencpn.desktop DESTINATION ${PREFIX_DATA}/applications PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ )
- INSTALL(FILES data/opencpn.appdata.xml DESTINATION ${PREFIX_DATA}/appdata PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ )
-- INSTALL(FILES opencpn.1 DESTINATION ${PREFIX_DATA}/man/man1 PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ )
-+ INSTALL(FILES opencpn.1 DESTINATION ${PREFIX_DATA}/../man/man1 PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ )
- ENDIF(UNIX)
+@@ -2221,7 +2221,7 @@ if (NOT APPLE)
+ FILES ${CMAKE_BINARY_DIR}/opencpn.appdata.xml
+ DESTINATION ${PREFIX_DATA}/metainfo
+ )
+- install(FILES opencpn.1 DESTINATION ${PREFIX_DATA}/man/man1)
++ install(FILES opencpn.1 DESTINATION ${PREFIX_DATA}/../man/man1)
+ endif (UNIX)
- ENDIF(NOT APPLE)
+ IF(PACKAGE_FORMAT MATCHES "DEB")
diff --git a/astro/opencpn/files/patch-cmake_TargetSetup.cmake b/astro/opencpn/files/patch-cmake_TargetSetup.cmake
new file mode 100644
index 000000000000..926bd1008406
--- /dev/null
+++ b/astro/opencpn/files/patch-cmake_TargetSetup.cmake
@@ -0,0 +1,20 @@
+--- cmake/TargetSetup.cmake.orig 2020-07-15 18:02:29 UTC
++++ cmake/TargetSetup.cmake
+@@ -26,14 +26,10 @@ elseif (APPLE)
+ execute_process(COMMAND "sw_vers" "-productVersion"
+ OUTPUT_VARIABLE PKG_TARGET_VERSION)
+ elseif (UNIX)
+- find_program(LSB_RELEASE NAMES lsb_release)
+- if (NOT LSB_RELEASE)
+- message(FATAL_ERROR
+- "Cannot find the lsb_release program, please install.")
+- endif ()
+- execute_process(COMMAND ${LSB_RELEASE} "-is"
++ find_program(LSB_RELEASE NAMES uname)
++ execute_process(COMMAND ${LSB_RELEASE} "-s"
+ OUTPUT_VARIABLE PKG_TARGET)
+- execute_process(COMMAND ${LSB_RELEASE} "-rs"
++ execute_process(COMMAND ${LSB_RELEASE} "-r"
+ OUTPUT_VARIABLE PKG_TARGET_VERSION)
+ else ()
+ set(PKG_TARGET "unknown")
diff --git a/astro/opencpn/files/patch-include_zeroconf-detail.hpp b/astro/opencpn/files/patch-include_zeroconf-detail.hpp
new file mode 100644
index 000000000000..3afcb3d6217b
--- /dev/null
+++ b/astro/opencpn/files/patch-include_zeroconf-detail.hpp
@@ -0,0 +1,18 @@
+--- include/zeroconf-detail.hpp.orig 2020-07-15 18:02:29 UTC
++++ include/zeroconf-detail.hpp
+@@ -21,7 +21,7 @@
+ #include <winsock2.h>
+ #else
+ #ifndef __WXOSX__
+- #include <error.h>
++// #include <error.h>
+ #else
+ #include <mach/error.h>
+ #endif
+@@ -424,4 +424,4 @@ namespace Zeroconf
+ }
+ }
+
+-#endif // ZEROCONF_DETAIL_HPP
+\ No newline at end of file
++#endif // ZEROCONF_DETAIL_HPP
diff --git a/astro/opencpn/files/patch-libs_easywsclient_easywsclient.cpp b/astro/opencpn/files/patch-libs_easywsclient_easywsclient.cpp
new file mode 100644
index 000000000000..8bd08907f853
--- /dev/null
+++ b/astro/opencpn/files/patch-libs_easywsclient_easywsclient.cpp
@@ -0,0 +1,10 @@
+--- libs/easywsclient/easywsclient.cpp.orig 2020-07-15 18:02:29 UTC
++++ libs/easywsclient/easywsclient.cpp
+@@ -56,6 +56,7 @@
+ #include <unistd.h>
+ #include <stdint.h>
+ #include <netinet/tcp.h>
++ #include <netinet/in.h>
+ #include <arpa/inet.h>
+
+ #ifndef _SOCKET_T_DEFINED
diff --git a/astro/opencpn/files/patch-libs_wxservdisc_wxServDisc.cpp b/astro/opencpn/files/patch-libs_wxservdisc_wxServDisc.cpp
new file mode 100644
index 000000000000..dce2bd31cf26
--- /dev/null
+++ b/astro/opencpn/files/patch-libs_wxservdisc_wxServDisc.cpp
@@ -0,0 +1,14 @@
+--- libs/wxservdisc/wxServDisc.cpp.orig 2020-07-15 18:02:29 UTC
++++ libs/wxservdisc/wxServDisc.cpp
+@@ -42,11 +42,9 @@
+
+
+ // Compatability defines
+-#ifdef __APPLE__
+ #ifndef IPV6_ADD_MEMBERSHIP
+ #define IPV6_ADD_MEMBERSHIP IPV6_JOIN_GROUP
+ #define IPV6_DROP_MEMBERSHIP IPV6_LEAVE_GROUP
+-#endif
+ #endif
+
+
diff --git a/astro/opencpn/files/patch-src_chart1.cpp b/astro/opencpn/files/patch-src_chart1.cpp
index dbab0ac86b2f..802c3c81c21f 100644
--- a/astro/opencpn/files/patch-src_chart1.cpp
+++ b/astro/opencpn/files/patch-src_chart1.cpp
@@ -1,6 +1,6 @@
---- src/chart1.cpp.orig 2020-01-13 17:48:06 UTC
+--- src/chart1.cpp.orig 2020-07-15 18:02:29 UTC
+++ src/chart1.cpp
-@@ -7917,7 +7917,7 @@ void MyFrame::MouseEvent( wxMouseEvent& event )
+@@ -8226,7 +8226,7 @@ void MyFrame::MouseEvent( wxMouseEvent& event )
#endif
#ifdef __WXGTK__
@@ -8,8 +8,8 @@
+#include <stdlib.h>
#endif
- int g_lastMemTick = -1;
-@@ -10282,6 +10282,8 @@ extern "C" int wait(int *); // POS
+ #if defined(__linux__)
+@@ -10370,6 +10370,8 @@ extern "C" int wait(int *); // POS
#include <sys/ioctl.h>
#ifdef __linux__
#include <linux/serial.h>
@@ -18,7 +18,7 @@
#endif
#endif
-@@ -10357,17 +10359,25 @@ int isTTYreal(const char *dev)
+@@ -10445,17 +10447,25 @@ int isTTYreal(const char *dev)
return 1;
return 0;
#else /* !NetBSD */
@@ -45,7 +45,7 @@
}
close (fd);
}
-@@ -10417,10 +10427,17 @@ wxArrayString *EnumerateSerialPorts( void )
+@@ -10505,10 +10515,17 @@ wxArrayString *EnumerateSerialPorts( void )
//Initialize the pattern table
if( devPatern[0] == NULL ) {
diff --git a/astro/opencpn/files/patch-src_routemanagerdialog.cpp b/astro/opencpn/files/patch-src_routemanagerdialog.cpp
deleted file mode 100644
index 1558ee6490fe..000000000000
--- a/astro/opencpn/files/patch-src_routemanagerdialog.cpp
+++ /dev/null
@@ -1,68 +0,0 @@
---- src/routemanagerdialog.cpp.orig 2020-01-13 18:06:15 UTC
-+++ src/routemanagerdialog.cpp
-@@ -948,7 +948,7 @@ void RouteManagerDialog::UpdateRouteListCtrl()
- list_index++;
- }
-
-- m_pRouteListCtrl->SortItems( SortRoutesOnName, NULL );
-+ m_pRouteListCtrl->SortItems( SortRoutesOnName, 0 );
-
- m_pRouteListCtrl->SetColumnWidth(0, 4 * m_charWidth);
-
-@@ -1356,11 +1356,11 @@ void RouteManagerDialog::OnRteColumnClicked( wxListEve
- if( event.m_col == 1 ) {
- sort_route_name_dir++;
-
-- m_pRouteListCtrl->SortItems( SortRoutesOnName, NULL );
-+ m_pRouteListCtrl->SortItems( SortRoutesOnName, 0 );
- } else
- if( event.m_col == 2 ) {
- sort_route_to_dir++;
-- m_pRouteListCtrl->SortItems( SortRoutesOnTo, NULL );
-+ m_pRouteListCtrl->SortItems( SortRoutesOnTo, 0 );
- }
- }
-
-@@ -1635,11 +1635,11 @@ void RouteManagerDialog::UpdateTrkListCtrl()
-
- switch( sort_track_key ){
- case SORT_ON_DISTANCE:
-- m_pTrkListCtrl->SortItems( SortTracksOnDistance, NULL );
-+ m_pTrkListCtrl->SortItems( SortTracksOnDistance, 0 );
- break;
- case SORT_ON_NAME:
- default:
-- m_pTrkListCtrl->SortItems( SortTracksOnName, NULL );
-+ m_pTrkListCtrl->SortItems( SortTracksOnName, 0 );
- break;
- }
-
-@@ -1668,12 +1668,12 @@ void RouteManagerDialog::OnTrkColumnClicked( wxListEve
- if( event.m_col == 1 ) {
- sort_track_key = SORT_ON_NAME;
- sort_track_name_dir++;
-- m_pTrkListCtrl->SortItems( SortTracksOnName, NULL );
-+ m_pTrkListCtrl->SortItems( SortTracksOnName, 0 );
- } else
- if( event.m_col == 2 ) {
- sort_track_key = SORT_ON_DISTANCE;
- sort_track_len_dir++;
-- m_pTrkListCtrl->SortItems( SortTracksOnDistance, NULL );
-+ m_pTrkListCtrl->SortItems( SortTracksOnDistance, 0 );
- }
- }
-
-@@ -2372,11 +2372,11 @@ void RouteManagerDialog::OnLayColumnClicked( wxListEve
- {
- if( event.m_col == 1 ) {
- sort_layer_name_dir++;
-- m_pLayListCtrl->SortItems( SortLayersOnName, NULL );
-+ m_pLayListCtrl->SortItems( SortLayersOnName, 0 );
- } else
- if( event.m_col == 2 ) {
- sort_layer_len_dir++;
-- m_pLayListCtrl->SortItems( SortLayersOnSize, NULL );
-+ m_pLayListCtrl->SortItems( SortLayersOnSize, 0 );
- }
- }
-
diff --git a/astro/opencpn/pkg-plist b/astro/opencpn/pkg-plist
index 9711edf0567d..b6b8f8239de7 100644
--- a/astro/opencpn/pkg-plist
+++ b/astro/opencpn/pkg-plist
@@ -4,7 +4,7 @@ lib/opencpn/libdashboard_pi.so
lib/opencpn/libgrib_pi.so
lib/opencpn/libwmm_pi.so
man/man1/opencpn.1.gz
-share/appdata/opencpn.appdata.xml
+share/metainfo/opencpn.appdata.xml
share/applications/opencpn.desktop
%%PORTDOCS%%%%DOCSDIR%%/changelog
%%PORTDOCS%%%%DOCSDIR%%/copyright
@@ -16,6 +16,10 @@ share/locale/ar_SA/LC_MESSAGES/opencpn-dashboard_pi.mo
share/locale/ar_SA/LC_MESSAGES/opencpn-grib_pi.mo
share/locale/ar_SA/LC_MESSAGES/opencpn-wmm_pi.mo
share/locale/ar_SA/LC_MESSAGES/opencpn.mo
+share/locale/bg_BG/LC_MESSAGES/opencpn-chartdldr_pi.mo
+share/locale/bg_BG/LC_MESSAGES/opencpn-dashboard_pi.mo
+share/locale/bg_BG/LC_MESSAGES/opencpn-grib_pi.mo
+share/locale/bg_BG/LC_MESSAGES/opencpn-wmm_pi.mo
share/locale/ca_ES/LC_MESSAGES/opencpn-chartdldr_pi.mo
share/locale/ca_ES/LC_MESSAGES/opencpn-dashboard_pi.mo
share/locale/ca_ES/LC_MESSAGES/opencpn-grib_pi.mo
@@ -175,6 +179,8 @@ share/locale/zh_TW/LC_MESSAGES/opencpn.mo
%%DATADIR%%/LICENSING
%%DATADIR%%/LINUX_DEVICES.md
%%DATADIR%%/authors.html
+%%DATADIR%%/license.txt
+%%DATADIR%%/ocpn-plugins.xml
%%PORTDOCS%%%%DATADIR%%/doc/50info/MBT1.jpg
%%PORTDOCS%%%%DATADIR%%/doc/50info/bridge1.jpg
%%PORTDOCS%%%%DATADIR%%/doc/50info/bridge2.jpg
@@ -1173,6 +1179,8 @@ share/locale/zh_TW/LC_MESSAGES/opencpn.mo
%%DATADIR%%/gshhs/wdb_rivers_c.b
%%DATADIR%%/license.html
%%DATADIR%%/opencpn.png
+%%DATADIR%%/plugins/chartdldr_pi/data/button_down.png
+%%DATADIR%%/plugins/chartdldr_pi/data/button_right.png
%%DATADIR%%/plugins/chartdldr_pi/data/chart_sources.xml
%%DATADIR%%/plugins/chartdldr_pi/data/doc/03-Chart-Downloader-Tab-First-Time.png
%%DATADIR%%/plugins/chartdldr_pi/data/doc/04-AddNewChartSource-Predefined.png
@@ -1188,11 +1196,18 @@ share/locale/zh_TW/LC_MESSAGES/opencpn.mo
%%DATADIR%%/plugins/chartdldr_pi/data/doc/highlight.min.js
%%DATADIR%%/plugins/chartdldr_pi/data/doc/index.html
%%DATADIR%%/plugins/chartdldr_pi/data/doc/preferences.png
+%%DATADIR%%/plugins/chartdldr_pi/data/file.png
+%%DATADIR%%/plugins/chartdldr_pi/data/folder.png
%%DATADIR%%/plugins/chartdldr_pi/data/folder215.png
%%DATADIR%%/plugins/chartdldr_pi/data/open182.png
%%DATADIR%%/plugins/dashboard_pi/data/Dashboard.svg
%%DATADIR%%/plugins/dashboard_pi/data/Dashboard_rollover.svg
%%DATADIR%%/plugins/dashboard_pi/data/Dashboard_toggled.svg
+%%DATADIR%%/plugins/dashboard_pi/data/dashboard_pi.svg
+%%DATADIR%%/plugins/dashboard_pi/data/dial.svg
+%%DATADIR%%/plugins/dashboard_pi/data/instrument.svg
+%%DATADIR%%/plugins/dashboard_pi/data/minus.svg
+%%DATADIR%%/plugins/dashboard_pi/data/plus.svg
%%DATADIR%%/plugins/grib_pi/data/altitude.svg
%%DATADIR%%/plugins/grib_pi/data/curdata.svg
%%DATADIR%%/plugins/grib_pi/data/grib.svg
@@ -1233,6 +1248,7 @@ share/locale/zh_TW/LC_MESSAGES/opencpn.mo
%%DATADIR%%/uidata/DragHandle.svg
%%DATADIR%%/uidata/MUI_flat/CompassRose.svg
%%DATADIR%%/uidata/MUI_flat/CompassRoseBlue.svg
+%%DATADIR%%/uidata/MUI_flat/CompassRoseMag.svg
%%DATADIR%%/uidata/MUI_flat/Dashboard.svg
%%DATADIR%%/uidata/MUI_flat/Dashboard_rollover.svg
%%DATADIR%%/uidata/MUI_flat/Dashboard_rollover_toggled.svg
@@ -1626,10 +1642,13 @@ share/locale/zh_TW/LC_MESSAGES/opencpn.mo
%%DATADIR%%/uidata/markicons/Weather-Tropical High.svg
%%DATADIR%%/uidata/markicons/Weather-Tropical-Storm-NH.svg
%%DATADIR%%/uidata/markicons/Weather-Tropical-Storm-SH.svg
+%%DATADIR%%/uidata/package-x-generic.png
+%%DATADIR%%/uidata/plus.svg
%%DATADIR%%/uidata/styles.xml
%%DATADIR%%/uidata/toolicons_journeyman.png
%%DATADIR%%/uidata/toolicons_journeyman_flat.png
%%DATADIR%%/uidata/toolicons_traditional.png
+%%DATADIR%%/uidata/traditional/4WayMove.svg
%%DATADIR%%/uidata/traditional/AIS.svg
%%DATADIR%%/uidata/traditional/AIS_AlertGeneral.svg
%%DATADIR%%/uidata/traditional/AIS_AlertGeneral_Active.svg
@@ -1645,6 +1664,7 @@ share/locale/zh_TW/LC_MESSAGES/opencpn.mo
%%DATADIR%%/uidata/traditional/AIS_Suppressed_rollover.svg
%%DATADIR%%/uidata/traditional/AIS_rollover.svg
%%DATADIR%%/uidata/traditional/CompassRose.svg
+%%DATADIR%%/uidata/traditional/CompassRoseBlue.png
%%DATADIR%%/uidata/traditional/CompassRoseBlue.svg
%%DATADIR%%/uidata/traditional/colorscheme.svg
%%DATADIR%%/uidata/traditional/colorscheme_rollover.svg
@@ -1653,16 +1673,25 @@ share/locale/zh_TW/LC_MESSAGES/opencpn.mo
%%DATADIR%%/uidata/traditional/current_rollover_toggled.svg
%%DATADIR%%/uidata/traditional/current_toggled.svg
%%DATADIR%%/uidata/traditional/down.svg
+%%DATADIR%%/uidata/traditional/emblem-default.svg
+%%DATADIR%%/uidata/traditional/emblem-legacy-update.svg
+%%DATADIR%%/uidata/traditional/emblem-readonly.svg
+%%DATADIR%%/uidata/traditional/emblem-system.svg
+%%DATADIR%%/uidata/traditional/emblem-unmanaged.svg
%%DATADIR%%/uidata/traditional/follow.svg
%%DATADIR%%/uidata/traditional/follow_rollover.svg
%%DATADIR%%/uidata/traditional/follow_rollover_toggled.svg
%%DATADIR%%/uidata/traditional/follow_toggled.svg
+%%DATADIR%%/uidata/traditional/ghost.svg
%%DATADIR%%/uidata/traditional/gps1Bar.svg
%%DATADIR%%/uidata/traditional/gps2Bar.svg
%%DATADIR%%/uidata/traditional/gps3Bar.svg
%%DATADIR%%/uidata/traditional/gpsGrn.svg
%%DATADIR%%/uidata/traditional/gpsGry.svg
%%DATADIR%%/uidata/traditional/gpsRed.svg
+%%DATADIR%%/uidata/traditional/grabber.svg
+%%DATADIR%%/uidata/traditional/grabber_ext.svg
+%%DATADIR%%/uidata/traditional/grabber_hi.svg
%%DATADIR%%/uidata/traditional/help.svg
%%DATADIR%%/uidata/traditional/help_rollover.svg
%%DATADIR%%/uidata/traditional/left.svg
@@ -1686,6 +1715,7 @@ share/locale/zh_TW/LC_MESSAGES/opencpn.mo
%%DATADIR%%/uidata/traditional/scout_disabled.svg
%%DATADIR%%/uidata/traditional/scout_rollover.svg
%%DATADIR%%/uidata/traditional/settings.svg
+%%DATADIR%%/uidata/traditional/settings.svgo
%%DATADIR%%/uidata/traditional/settings_disabled.svg
%%DATADIR%%/uidata/traditional/settings_rollover.svg
%%DATADIR%%/uidata/traditional/text.svg