aboutsummaryrefslogtreecommitdiff
path: root/astro/openuniverse
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /astro/openuniverse
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'astro/openuniverse')
-rw-r--r--astro/openuniverse/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/astro/openuniverse/Makefile b/astro/openuniverse/Makefile
index bb1e6a67a066..74a482dc303d 100644
--- a/astro/openuniverse/Makefile
+++ b/astro/openuniverse/Makefile
@@ -9,8 +9,7 @@ PORTNAME= openuniverse
DISTVERSION= 1.0beta3
PORTREVISION= 4
CATEGORIES= astro
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= openuniverse
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenGL Solar System simulator for X Window System
@@ -26,8 +25,8 @@ USE_GMAKE= yes
CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib" \
-CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${X11BASE}/include/GL -I${LOCALBASE}/include" \
- LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib -lm" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/GL -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lm" \
LIBS="-lcompat" PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"