aboutsummaryrefslogtreecommitdiff
path: root/astro/openuniverse
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-03-13 17:14:49 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-03-13 17:14:49 +0000
commit7c43e8c026546a5d99be6a68983adbbe3ab9f7ae (patch)
tree975cacf546d50c3bfbd2f8ee990da57eeeb2cd06 /astro/openuniverse
parentd0d810fecbd18bb124c9183133b67b2f83ea7e86 (diff)
downloadports-7c43e8c026546a5d99be6a68983adbbe3ab9f7ae.tar.gz
ports-7c43e8c026546a5d99be6a68983adbbe3ab9f7ae.zip
- USE_X_PREFIX --> USE_XORG
- Use USE_GL instead of depending directly on glut - Beautify Makefile Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=208974
Diffstat (limited to 'astro/openuniverse')
-rw-r--r--astro/openuniverse/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/astro/openuniverse/Makefile b/astro/openuniverse/Makefile
index 6bdb525b55e8..bb1e6a67a066 100644
--- a/astro/openuniverse/Makefile
+++ b/astro/openuniverse/Makefile
@@ -6,19 +6,20 @@
#
PORTNAME= openuniverse
-PORTVERSION= 1.0.b3
-PORTREVISION= 3
+DISTVERSION= 1.0beta3
+PORTREVISION= 4
CATEGORIES= astro
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= openuniverse
-DISTNAME= ${PORTNAME}-1.0beta3
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenGL Solar System simulator for X Window System
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- glut.4:${PORTSDIR}/graphics/libglut
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+USE_GL= glut
+
+USE_XORG= sm ice xmu xi xext x11
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -30,6 +31,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${X11BASE}/include/GL -I${LOCALB
LIBS="-lcompat" PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
-USE_X_PREFIX= yes
-
.include <bsd.port.mk>