aboutsummaryrefslogtreecommitdiff
path: root/astro/p5-Astro-SIMBAD-Client
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-11 22:34:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-11 22:34:53 +0000
commit521b6c1c3f364a8c2c93965ee6c1fdc81c12d009 (patch)
treef96e373e22e317186bb5dca45faecba53010021c /astro/p5-Astro-SIMBAD-Client
parent6c3c68ffeae5df4de07df69da8a4478f505f6268 (diff)
downloadports-521b6c1c3f364a8c2c93965ee6c1fdc81c12d009.tar.gz
ports-521b6c1c3f364a8c2c93965ee6c1fdc81c12d009.zip
p5-Astro-SIMBAD-Client provides an object-oriented interface to
SIMBAD4. The new SOAP queries are supported, with the object carrying default output type and output format, as well as server name on the assumption that mirrors will be forthcoming. WWW: http://search.cpan.org/dist/Astro-SIMBAD-Client/ PR: ports/133602 Submitted by: Wen Heping <wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=232140
Diffstat (limited to 'astro/p5-Astro-SIMBAD-Client')
-rw-r--r--astro/p5-Astro-SIMBAD-Client/Makefile30
-rw-r--r--astro/p5-Astro-SIMBAD-Client/distinfo3
-rw-r--r--astro/p5-Astro-SIMBAD-Client/pkg-descr6
-rw-r--r--astro/p5-Astro-SIMBAD-Client/pkg-plist11
4 files changed, 50 insertions, 0 deletions
diff --git a/astro/p5-Astro-SIMBAD-Client/Makefile b/astro/p5-Astro-SIMBAD-Client/Makefile
new file mode 100644
index 000000000000..7cd3c53f2c83
--- /dev/null
+++ b/astro/p5-Astro-SIMBAD-Client/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: Astro-SIMBAD-Client
+# Date created: 11 April, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Astro-SIMBAD-Client
+PORTVERSION= 0.018
+CATEGORIES= astro perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= An object-oriented interface to SIMBAD4
+
+RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ p5-HTML-Parser>=3.60:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-SOAP-Lite>0:${PORTSDIR}/net/p5-SOAP-Lite \
+ p5-Scalar-List-Utils>=1.0.1:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-XML-DoubleEncodedEntities>=1.0:${PORTSDIR}/textproc/p5-XML-DoubleEncodedEntities
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= -y
+
+MAN1= simbadc.1
+MAN3= Astro::SIMBAD::Client.3
+
+.include <bsd.port.mk>
diff --git a/astro/p5-Astro-SIMBAD-Client/distinfo b/astro/p5-Astro-SIMBAD-Client/distinfo
new file mode 100644
index 000000000000..edb9cb9a7564
--- /dev/null
+++ b/astro/p5-Astro-SIMBAD-Client/distinfo
@@ -0,0 +1,3 @@
+MD5 (Astro-SIMBAD-Client-0.018.tar.gz) = 7f8395486c3e0e9924664f7df9ccf430
+SHA256 (Astro-SIMBAD-Client-0.018.tar.gz) = 62d86ed6dee5cc7c7e81bbb6aae60a359a312903f462b1aec4e8079c05c3e4fc
+SIZE (Astro-SIMBAD-Client-0.018.tar.gz) = 31887
diff --git a/astro/p5-Astro-SIMBAD-Client/pkg-descr b/astro/p5-Astro-SIMBAD-Client/pkg-descr
new file mode 100644
index 000000000000..b90bef112a07
--- /dev/null
+++ b/astro/p5-Astro-SIMBAD-Client/pkg-descr
@@ -0,0 +1,6 @@
+p5-Astro-SIMBAD-Client provides an object-oriented interface to
+SIMBAD4. The new SOAP queries are supported, with the object carrying
+default output type and output format, as well as server name on the
+assumption that mirrors will be forthcoming.
+
+WWW: http://search.cpan.org/dist/Astro-SIMBAD-Client/
diff --git a/astro/p5-Astro-SIMBAD-Client/pkg-plist b/astro/p5-Astro-SIMBAD-Client/pkg-plist
new file mode 100644
index 000000000000..ebbaac245cc2
--- /dev/null
+++ b/astro/p5-Astro-SIMBAD-Client/pkg-plist
@@ -0,0 +1,11 @@
+bin/simbadc
+%%SITE_PERL%%/Astro/SIMBAD/Client.pm
+%%SITE_PERL%%/Astro/SIMBAD/Client/WSQueryInterfaceService.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/SIMBAD/Client/.packlist
+@dirrm %%SITE_PERL%%/Astro/SIMBAD/Client
+@dirrm %%SITE_PERL%%/Astro/SIMBAD
+@dirrmtry %%SITE_PERL%%/Astro
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/SIMBAD/Client
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/SIMBAD
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro
+@dirrmtry %%SITE_PERL%%/Astro