aboutsummaryrefslogtreecommitdiff
path: root/astro/pp3
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-12-31 14:14:55 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-12-31 14:14:55 +0000
commitea9be90bac2538c364668bd8e7aac10fc05648ac (patch)
treee1a41c07f69b96859806d9a711eb7cf2e56efb93 /astro/pp3
parent0316d191b0793033247622ffe8b2f08e358949b6 (diff)
downloadports-ea9be90bac2538c364668bd8e7aac10fc05648ac.tar.gz
ports-ea9be90bac2538c364668bd8e7aac10fc05648ac.zip
Notes
Diffstat (limited to 'astro/pp3')
-rw-r--r--astro/pp3/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/astro/pp3/Makefile b/astro/pp3/Makefile
index f9abaec89d86..cda097192437 100644
--- a/astro/pp3/Makefile
+++ b/astro/pp3/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: pp3
-# Date created: Dec 24, 2003
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= pp3
PORTVERSION= 1.3.3
@@ -19,6 +14,8 @@ RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base
USE_BZIP2= yes
+.include <bsd.port.options.mk>
+
do-build:
cd ${WRKSRC} \
&& ${CXX} ${CXXFLAGS} -DPP3DATA=\"${DATADIR}\" pp3.cc -o pp3
@@ -27,12 +24,12 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pp3 ${PREFIX}/bin
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.dat ${DATADIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/WHATSNEW ${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif