aboutsummaryrefslogtreecommitdiff
path: root/astro/prune/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-25 13:43:32 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-25 13:43:32 +0000
commit36adcf8c6b041841eadcd6a1cefa32754180331f (patch)
treec0aaa71fbb753d56d12e8726a0b28f21653f5f3a /astro/prune/Makefile
parentee6434acd4e786bf90ea2fa649c677c98dd7905e (diff)
downloadports-36adcf8c6b041841eadcd6a1cefa32754180331f.tar.gz
ports-36adcf8c6b041841eadcd6a1cefa32754180331f.zip
Notes
Diffstat (limited to 'astro/prune/Makefile')
-rw-r--r--astro/prune/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/astro/prune/Makefile b/astro/prune/Makefile
new file mode 100644
index 000000000000..d5625ea12754
--- /dev/null
+++ b/astro/prune/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: prune
+# Date created: 25 Jun 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= prune
+PORTVERSION= 7
+CATEGORIES= astro java
+MASTER_SITES= http://activityworkshop.net/software/prune/ \
+ http://mirror.amdmi3.ru/distfiles/
+DISTNAME= ${PORTNAME}_0${PORTVERSION}
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY= # empty
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Application for viewing, editing and converting GPS coordinate data
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+
+SUB_FILES= prune.sh
+SUB_LIST= JARNAME=${DISTNAME}
+
+PLIST_FILES= bin/prune ${JAVAJARDIR:C,${PREFIX}/?,,}/${DISTNAME}
+
+do-install:
+ ${MKDIR} ${JAVAJARDIR}/
+ ${INSTALL_DATA} ${DISTDIR}/${DISTNAME} ${JAVAJARDIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/prune.sh ${PREFIX}/bin/prune
+
+.include <bsd.port.mk>