aboutsummaryrefslogtreecommitdiff
path: root/astro/py-RO
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-30 06:42:43 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-30 06:42:43 +0000
commitf21ba409cbc682a2f675c9ca3b80c8392822f0a9 (patch)
tree6cdbe55a8c40b896fac0de376d878cb62dbd896b /astro/py-RO
parente3f9f84e52847a3afd64a08aab2b1403c7968151 (diff)
downloadports-f21ba409cbc682a2f675c9ca3b80c8392822f0a9.tar.gz
ports-f21ba409cbc682a2f675c9ca3b80c8392822f0a9.zip
Notes
Diffstat (limited to 'astro/py-RO')
-rw-r--r--astro/py-RO/Makefile14
-rw-r--r--astro/py-RO/files/patch-tools-fitsinfo.py11
2 files changed, 19 insertions, 6 deletions
diff --git a/astro/py-RO/Makefile b/astro/py-RO/Makefile
index fb7ac2537909..741c9c110d04 100644
--- a/astro/py-RO/Makefile
+++ b/astro/py-RO/Makefile
@@ -3,6 +3,7 @@
PORTNAME= RO
PORTVERSION= 3.6.9
+PORTREVISION= 1
CATEGORIES= astro python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,18 +16,19 @@ LICENSE= MIT
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/numeric.py:math/py-numpy@${FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-OPTIONS_DEFINE= MATPLOTLIB PYFITS PYGAME
-OPTIONS_DEFAULT= PYFITS
+OPTIONS_DEFINE= ASTROPY MATPLOTLIB PYGAME
+OPTIONS_DEFAULT= ASTROPY
+ASTROPY_DESC= Add Support for Astropy
MATPLOTLIB_DESC= Add support for Matplotlib
-PYFITS_DESC= Add Support for PyFITS
PYGAME_DESC= Add Support for PyGame
+NO_ARCH= yes
USES= python
USE_PYTHON= autoplist distutils
-MATPLOTLIB_RUN_DEPENDS= ${PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${FLAVOR}
-PYFITS_RUN_DEPENDS= ${PKGNAMEPREFIX}pyfits>=1.1:astro/py-pyfits@${FLAVOR}
-PYGAME_RUN_DEPENDS= ${PKGNAMEPREFIX}game>=1.8.1:devel/py-game@${FLAVOR}
+ASTROPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>=0:astro/py-astropy@${FLAVOR}
+MATPLOTLIB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${FLAVOR}
+PYGAME_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>=1.8.1:devel/py-game@${FLAVOR}
.include <bsd.port.mk>
diff --git a/astro/py-RO/files/patch-tools-fitsinfo.py b/astro/py-RO/files/patch-tools-fitsinfo.py
new file mode 100644
index 000000000000..0cc4adc15424
--- /dev/null
+++ b/astro/py-RO/files/patch-tools-fitsinfo.py
@@ -0,0 +1,11 @@
+--- tools/fitsinfo.py.orig 2014-09-18 18:19:45 UTC
++++ tools/fitsinfo.py
+@@ -2,7 +2,7 @@
+ from __future__ import absolute_import, division, print_function
+ import argparse
+ import numpy
+-import pyfits
++import astropy.io.fits as pyfits
+
+ def fitsInfo(filePath, hduList=None, showHeader=True, showStats=True):
+ """Print information about a FITS file