aboutsummaryrefslogtreecommitdiff
path: root/astro/py-astropy
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-01-21 21:17:27 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-01-21 21:17:27 +0000
commit4aeef20d8f6c1ad6ef539bdbfc3a5682f5dfd903 (patch)
tree4f00e03c6fb4781500c8fbd626dd6c052d9e8f5b /astro/py-astropy
parent27b090319716dd29353a2c46024c927675ce9707 (diff)
downloadports-4aeef20d8f6c1ad6ef539bdbfc3a5682f5dfd903.tar.gz
ports-4aeef20d8f6c1ad6ef539bdbfc3a5682f5dfd903.zip
astro/py-astropy: Update 1.1.2 -> 3.1.1
Port changes: * Replace WWW with the https version * Now only works for pythion 3.5+ * Add a fix for the wrong plist problem * Remove patches for compiler warnings, reported them upstream PR: 231279 Approved by: nwhitehorn@FreeBSD.org (maintainer's timeout; 132 days)
Notes
Notes: svn path=/head/; revision=490900
Diffstat (limited to 'astro/py-astropy')
-rw-r--r--astro/py-astropy/Makefile10
-rw-r--r--astro/py-astropy/distinfo6
-rw-r--r--astro/py-astropy/files/patch-astropy_io_fits_setup__package.py11
-rw-r--r--astro/py-astropy/files/patch-astropy_modeling_setup__package.py12
-rw-r--r--astro/py-astropy/files/patch-astropy_wcs_setup__package.py12
-rw-r--r--astro/py-astropy/pkg-descr2
6 files changed, 11 insertions, 42 deletions
diff --git a/astro/py-astropy/Makefile b/astro/py-astropy/Makefile
index a823102fcfaf..fa45287d2d0d 100644
--- a/astro/py-astropy/Makefile
+++ b/astro/py-astropy/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= astropy
-PORTVERSION= 1.1.2
-PORTREVISION= 2
+PORTVERSION= 3.1.1
CATEGORIES= astro
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +15,12 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY}
-USES= python
+USES= python:3.5+
USE_PYTHON= autoplist distutils
+POST_PLIST= rm-bogus-plist-files
+
+rm-bogus-plist-files: # https://github.com/astropy/astropy/issues/8364
+ @${REINPLACE_CMD} '/.*\.\.\/wcs\/tests/d' ${TMPPLIST}
+
.include <bsd.port.mk>
diff --git a/astro/py-astropy/distinfo b/astro/py-astropy/distinfo
index 2f23e3987cb1..908408fdd381 100644
--- a/astro/py-astropy/distinfo
+++ b/astro/py-astropy/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1465919806
-SHA256 (astropy-1.1.2.tar.gz) = 6f0d84cd7dfb304bb437dda666406a1d42208c16204043bc920308ff8ffdfad1
-SIZE (astropy-1.1.2.tar.gz) = 8059713
+TIMESTAMP = 1548103725
+SHA256 (astropy-3.1.1.tar.gz) = 6527e63f9aee01ed14a3e3c0865f8ae1bffadb01c8c755b4452662211216f53b
+SIZE (astropy-3.1.1.tar.gz) = 8204190
diff --git a/astro/py-astropy/files/patch-astropy_io_fits_setup__package.py b/astro/py-astropy/files/patch-astropy_io_fits_setup__package.py
deleted file mode 100644
index e1fa9457aea1..000000000000
--- a/astro/py-astropy/files/patch-astropy_io_fits_setup__package.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- astropy/io/fits/setup_package.py.orig 2016-03-10 22:20:43 UTC
-+++ astropy/io/fits/setup_package.py
-@@ -39,7 +39,7 @@ def _get_compression_extension():
- '-Wno-uninitialized', '-Wno-format',
- '-Wno-strict-prototypes', '-Wno-unused', '-Wno-comments',
- '-Wno-switch', '-Wno-strict-aliasing', '-Wno-return-type',
-- '-Wno-address', '-Wno-unused-result'
-+ '-Wno-address'
- ])
-
- cfitsio_path = os.path.join('cextern', 'cfitsio')
diff --git a/astro/py-astropy/files/patch-astropy_modeling_setup__package.py b/astro/py-astropy/files/patch-astropy_modeling_setup__package.py
deleted file mode 100644
index 98bdaa5f7dda..000000000000
--- a/astro/py-astropy/files/patch-astropy_modeling_setup__package.py
+++ /dev/null
@@ -1,12 +0,0 @@
---- astropy/modeling/setup_package.py.orig 2016-03-10 22:20:43 UTC
-+++ astropy/modeling/setup_package.py
-@@ -123,8 +123,7 @@ def preprocess_source():
-
- def get_package_data():
- return {
-- 'astropy.modeling.tests': ['data/*.fits', 'data/*.hdr',
-- '../../wcs/tests/maps/*.hdr']
-+ 'astropy.modeling.tests': ['data/*.fits', 'data/*.hdr' ]
- }
-
-
diff --git a/astro/py-astropy/files/patch-astropy_wcs_setup__package.py b/astro/py-astropy/files/patch-astropy_wcs_setup__package.py
deleted file mode 100644
index a2a12f28f3d8..000000000000
--- a/astro/py-astropy/files/patch-astropy_wcs_setup__package.py
+++ /dev/null
@@ -1,12 +0,0 @@
---- astropy/wcs/setup_package.py.orig 2016-03-10 22:20:43 UTC
-+++ astropy/wcs/setup_package.py
-@@ -244,8 +244,7 @@ def get_wcslib_cfg(cfg, wcslib_files, in
- '-Wno-strict-prototypes',
- '-Wno-unused-function',
- '-Wno-unused-value',
-- '-Wno-uninitialized',
-- '-Wno-unused-but-set-variable'])
-+ '-Wno-uninitialized'])
-
-
-
diff --git a/astro/py-astropy/pkg-descr b/astro/py-astropy/pkg-descr
index acce28f2744c..484b76ca15cf 100644
--- a/astro/py-astropy/pkg-descr
+++ b/astro/py-astropy/pkg-descr
@@ -3,4 +3,4 @@ tools needed for performing astronomy and astrophysics research with Python. It
also provides an index for other astronomy packages and tools for managing
them.
-WWW: http://www.astropy.org
+WWW: https://www.astropy.org