aboutsummaryrefslogtreecommitdiff
path: root/astro/py-metar
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-07-27 16:27:31 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-07-27 16:27:31 +0000
commit6f950576f995cd0ca59d7e7d516202e1c401df23 (patch)
tree194ddd8cf9c83cb63dc540eb4948d143fcbe6788 /astro/py-metar
parent1075ba838cd70b41af0e28eb41108ee8b19b438f (diff)
downloadports-6f950576f995cd0ca59d7e7d516202e1c401df23.tar.gz
ports-6f950576f995cd0ca59d7e7d516202e1c401df23.zip
- Cleanup Makefile
Notes
Notes: svn path=/head/; revision=363081
Diffstat (limited to 'astro/py-metar')
-rw-r--r--astro/py-metar/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/astro/py-metar/Makefile b/astro/py-metar/Makefile
index 7c78e1e5e43f..6b74630e4c4f 100644
--- a/astro/py-metar/Makefile
+++ b/astro/py-metar/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= astro python geography
MASTER_SITES= http://www.schwarzvogel.de/pkgs/ \
LOCAL/sunpoet
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= ${REALPORTNAME}-${PORTVERSION}
+DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python module that provides access to NOAA METAR weather reports
@@ -25,13 +25,11 @@ USES= shebangfix
PORTDOCS= COPYING README THANKS librarydoc.txt
-REALPORTNAME= pymetar
-
-SHEBANG_FILES= bin/${REALPORTNAME}
+SHEBANG_FILES= bin/py${PORTNAME}
python_CMD= ${PYTHON_CMD}
post-patch:
@${REINPLACE_CMD} -e 's|share/\(man/man1\)|\1|' \
- -e 's|"share/doc/pymetar-%s"%pymetar.__version__|"${DOCSDIR}"|' ${WRKSRC}/${PYSETUP}
+ -e 's|"share/doc/pymetar-%s"%pymetar.__version__|"${DOCSDIR}"|' ${WRKSRC}/setup.py
.include <bsd.port.mk>