aboutsummaryrefslogtreecommitdiff
path: root/astro/py-spktype01
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-02-27 18:27:26 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-02-27 18:27:26 +0000
commit94dbf3b119a7fc3832364cfb53f3cdad777aa0b6 (patch)
tree7195b93b3523ecf746498f7c08e40c01a537f883 /astro/py-spktype01
parent0385ff5febb381c31267c9a57dfd8478b9600b78 (diff)
downloadports-94dbf3b119a7fc3832364cfb53f3cdad777aa0b6.tar.gz
ports-94dbf3b119a7fc3832364cfb53f3cdad777aa0b6.zip
Adding spktype01 and spktype21, two supporting modules for jplephem to handle data type 1 and 21.
Notes
Notes: svn path=/head/; revision=566726
Diffstat (limited to 'astro/py-spktype01')
-rw-r--r--astro/py-spktype01/Makefile33
-rw-r--r--astro/py-spktype01/distinfo3
-rw-r--r--astro/py-spktype01/pkg-descr15
3 files changed, 51 insertions, 0 deletions
diff --git a/astro/py-spktype01/Makefile b/astro/py-spktype01/Makefile
new file mode 100644
index 000000000000..06e0f2c3b543
--- /dev/null
+++ b/astro/py-spktype01/Makefile
@@ -0,0 +1,33 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= spktype01
+PORTVERSION= 1.0.0
+CATEGORIES= astro python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Supporting module for jplephem to handle data type 1
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${NUMPY}
+RUN_DEPENDS= ${NUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}jplephem>0:astro/py-jplephem@${PY_FLAVOR}
+
+USE_GITHUB= yes
+GH_ACCOUNT= whiskie14142
+GH_TAGNAME= 964cc70
+
+USES= python:3.7+
+USE_PYTHON= distutils
+
+WRKSRC_SUBDIR= package/${PORTNAME}
+TEST_WRKSRC= ${WRKSRC}/../../test
+NO_ARCH= yes
+
+PLIST_FILES= ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}/__pycache__/spktype01.cpython-${PYTHON_SUFFIX}.opt-1.pyc \
+ ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}/__pycache__/spktype01.cpython-${PYTHON_SUFFIX}.pyc \
+ ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}/spktype01.py
+
+.include <bsd.port.mk>
diff --git a/astro/py-spktype01/distinfo b/astro/py-spktype01/distinfo
new file mode 100644
index 000000000000..70325e58fa44
--- /dev/null
+++ b/astro/py-spktype01/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1613725418
+SHA256 (whiskie14142-spktype01-1.0.0-964cc70_GH0.tar.gz) = 4ca5ad6e18be4bd6558c33cda3685d9fb135c3a25de2a32ccfd67755c4972c8a
+SIZE (whiskie14142-spktype01-1.0.0-964cc70_GH0.tar.gz) = 2401389
diff --git a/astro/py-spktype01/pkg-descr b/astro/py-spktype01/pkg-descr
new file mode 100644
index 000000000000..c171f94369b8
--- /dev/null
+++ b/astro/py-spktype01/pkg-descr
@@ -0,0 +1,15 @@
+This module computes positions and velocities of a celestial small body, from a
+NASA SPICE SPK ephemeris kernel file of data type 1 (Modified Difference
+Arrays).
+See http://naif.jpl.nasa.gov/pub/naif/toolkit_docs/FORTRAN/req/spk.html
+
+You can get SPK files for many solar system small bodies from HORIZONS system of
+NASA/JPL.
+See https://ssd.jpl.nasa.gov/?horizons
+
+This module reads SPK files of data type 1, one of the types of binary SPK file.
+At the point of Oct. 2018, HORIZONS system provides files of type 21 as binary
+SPK files by default. You can get type 1 binary SPK file for celestial small
+bodies through TELNET interface by answering back '1' for 'SPK file format'.
+
+WWW: https://github.com/whiskie14142/spktype01