aboutsummaryrefslogtreecommitdiff
path: root/astro/pykep
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-28 05:16:00 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-28 05:16:00 +0000
commitc7b6cdec8bbc9163e4cca43bd48d3bcb64286532 (patch)
treeab397c67d44c194f15be92ff97817eb820a282dd /astro/pykep
parentdeef461fad4b99336f5eecdd22d09718931bed00 (diff)
downloadports-c7b6cdec8bbc9163e4cca43bd48d3bcb64286532.tar.gz
ports-c7b6cdec8bbc9163e4cca43bd48d3bcb64286532.zip
New port: astro/pykep: C++ library providing basic tools for astrodynamics research
Notes
Notes: svn path=/head/; revision=566746
Diffstat (limited to 'astro/pykep')
-rw-r--r--astro/pykep/Makefile24
-rw-r--r--astro/pykep/distinfo3
-rw-r--r--astro/pykep/pkg-descr10
-rw-r--r--astro/pykep/pkg-plist116
4 files changed, 153 insertions, 0 deletions
diff --git a/astro/pykep/Makefile b/astro/pykep/Makefile
new file mode 100644
index 000000000000..77778ddc1ec1
--- /dev/null
+++ b/astro/pykep/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= pykep
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.6
+CATEGORIES= astro
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ library providing basic tools for astrodynamics research
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libboost_serialization.so:devel/boost-libs
+
+USES= cmake compiler:c++11-lang
+USE_LDCONFIG= yes
+
+CMAKE_OFF= PYKEP_BUILD_TESTS
+
+USE_GITHUB= yes
+GH_ACCOUNT= esa
+
+.include <bsd.port.mk>
diff --git a/astro/pykep/distinfo b/astro/pykep/distinfo
new file mode 100644
index 000000000000..4acc6b257ef9
--- /dev/null
+++ b/astro/pykep/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614487843
+SHA256 (esa-pykep-v2.6_GH0.tar.gz) = 67ba9a45b51ce9e99117621a4901095c5404c7ec285ac58e7782c94f37c65de7
+SIZE (esa-pykep-v2.6_GH0.tar.gz) = 31000269
diff --git a/astro/pykep/pkg-descr b/astro/pykep/pkg-descr
new file mode 100644
index 000000000000..92a24c41795b
--- /dev/null
+++ b/astro/pykep/pkg-descr
@@ -0,0 +1,10 @@
+pykep is a scientific library providing basic tools for astrodynamics research.
+Algorithmic efficiency is a main focus of the library, which is written in C++
+and exposed to Python using the boost::python library. At the library core is
+the implementation of an efficient solver for the multiple revolutions Lambert's
+problem, objects representing direct (Sims-Flanagan), indirect (Pontryagin) and
+hybrid methods to represent low-thrust optimization problems, efficient
+keplerian propagators, Taylor-integrators, a SGP4 propagator, TLE and SATCAT
+support and more.
+
+WWW: https://github.com/esa/pykep
diff --git a/astro/pykep/pkg-plist b/astro/pykep/pkg-plist
new file mode 100644
index 000000000000..24e530df66d2
--- /dev/null
+++ b/astro/pykep/pkg-plist
@@ -0,0 +1,116 @@
+include/keplerian_toolbox/astro_constants.hpp
+include/keplerian_toolbox/config.hpp
+include/keplerian_toolbox/core_functions/array3D_operations.hpp
+include/keplerian_toolbox/core_functions/closest_distance.hpp
+include/keplerian_toolbox/core_functions/convert_anomalies.hpp
+include/keplerian_toolbox/core_functions/convert_dates.hpp
+include/keplerian_toolbox/core_functions/damon.hpp
+include/keplerian_toolbox/core_functions/eq2ic.hpp
+include/keplerian_toolbox/core_functions/eq2par.hpp
+include/keplerian_toolbox/core_functions/fb_con.hpp
+include/keplerian_toolbox/core_functions/fb_prop.hpp
+include/keplerian_toolbox/core_functions/fb_vel.hpp
+include/keplerian_toolbox/core_functions/ic2eq.hpp
+include/keplerian_toolbox/core_functions/ic2par.hpp
+include/keplerian_toolbox/core_functions/jorba.h
+include/keplerian_toolbox/core_functions/kepler_equations.hpp
+include/keplerian_toolbox/core_functions/lambert_2d.hpp
+include/keplerian_toolbox/core_functions/lambert_3d.hpp
+include/keplerian_toolbox/core_functions/lambert_find_N.hpp
+include/keplerian_toolbox/core_functions/par2eq.hpp
+include/keplerian_toolbox/core_functions/par2ic.hpp
+include/keplerian_toolbox/core_functions/propagate_lagrangian.hpp
+include/keplerian_toolbox/core_functions/propagate_lagrangian_u.hpp
+include/keplerian_toolbox/core_functions/propagate_taylor.hpp
+include/keplerian_toolbox/core_functions/propagate_taylor_J2.hpp
+include/keplerian_toolbox/core_functions/propagate_taylor_disturbance.hpp
+include/keplerian_toolbox/core_functions/propagate_taylor_jorba.hpp
+include/keplerian_toolbox/core_functions/propagate_taylor_s.hpp
+include/keplerian_toolbox/core_functions/stumpff.hpp
+include/keplerian_toolbox/core_functions/three_impulses_approximation.hpp
+include/keplerian_toolbox/core_functions/x2tof.hpp
+include/keplerian_toolbox/detail/visibility.hpp
+include/keplerian_toolbox/epoch.hpp
+include/keplerian_toolbox/exceptions.hpp
+include/keplerian_toolbox/io.hpp
+include/keplerian_toolbox/keplerian_toolbox.hpp
+include/keplerian_toolbox/lambert_problem.hpp
+include/keplerian_toolbox/numerics/newton_raphson.hpp
+include/keplerian_toolbox/numerics/regula_falsi.hpp
+include/keplerian_toolbox/planet/base.hpp
+include/keplerian_toolbox/planet/gtoc2.hpp
+include/keplerian_toolbox/planet/gtoc5.hpp
+include/keplerian_toolbox/planet/gtoc6.hpp
+include/keplerian_toolbox/planet/gtoc7.hpp
+include/keplerian_toolbox/planet/j2.hpp
+include/keplerian_toolbox/planet/jpl_low_precision.hpp
+include/keplerian_toolbox/planet/keplerian.hpp
+include/keplerian_toolbox/planet/mpcorb.hpp
+include/keplerian_toolbox/planet/spice.hpp
+include/keplerian_toolbox/planet/tle.hpp
+include/keplerian_toolbox/serialization.hpp
+include/keplerian_toolbox/sims_flanagan/leg.hpp
+include/keplerian_toolbox/sims_flanagan/leg_s.hpp
+include/keplerian_toolbox/sims_flanagan/sc_state.hpp
+include/keplerian_toolbox/sims_flanagan/spacecraft.hpp
+include/keplerian_toolbox/sims_flanagan/throttle.hpp
+include/keplerian_toolbox/third_party/cspice/SpiceCK.h
+include/keplerian_toolbox/third_party/cspice/SpiceCel.h
+include/keplerian_toolbox/third_party/cspice/SpiceDLA.h
+include/keplerian_toolbox/third_party/cspice/SpiceDSK.h
+include/keplerian_toolbox/third_party/cspice/SpiceDtl.h
+include/keplerian_toolbox/third_party/cspice/SpiceEK.h
+include/keplerian_toolbox/third_party/cspice/SpiceEll.h
+include/keplerian_toolbox/third_party/cspice/SpiceErr.h
+include/keplerian_toolbox/third_party/cspice/SpiceFrm.h
+include/keplerian_toolbox/third_party/cspice/SpiceGF.h
+include/keplerian_toolbox/third_party/cspice/SpiceOccult.h
+include/keplerian_toolbox/third_party/cspice/SpiceOsc.h
+include/keplerian_toolbox/third_party/cspice/SpicePln.h
+include/keplerian_toolbox/third_party/cspice/SpiceSPK.h
+include/keplerian_toolbox/third_party/cspice/SpiceSrf.h
+include/keplerian_toolbox/third_party/cspice/SpiceUsr.h
+include/keplerian_toolbox/third_party/cspice/SpiceZad.h
+include/keplerian_toolbox/third_party/cspice/SpiceZdf.h
+include/keplerian_toolbox/third_party/cspice/SpiceZfc.h
+include/keplerian_toolbox/third_party/cspice/SpiceZim.h
+include/keplerian_toolbox/third_party/cspice/SpiceZmc.h
+include/keplerian_toolbox/third_party/cspice/SpiceZpl.h
+include/keplerian_toolbox/third_party/cspice/SpiceZpr.h
+include/keplerian_toolbox/third_party/cspice/SpiceZrnm.h
+include/keplerian_toolbox/third_party/cspice/SpiceZst.h
+include/keplerian_toolbox/third_party/cspice/f2c.h
+include/keplerian_toolbox/third_party/cspice/f2cMang.h
+include/keplerian_toolbox/third_party/cspice/fio.h
+include/keplerian_toolbox/third_party/cspice/fmt.h
+include/keplerian_toolbox/third_party/cspice/fp.h
+include/keplerian_toolbox/third_party/cspice/lio.h
+include/keplerian_toolbox/third_party/cspice/rawio.h
+include/keplerian_toolbox/third_party/cspice/signal1.h
+include/keplerian_toolbox/third_party/cspice/zzalloc.h
+include/keplerian_toolbox/third_party/cspice/zzerror.h
+include/keplerian_toolbox/third_party/libsgp4/CoordGeodetic.h
+include/keplerian_toolbox/third_party/libsgp4/CoordTopocentric.h
+include/keplerian_toolbox/third_party/libsgp4/DateTime.h
+include/keplerian_toolbox/third_party/libsgp4/DecayedException.h
+include/keplerian_toolbox/third_party/libsgp4/Eci.h
+include/keplerian_toolbox/third_party/libsgp4/Globals.h
+include/keplerian_toolbox/third_party/libsgp4/Observer.h
+include/keplerian_toolbox/third_party/libsgp4/OrbitalElements.h
+include/keplerian_toolbox/third_party/libsgp4/SGP4.h
+include/keplerian_toolbox/third_party/libsgp4/SatelliteException.h
+include/keplerian_toolbox/third_party/libsgp4/SolarPosition.h
+include/keplerian_toolbox/third_party/libsgp4/TimeSpan.h
+include/keplerian_toolbox/third_party/libsgp4/Tle.h
+include/keplerian_toolbox/third_party/libsgp4/TleException.h
+include/keplerian_toolbox/third_party/libsgp4/Util.h
+include/keplerian_toolbox/third_party/libsgp4/Vector.h
+include/keplerian_toolbox/util/spice_utils.hpp
+lib/cmake/keplerian_toolbox/PykepFindBoost.cmake
+lib/cmake/keplerian_toolbox/keplerian_toolbox-config-version.cmake
+lib/cmake/keplerian_toolbox/keplerian_toolbox-config.cmake
+lib/cmake/keplerian_toolbox/keplerian_toolbox_export-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/keplerian_toolbox/keplerian_toolbox_export.cmake
+lib/libkeplerian_toolbox.so
+lib/libkeplerian_toolbox.so.1
+lib/libkeplerian_toolbox.so.1.0