aboutsummaryrefslogtreecommitdiff
path: root/astro/qmapshack
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2018-09-29 15:05:36 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2018-09-29 15:05:36 +0000
commit3f5efd41bc2fe9f6ced9b96aa803e2a83fc159b3 (patch)
treec87beb3639b48ff1b0a267d7df52c6bff6d012d8 /astro/qmapshack
parentf52c1200516b78ef4f1a5fde3f5a2e0fec87f586 (diff)
downloadports-3f5efd41bc2fe9f6ced9b96aa803e2a83fc159b3.tar.gz
ports-3f5efd41bc2fe9f6ced9b96aa803e2a83fc159b3.zip
astro/qmapshack: update to 1.12.0
Announcement: https://sourceforge.net/p/qlandkartegt/mailman/message/36406997/ PR: 231359 Approved by: maintainer-timeout (bofh)
Notes
Notes: svn path=/head/; revision=480909
Diffstat (limited to 'astro/qmapshack')
-rw-r--r--astro/qmapshack/Makefile8
-rw-r--r--astro/qmapshack/distinfo6
-rw-r--r--astro/qmapshack/files/patch-hg_e9b47af19
3 files changed, 7 insertions, 26 deletions
diff --git a/astro/qmapshack/Makefile b/astro/qmapshack/Makefile
index 761f5c7e1c79..95407698cef2 100644
--- a/astro/qmapshack/Makefile
+++ b/astro/qmapshack/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qmapshack
-PORTVERSION= 1.11.1
-PORTREVISION= 1
+PORTVERSION= 1.12.0
CATEGORIES= astro
MASTER_SITES= https://bitbucket.org/maproom/qmapshack/downloads/
@@ -20,7 +19,8 @@ LIB_DEPENDS= libgdal.so:graphics/gdal \
RUN_DEPENDS= ${LOCALBASE}/bin/bsdisks:sysutils/bsdisks
USES= cmake compiler:c++11-lib desktop-file-utils jpeg qt:5
-USE_QT= buildtools core dbus gui linguisttools network printsupport \
- qmake script sql sql-sqlite3 uitools webkit widgets xml
+USE_QT= buildtools core dbus gui linguisttools location network \
+ printsupport qmake qml quick sql sql-sqlite3 uitools \
+ webchannel webengine widgets xml
.include <bsd.port.mk>
diff --git a/astro/qmapshack/distinfo b/astro/qmapshack/distinfo
index 4b39152c3346..050ca2515002 100644
--- a/astro/qmapshack/distinfo
+++ b/astro/qmapshack/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1524141966
-SHA256 (qmapshack-1.11.1.tar.gz) = 3e65e443665041bb4c10ebd10fb49ca6df9015d9cecd2551a888bbdaa8a3117b
-SIZE (qmapshack-1.11.1.tar.gz) = 11446871
+TIMESTAMP = 1536321097
+SHA256 (qmapshack-1.12.0.tar.gz) = 30ee69165a8548b529d5d9679da52099226405b9285b42b18342dd842730b734
+SIZE (qmapshack-1.12.0.tar.gz) = 12030329
diff --git a/astro/qmapshack/files/patch-hg_e9b47af b/astro/qmapshack/files/patch-hg_e9b47af
deleted file mode 100644
index 603d9acb0ef3..000000000000
--- a/astro/qmapshack/files/patch-hg_e9b47af
+++ /dev/null
@@ -1,19 +0,0 @@
-# HG changeset patch
-# User kiozen
-# Date 1528899896 -7200
-# Node ID e9b47af61b0945acb74649bab30dec23ac42f375
-# Parent f52eedfb8f94ea218eb1c55bb8f2fa0c0503238f
-[Issue #344 ] Building latest version of QMapShack fails after updating QT from 5.10.1 to 5.11.0
-
-diff --git a/src/qmapshack/helpers/CToolBarSetupDialog.cpp b/src/qmapshack/helpers/CToolBarSetupDialog.cpp
---- src/qmapshack/helpers/CToolBarSetupDialog.cpp
-+++ src/qmapshack/helpers/CToolBarSetupDialog.cpp
-@@ -20,6 +20,8 @@
- #include "helpers/CToolBarConfig.h"
- #include "helpers/CToolBarSetupDialog.h"
-
-+#include <QAction>
-+
- bool CToolBarSetupDialog::CItemFilter::shouldBeMoved(QListWidgetItem *item)
- {
- CDialogItem * dialogItem = dynamic_cast<CDialogItem *>(item);