aboutsummaryrefslogtreecommitdiff
path: root/astro/qmapshack
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2016-07-14 18:39:51 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2016-07-14 18:39:51 +0000
commit426df6c6b8b9c320c9b8b6920560c22e220f5e08 (patch)
treee89f440803403a330cc919c7d41cb9ea0ec809a5 /astro/qmapshack
parentbca2c77b6a6d340bdd51571a2a461f5af6c7e625 (diff)
downloadports-426df6c6b8b9c320c9b8b6920560c22e220f5e08.tar.gz
ports-426df6c6b8b9c320c9b8b6920560c22e220f5e08.zip
astro/qmapshack: Update version 1.6.1=>1.6.3
- Upstream FreeBSD support PR: 210808 Submitted by: cmt
Notes
Notes: svn path=/head/; revision=418552
Diffstat (limited to 'astro/qmapshack')
-rw-r--r--astro/qmapshack/Makefile3
-rw-r--r--astro/qmapshack/distinfo6
-rw-r--r--astro/qmapshack/files/patch-src_device_IDevice.cpp29
-rw-r--r--astro/qmapshack/files/patch-src_gis_CGisListWks.cpp20
-rw-r--r--astro/qmapshack/files/patch-src_setup_IAppSetup.cpp11
-rw-r--r--astro/qmapshack/pkg-plist15
6 files changed, 20 insertions, 64 deletions
diff --git a/astro/qmapshack/Makefile b/astro/qmapshack/Makefile
index 2149017bcf21..f5951c02ecea 100644
--- a/astro/qmapshack/Makefile
+++ b/astro/qmapshack/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qmapshack
-PORTVERSION= 1.6.1
+PORTVERSION= 1.6.3
CATEGORIES= astro
MASTER_SITES= https://bitbucket.org/maproom/qmapshack/downloads/
@@ -15,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgdal.so:graphics/gdal \
libproj.so:graphics/proj \
libroutino.so:astro/routino
+RUN_DEPENDS= ${LOCALBASE}/bin/bsdisks:sysutils/bsdisks
USES= cmake compiler:c++11-lib desktop-file-utils
USE_QT5= buildtools core dbus gui linguisttools network printsupport \
diff --git a/astro/qmapshack/distinfo b/astro/qmapshack/distinfo
index 038b64a186b8..7c77407d2503 100644
--- a/astro/qmapshack/distinfo
+++ b/astro/qmapshack/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1465057676
-SHA256 (qmapshack-1.6.1.tar.gz) = e702482ef894ec3fdbc5a932dd220bbb34eef1580b1645a314e9a3fa99956c22
-SIZE (qmapshack-1.6.1.tar.gz) = 4538423
+TIMESTAMP = 1468517493
+SHA256 (qmapshack-1.6.3.tar.gz) = 6fa5158bd823e8d43eb8a4e4db35a05720d1fe8d624eb65320b905ae315bd708
+SIZE (qmapshack-1.6.3.tar.gz) = 5181205
diff --git a/astro/qmapshack/files/patch-src_device_IDevice.cpp b/astro/qmapshack/files/patch-src_device_IDevice.cpp
deleted file mode 100644
index 518ff5cc2600..000000000000
--- a/astro/qmapshack/files/patch-src_device_IDevice.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/device/IDevice.cpp.orig 2016-06-04 19:56:45 UTC
-+++ src/device/IDevice.cpp
-@@ -22,7 +22,7 @@
- #include "gis/prj/IGisProject.h"
- #include "helpers/CSelectCopyAction.h"
-
--#ifdef Q_OS_LINUX
-+#if defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
- #include <QtDBus>
- #endif
-
-@@ -52,7 +52,7 @@ IDevice::~IDevice()
-
- void IDevice::mount(const QString& path)
- {
--#ifdef Q_OS_LINUX
-+#if defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
- QDBusMessage message = QDBusMessage::createMethodCall("org.freedesktop.UDisks2",path,"org.freedesktop.UDisks2.Filesystem","Mount");
- QVariantMap args;
- args.insert("options", "sync");
-@@ -63,7 +63,7 @@ void IDevice::mount(const QString& path)
-
- void IDevice::umount(const QString &path)
- {
--#ifdef Q_OS_LINUX
-+#if defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
- QDBusMessage message = QDBusMessage::createMethodCall("org.freedesktop.UDisks2",path,"org.freedesktop.UDisks2.Filesystem","Unmount");
- QVariantMap args;
- message << args;
diff --git a/astro/qmapshack/files/patch-src_gis_CGisListWks.cpp b/astro/qmapshack/files/patch-src_gis_CGisListWks.cpp
deleted file mode 100644
index 856f24840cd3..000000000000
--- a/astro/qmapshack/files/patch-src_gis_CGisListWks.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/gis/CGisListWks.cpp.orig 2016-06-04 19:56:53 UTC
-+++ src/gis/CGisListWks.cpp
-@@ -18,7 +18,7 @@
-
- #include "CMainWindow.h"
- #include "canvas/CCanvas.h"
--#ifdef Q_OS_LINUX
-+#if defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
- #include "device/CDeviceWatcherLinux.h"
- #endif
- #ifdef Q_OS_WIN
-@@ -196,7 +196,7 @@ CGisListWks::CGisListWks(QWidget *parent
- QTimer::singleShot(saveEvery * 60000, this, SLOT(slotSaveWorkspace()));
- }
-
--#ifdef Q_OS_LINUX
-+#if defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
- deviceWatcher = new CDeviceWatcherLinux(this);
- connect(deviceWatcher, &CDeviceWatcherLinux::sigChanged, this, &CGisListWks::sigChanged);
- #endif
diff --git a/astro/qmapshack/files/patch-src_setup_IAppSetup.cpp b/astro/qmapshack/files/patch-src_setup_IAppSetup.cpp
deleted file mode 100644
index b1964feeeaa8..000000000000
--- a/astro/qmapshack/files/patch-src_setup_IAppSetup.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/setup/IAppSetup.cpp.orig 2016-06-04 19:55:57 UTC
-+++ src/setup/IAppSetup.cpp
-@@ -36,7 +36,7 @@ IAppSetup* IAppSetup::getPlatformInstanc
- {
- #if defined(Q_OS_MAC)
- instance = new CAppSetupMac();
--#elif defined(Q_OS_LINUX)
-+#elif defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
- instance = new CAppSetupLinux();
- #elif defined (Q_OS_WIN32)
- instance = new CAppSetupWin();
diff --git a/astro/qmapshack/pkg-plist b/astro/qmapshack/pkg-plist
index d5e99fa23f66..c40245391be8 100644
--- a/astro/qmapshack/pkg-plist
+++ b/astro/qmapshack/pkg-plist
@@ -1,8 +1,23 @@
bin/qmapshack
man/man1/qmapshack.1.gz
share/applications/qmapshack.desktop
+share/icons/hicolor/128x128/apps/QMapShack.png
+share/icons/hicolor/16x16/apps/QMapShack.png
+share/icons/hicolor/192x192/apps/QMapShack.png
+share/icons/hicolor/22x22/apps/QMapShack.png
+share/icons/hicolor/24x24/apps/QMapShack.png
+share/icons/hicolor/256x256/apps/QMapShack.png
share/icons/hicolor/32x32/apps/QMapShack.png
+share/icons/hicolor/36x36/apps/QMapShack.png
+share/icons/hicolor/40x40/apps/QMapShack.png
+share/icons/hicolor/42x42/apps/QMapShack.png
share/icons/hicolor/48x48/apps/QMapShack.png
+share/icons/hicolor/512x512/apps/QMapShack.png
+share/icons/hicolor/64x64/apps/QMapShack.png
+share/icons/hicolor/72x72/apps/QMapShack.png
+share/icons/hicolor/80x80/apps/QMapShack.png
+share/icons/hicolor/8x8/apps/QMapShack.png
+share/icons/hicolor/96x96/apps/QMapShack.png
share/icons/hicolor/scalable/apps/QMapShack.svg
share/pixmaps/QMapShack.png
%%DATADIR%%/translations/qmapshack_cs.qm