aboutsummaryrefslogtreecommitdiff
path: root/astro/qmapshack
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-04-02 11:56:27 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-04-02 11:56:27 +0000
commit5d749b104341c1ffbcef04fd389db5a1301e64f4 (patch)
treef344302d5876a6cc3783644862ef89db1e09a163 /astro/qmapshack
parent13bbe3642ea7e525f897f3dcc63f11abd1505f07 (diff)
downloadports-5d749b104341c1ffbcef04fd389db5a1301e64f4.tar.gz
ports-5d749b104341c1ffbcef04fd389db5a1301e64f4.zip
astro/qmapshack: Update version 1.14.0=>1.14.1
Notes
Notes: svn path=/head/; revision=530277
Diffstat (limited to 'astro/qmapshack')
-rw-r--r--astro/qmapshack/Makefile12
-rw-r--r--astro/qmapshack/distinfo6
-rw-r--r--astro/qmapshack/files/patch-CMakeLists.txt8
-rw-r--r--astro/qmapshack/files/patch-cmake_Modules_DefineInstallationPaths.cmake11
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt6
-rw-r--r--astro/qmapshack/files/patch-src_qmaptool_CMakeLists.txt6
-rw-r--r--astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt8
-rw-r--r--astro/qmapshack/files/patch-src_qmt__rgb2pct_CMakeLists.txt4
-rw-r--r--astro/qmapshack/pkg-plist6
9 files changed, 42 insertions, 25 deletions
diff --git a/astro/qmapshack/Makefile b/astro/qmapshack/Makefile
index ea40cad45c2d..4a626ed351ca 100644
--- a/astro/qmapshack/Makefile
+++ b/astro/qmapshack/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= qmapshack
-PORTVERSION= 1.14.0
+PORTVERSION= 1.14.1
DISTVERSIONPREFIX= V_
-PORTREVISION= 1
CATEGORIES= astro
MAINTAINER= bofh@FreeBSD.org
@@ -21,11 +20,14 @@ RUN_DEPENDS= ${LOCALBASE}/bin/bsdisks:sysutils/bsdisks
USES= cmake compiler:c++11-lib desktop-file-utils gl jpeg \
pkgconfig qt:5 xorg
-USE_QT= buildtools core dbus declarative gui linguisttools location network \
+USE_GITHUB= yes
+USE_GL= gl
+USE_QT= buildtools core dbus declarative gui help linguisttools location network \
printsupport qmake sql sql-sqlite3 uitools \
webchannel webengine widgets xml
-USE_GL= gl
-USE_GITHUB= yes
+
GH_ACCOUNT= Maproom
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/astro/qmapshack/distinfo b/astro/qmapshack/distinfo
index a19c55fd84db..9cc864774a82 100644
--- a/astro/qmapshack/distinfo
+++ b/astro/qmapshack/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1574525969
-SHA256 (Maproom-qmapshack-V_1.14.0_GH0.tar.gz) = fd50f335b741087ab228ce4f8f45e386562eb128aea84298a1bdcfd299126576
-SIZE (Maproom-qmapshack-V_1.14.0_GH0.tar.gz) = 12541988
+TIMESTAMP = 1585556579
+SHA256 (Maproom-qmapshack-V_1.14.1_GH0.tar.gz) = 76f64185fc4620da6d9b71998edefcb9091eff1c3486626f87e4f30d444be623
+SIZE (Maproom-qmapshack-V_1.14.1_GH0.tar.gz) = 43586361
diff --git a/astro/qmapshack/files/patch-CMakeLists.txt b/astro/qmapshack/files/patch-CMakeLists.txt
index a5b92c5fada3..1872b290793c 100644
--- a/astro/qmapshack/files/patch-CMakeLists.txt
+++ b/astro/qmapshack/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2019-04-08 16:08:10 UTC
+--- CMakeLists.txt.orig 2020-03-27 08:07:31 UTC
+++ CMakeLists.txt
-@@ -43,6 +43,7 @@ include(TranslateDesktop)
+@@ -65,6 +65,7 @@ include(TranslateDesktop)
include(DefineCMakeDefaults)
include(DefineCompilerFlags)
include(DefineInstallationPaths)
@@ -8,9 +8,9 @@
include(CPackConfig.cmake)
include(ConfigureChecks.cmake)
-@@ -135,7 +136,10 @@ find_package(Qt5Network REQUIRED)
- find_package(Qt5WebEngineWidgets REQUIRED)
+@@ -167,7 +168,10 @@ find_package(Qt5WebEngineWidgets REQUIRED)
find_package(Qt5Qml REQUIRED)
+ find_package(Qt5Help REQUIRED)
find_package(GDAL REQUIRED)
-find_package(PROJ4 REQUIRED)
+find_package(PROJ4)
diff --git a/astro/qmapshack/files/patch-cmake_Modules_DefineInstallationPaths.cmake b/astro/qmapshack/files/patch-cmake_Modules_DefineInstallationPaths.cmake
index e4c37a5e153c..8fd3709ff063 100644
--- a/astro/qmapshack/files/patch-cmake_Modules_DefineInstallationPaths.cmake
+++ b/astro/qmapshack/files/patch-cmake_Modules_DefineInstallationPaths.cmake
@@ -1,5 +1,14 @@
---- cmake/Modules/DefineInstallationPaths.cmake.orig 2018-09-08 09:17:56 UTC
+--- cmake/Modules/DefineInstallationPaths.cmake.orig 2020-03-27 08:07:31 UTC
+++ cmake/Modules/DefineInstallationPaths.cmake
+@@ -59,7 +59,7 @@ if (UNIX)
+ FORCE
+ )
+ SET(HTML_INSTALL_DIR
+- "${DATA_INSTALL_PREFIX}/doc/HTML"
++ "${DATA_INSTALL_PREFIX}/doc/${_PROJECT_NAME}/HTML"
+ CACHE PATH "The HTML install dir for documentation (default data/doc/html)"
+ FORCE
+ )
@@ -97,7 +97,7 @@ if (UNIX)
FORCE
)
diff --git a/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt b/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt
index f626b3881957..305ebbe7f15f 100644
--- a/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt
+++ b/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt
@@ -1,7 +1,7 @@
---- src/qmapshack/CMakeLists.txt.orig 2019-04-08 15:33:43 UTC
+--- src/qmapshack/CMakeLists.txt.orig 2020-03-27 08:07:31 UTC
+++ src/qmapshack/CMakeLists.txt
-@@ -891,7 +891,7 @@ target_link_libraries(${APPLICATION_NAME}
- Qt5::Positioning
+@@ -920,7 +920,7 @@ target_link_libraries(${APPLICATION_NAME}
+ Qt5::Help
${DBUS_LIB}
${GDAL_LIBRARIES}
- ${PROJ4_LIBRARIES}
diff --git a/astro/qmapshack/files/patch-src_qmaptool_CMakeLists.txt b/astro/qmapshack/files/patch-src_qmaptool_CMakeLists.txt
index 23ddf4b994df..2e65464897a6 100644
--- a/astro/qmapshack/files/patch-src_qmaptool_CMakeLists.txt
+++ b/astro/qmapshack/files/patch-src_qmaptool_CMakeLists.txt
@@ -1,8 +1,8 @@
---- src/qmaptool/CMakeLists.txt.orig 2019-04-08 15:33:47 UTC
+--- src/qmaptool/CMakeLists.txt.orig 2020-03-27 08:07:31 UTC
+++ src/qmaptool/CMakeLists.txt
-@@ -247,7 +247,7 @@ target_link_libraries(${APPLICATION_NAME}
- Qt5::Widgets
+@@ -254,7 +254,7 @@ target_link_libraries(${APPLICATION_NAME}
Qt5::Network
+ Qt5::Help
${GDAL_LIBRARIES}
- ${PROJ4_LIBRARIES}
+ ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES}
diff --git a/astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt b/astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt
index 03f3f45e9452..c23a15cd3cf3 100644
--- a/astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt
+++ b/astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt
@@ -1,11 +1,11 @@
---- src/qmt_map2jnx/CMakeLists.txt.orig 2019-04-08 15:33:49 UTC
+--- src/qmt_map2jnx/CMakeLists.txt.orig 2020-03-27 08:07:31 UTC
+++ src/qmt_map2jnx/CMakeLists.txt
-@@ -46,7 +46,7 @@ IF(WIN32)
+@@ -48,7 +48,7 @@ IF(WIN32)
ADD_DEFINITIONS(-D_CRT_SECURE_NO_DEPRECATE)
ENDIF(WIN32)
-TARGET_LINK_LIBRARIES(${APPLICATION_NAME} ${GDAL_LIBRARIES} ${PROJ4_LIBRARIES} ${JPEG_LIBRARIES})
+TARGET_LINK_LIBRARIES(${APPLICATION_NAME} ${GDAL_LIBRARIES} ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES} ${JPEG_LIBRARIES})
- if(APPLE)
- set_target_properties(${APPLICATION_NAME} PROPERTIES
+ install(
+ TARGETS ${APPLICATION_NAME} DESTINATION ${BIN_INSTALL_DIR}
diff --git a/astro/qmapshack/files/patch-src_qmt__rgb2pct_CMakeLists.txt b/astro/qmapshack/files/patch-src_qmt__rgb2pct_CMakeLists.txt
index 3c2211fc1556..4ec858ca803c 100644
--- a/astro/qmapshack/files/patch-src_qmt__rgb2pct_CMakeLists.txt
+++ b/astro/qmapshack/files/patch-src_qmt__rgb2pct_CMakeLists.txt
@@ -1,6 +1,6 @@
---- src/qmt_rgb2pct/CMakeLists.txt.orig 2019-04-08 15:33:50 UTC
+--- src/qmt_rgb2pct/CMakeLists.txt.orig 2020-03-27 08:07:31 UTC
+++ src/qmt_rgb2pct/CMakeLists.txt
-@@ -95,7 +95,7 @@ add_executable(${APPLICATION_NAME} WIN32 ${MAININP})
+@@ -92,7 +92,7 @@ target_compile_definitions(${APPLICATION_NAME} PUBLIC
target_link_libraries(${APPLICATION_NAME}
Qt5::Core
${GDAL_LIBRARIES}
diff --git a/astro/qmapshack/pkg-plist b/astro/qmapshack/pkg-plist
index 366039603158..e442b203fbc4 100644
--- a/astro/qmapshack/pkg-plist
+++ b/astro/qmapshack/pkg-plist
@@ -46,6 +46,8 @@ share/pixmaps/QMapShack.png
share/pixmaps/QMapTool.png
share/qmaptool/translations/qmaptool_de.qm
share/qmaptool/translations/qmaptool_es.qm
+share/qmaptool/translations/qmaptool_it.qm
+share/qmaptool/translations/qmaptool_ru.qm
share/qmt_rgb2pct/translations/qmt_rgb2pct_de.qm
%%DATADIR%%/translations/qmapshack_ca.qm
%%DATADIR%%/translations/qmapshack_cs.qm
@@ -55,3 +57,7 @@ share/qmt_rgb2pct/translations/qmt_rgb2pct_de.qm
%%DATADIR%%/translations/qmapshack_it.qm
%%DATADIR%%/translations/qmapshack_nl.qm
%%DATADIR%%/translations/qmapshack_ru.qm
+%%PORTDOCS%%%%DOCSDIR%%/HTML/QMSHelp.qch
+%%PORTDOCS%%%%DOCSDIR%%/HTML/QMSHelp.qhc
+%%PORTDOCS%%%%DOCSDIR%%/HTML/QMTHelp.qch
+%%PORTDOCS%%%%DOCSDIR%%/HTML/QMTHelp.qhc