aboutsummaryrefslogtreecommitdiff
path: root/astro/qmapshack
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-04-21 18:09:48 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-04-21 18:09:48 +0000
commit63ae23ca4318c926863b56642baeb6442be2c6f9 (patch)
tree226c015bddcceee552a47f583469f7a9b4d44d29 /astro/qmapshack
parent938fe75adf44b551a369522fa4adb4d80dd27d0c (diff)
downloadports-63ae23ca4318c926863b56642baeb6442be2c6f9.tar.gz
ports-63ae23ca4318c926863b56642baeb6442be2c6f9.zip
astro/qmapshack: Update version 1.12.3=>1.13.0
- fix libproj detection: Our graphics proj is built with autotools and thus does not install it's cmake files. Patches provide an alternate method for finding libproj using pkg-config, see: https://sourceforge.net/p/qlandkartegt/mailman/message/36639866/ - fix a crash with current Qt when no GPS device is found (which at least for me is the default case): since the last Qt update, QList aborts on an assertion when trying to access the first element of an empty list. PR: 237425 Submitted by: cmt
Notes
Notes: svn path=/head/; revision=499552
Diffstat (limited to 'astro/qmapshack')
-rw-r--r--astro/qmapshack/Makefile5
-rw-r--r--astro/qmapshack/distinfo6
-rw-r--r--astro/qmapshack/files/patch-CMakeLists.txt22
-rw-r--r--astro/qmapshack/files/patch-cmake_Modules_DefineInstallationPaths.cmake4
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt11
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp13
-rw-r--r--astro/qmapshack/files/patch-src_qmaptool_CMakeLists.txt11
-rw-r--r--astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt11
-rw-r--r--astro/qmapshack/files/patch-src_qmt__rgb2pct_CMakeLists.txt11
9 files changed, 86 insertions, 8 deletions
diff --git a/astro/qmapshack/Makefile b/astro/qmapshack/Makefile
index 9fa123254309..ae36d1775240 100644
--- a/astro/qmapshack/Makefile
+++ b/astro/qmapshack/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qmapshack
-PORTVERSION= 1.12.3
-PORTREVISION= 1
+PORTVERSION= 1.13.0
CATEGORIES= astro
MASTER_SITES= https://bitbucket.org/maproom/qmapshack/downloads/
@@ -19,7 +18,7 @@ LIB_DEPENDS= libgdal.so:graphics/gdal \
libroutino.so:astro/routino
RUN_DEPENDS= ${LOCALBASE}/bin/bsdisks:sysutils/bsdisks
-USES= cmake compiler:c++11-lib desktop-file-utils jpeg qt:5
+USES= cmake compiler:c++11-lib desktop-file-utils jpeg pkgconfig qt:5
USE_QT= buildtools core dbus declarative gui linguisttools location network \
printsupport qmake sql sql-sqlite3 uitools \
webchannel webengine widgets xml
diff --git a/astro/qmapshack/distinfo b/astro/qmapshack/distinfo
index dccff4b6637b..2d4860559c56 100644
--- a/astro/qmapshack/distinfo
+++ b/astro/qmapshack/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1549642588
-SHA256 (qmapshack-1.12.3.tar.gz) = 3d4ffbfa34c41d85d2a46d0d2a6c5254c305aa4ae137c253e6913f82097fe5fa
-SIZE (qmapshack-1.12.3.tar.gz) = 12029443
+TIMESTAMP = 1554993320
+SHA256 (qmapshack-1.13.0.tar.gz) = 6a658f9188cd96ec53bd051cf475256b4bacc4a76a7043c5f478a38cc27161b3
+SIZE (qmapshack-1.13.0.tar.gz) = 12323773
diff --git a/astro/qmapshack/files/patch-CMakeLists.txt b/astro/qmapshack/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a5b92c5fada3
--- /dev/null
+++ b/astro/qmapshack/files/patch-CMakeLists.txt
@@ -0,0 +1,22 @@
+--- CMakeLists.txt.orig 2019-04-08 16:08:10 UTC
++++ CMakeLists.txt
+@@ -43,6 +43,7 @@ include(TranslateDesktop)
+ include(DefineCMakeDefaults)
+ include(DefineCompilerFlags)
+ include(DefineInstallationPaths)
++include(FindPkgConfig)
+ include(CPackConfig.cmake)
+ include(ConfigureChecks.cmake)
+
+@@ -135,7 +136,10 @@ find_package(Qt5Network REQUIRED)
+ find_package(Qt5WebEngineWidgets REQUIRED)
+ find_package(Qt5Qml REQUIRED)
+ find_package(GDAL REQUIRED)
+-find_package(PROJ4 REQUIRED)
++find_package(PROJ4)
++if (NOT PROJ4_FOUND)
++ pkg_search_module(PROJ4 REQUIRED proj)
++endif()
+ find_package(JPEG REQUIRED)
+ find_package(ROUTINO REQUIRED)
+ find_package(QuaZip5 REQUIRED)
diff --git a/astro/qmapshack/files/patch-cmake_Modules_DefineInstallationPaths.cmake b/astro/qmapshack/files/patch-cmake_Modules_DefineInstallationPaths.cmake
index fcc8eac91104..e4c37a5e153c 100644
--- a/astro/qmapshack/files/patch-cmake_Modules_DefineInstallationPaths.cmake
+++ b/astro/qmapshack/files/patch-cmake_Modules_DefineInstallationPaths.cmake
@@ -1,6 +1,6 @@
---- cmake/Modules/DefineInstallationPaths.cmake.orig 2014-08-18 10:08:14 UTC
+--- cmake/Modules/DefineInstallationPaths.cmake.orig 2018-09-08 09:17:56 UTC
+++ cmake/Modules/DefineInstallationPaths.cmake
-@@ -101,7 +101,7 @@ if (UNIX)
+@@ -97,7 +97,7 @@ if (UNIX)
FORCE
)
SET(MAN_INSTALL_DIR
diff --git a/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt b/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt
new file mode 100644
index 000000000000..f626b3881957
--- /dev/null
+++ b/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/qmapshack/CMakeLists.txt.orig 2019-04-08 15:33:43 UTC
++++ src/qmapshack/CMakeLists.txt
+@@ -891,7 +891,7 @@ target_link_libraries(${APPLICATION_NAME}
+ Qt5::Positioning
+ ${DBUS_LIB}
+ ${GDAL_LIBRARIES}
+- ${PROJ4_LIBRARIES}
++ ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES}
+ ${ROUTINO_LIBRARIES}
+ ${ALGLIB_LIBRARIES}
+ ${QUAZIP_LIBRARIES}
diff --git a/astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp b/astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp
new file mode 100644
index 000000000000..31b3a856b073
--- /dev/null
+++ b/astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp
@@ -0,0 +1,13 @@
+--- src/qmapshack/device/CDeviceWatcherLinux.cpp.orig 2019-04-20 21:33:23.749597000 +0200
++++ src/qmapshack/device/CDeviceWatcherLinux.cpp 2019-04-20 21:34:05.021101000 +0200
+@@ -174,7 +174,9 @@
+ #if defined(Q_OS_FREEBSD)
+ for(const QVariant &arg : reply.arguments())
+ {
+- points.append(arg.value<QDBusVariant>().variant().value<QStringList>().first());
++ if(!arg.value<QDBusVariant>().variant().value<QStringList>().isEmpty()) {
++ points.append(arg.value<QDBusVariant>().variant().value<QStringList>().first());
++ }
+ }
+ #else
+ QList<QByteArray> list;
diff --git a/astro/qmapshack/files/patch-src_qmaptool_CMakeLists.txt b/astro/qmapshack/files/patch-src_qmaptool_CMakeLists.txt
new file mode 100644
index 000000000000..23ddf4b994df
--- /dev/null
+++ b/astro/qmapshack/files/patch-src_qmaptool_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/qmaptool/CMakeLists.txt.orig 2019-04-08 15:33:47 UTC
++++ src/qmaptool/CMakeLists.txt
+@@ -247,7 +247,7 @@ target_link_libraries(${APPLICATION_NAME}
+ Qt5::Widgets
+ Qt5::Network
+ ${GDAL_LIBRARIES}
+- ${PROJ4_LIBRARIES}
++ ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES}
+ )
+
+ if(APPLE)
diff --git a/astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt b/astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt
new file mode 100644
index 000000000000..03f3f45e9452
--- /dev/null
+++ b/astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/qmt_map2jnx/CMakeLists.txt.orig 2019-04-08 15:33:49 UTC
++++ src/qmt_map2jnx/CMakeLists.txt
+@@ -46,7 +46,7 @@ IF(WIN32)
+ ADD_DEFINITIONS(-D_CRT_SECURE_NO_DEPRECATE)
+ ENDIF(WIN32)
+
+-TARGET_LINK_LIBRARIES(${APPLICATION_NAME} ${GDAL_LIBRARIES} ${PROJ4_LIBRARIES} ${JPEG_LIBRARIES})
++TARGET_LINK_LIBRARIES(${APPLICATION_NAME} ${GDAL_LIBRARIES} ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES} ${JPEG_LIBRARIES})
+
+ if(APPLE)
+ set_target_properties(${APPLICATION_NAME} PROPERTIES
diff --git a/astro/qmapshack/files/patch-src_qmt__rgb2pct_CMakeLists.txt b/astro/qmapshack/files/patch-src_qmt__rgb2pct_CMakeLists.txt
new file mode 100644
index 000000000000..3c2211fc1556
--- /dev/null
+++ b/astro/qmapshack/files/patch-src_qmt__rgb2pct_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/qmt_rgb2pct/CMakeLists.txt.orig 2019-04-08 15:33:50 UTC
++++ src/qmt_rgb2pct/CMakeLists.txt
+@@ -95,7 +95,7 @@ add_executable(${APPLICATION_NAME} WIN32 ${MAININP})
+ target_link_libraries(${APPLICATION_NAME}
+ Qt5::Core
+ ${GDAL_LIBRARIES}
+- ${PROJ4_LIBRARIES}
++ ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES}
+ )
+
+ if(APPLE)