aboutsummaryrefslogtreecommitdiff
path: root/astro/qmapshack
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2016-10-18 18:49:24 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2016-10-18 18:49:24 +0000
commitd79f919be18b144328f5b56fd9411dfd53a9f062 (patch)
tree6530676f61864fa1668a135623729298216e38af /astro/qmapshack
parent628de31fe1362c1790dddd60109053b2bce00346 (diff)
downloadports-d79f919be18b144328f5b56fd9411dfd53a9f062.tar.gz
ports-d79f919be18b144328f5b56fd9411dfd53a9f062.zip
update qmapshack to 1.7.1
PR: 212844 Approved by: rene (mentor) Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=424204
Diffstat (limited to 'astro/qmapshack')
-rw-r--r--astro/qmapshack/Makefile2
-rw-r--r--astro/qmapshack/distinfo6
-rw-r--r--astro/qmapshack/files/patch-src_gis_CGisListWks.cpp11
3 files changed, 15 insertions, 4 deletions
diff --git a/astro/qmapshack/Makefile b/astro/qmapshack/Makefile
index f5951c02ecea..ab6f435a9046 100644
--- a/astro/qmapshack/Makefile
+++ b/astro/qmapshack/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qmapshack
-PORTVERSION= 1.6.3
+PORTVERSION= 1.7.1
CATEGORIES= astro
MASTER_SITES= https://bitbucket.org/maproom/qmapshack/downloads/
diff --git a/astro/qmapshack/distinfo b/astro/qmapshack/distinfo
index 7c77407d2503..5a98f27b2e86 100644
--- a/astro/qmapshack/distinfo
+++ b/astro/qmapshack/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1468517493
-SHA256 (qmapshack-1.6.3.tar.gz) = 6fa5158bd823e8d43eb8a4e4db35a05720d1fe8d624eb65320b905ae315bd708
-SIZE (qmapshack-1.6.3.tar.gz) = 5181205
+TIMESTAMP = 1474306176
+SHA256 (qmapshack-1.7.1.tar.gz) = 5da33e575fec11c1bfe097ab9c89c9d815124436b5ebf736ec0681acbda4a509
+SIZE (qmapshack-1.7.1.tar.gz) = 5201773
diff --git a/astro/qmapshack/files/patch-src_gis_CGisListWks.cpp b/astro/qmapshack/files/patch-src_gis_CGisListWks.cpp
new file mode 100644
index 000000000000..4de0776ab617
--- /dev/null
+++ b/astro/qmapshack/files/patch-src_gis_CGisListWks.cpp
@@ -0,0 +1,11 @@
+--- src/gis/CGisListWks.cpp.orig 2016-09-19 19:38:41.441780000 +0200
++++ src/gis/CGisListWks.cpp 2016-09-19 19:38:56.183055000 +0200
+@@ -346,7 +346,7 @@
+ QAction * action = menu->addAction(QIcon(icon), text);
+ action->setCheckable(true);
+
+- auto func = bind(&CGisListWks::slotSetSortMode, this, mode, std::placeholders::_1);
++ auto func = std::bind(&CGisListWks::slotSetSortMode, this, mode, std::placeholders::_1);
+ connect(action, &QAction::toggled, this, func);
+
+ actionGroup->addAction(action);