aboutsummaryrefslogtreecommitdiff
path: root/astro/siril
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-26 09:04:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-26 09:04:18 +0000
commit2c432ea8ff86ea1d9aea762990d6d0f9790a2f12 (patch)
treea391163f0625072d19e742a02a34ded8230ee2b3 /astro/siril
parente2833eb245c90a2ef3d90d05c3c5471c1e641f4c (diff)
downloadports-2c432ea8ff86ea1d9aea762990d6d0f9790a2f12.tar.gz
ports-2c432ea8ff86ea1d9aea762990d6d0f9790a2f12.zip
science/siril: Move to astro/siril; Mark broken on i386; Add OPENMP category
Notes
Notes: svn path=/head/; revision=465565
Diffstat (limited to 'astro/siril')
-rw-r--r--astro/siril/Makefile48
-rw-r--r--astro/siril/distinfo3
-rw-r--r--astro/siril/files/patch-Makefile.am16
-rw-r--r--astro/siril/pkg-descr11
-rw-r--r--astro/siril/pkg-plist42
5 files changed, 120 insertions, 0 deletions
diff --git a/astro/siril/Makefile b/astro/siril/Makefile
new file mode 100644
index 000000000000..fab98e988dab
--- /dev/null
+++ b/astro/siril/Makefile
@@ -0,0 +1,48 @@
+# $FreeBSD$
+
+PORTNAME= siril
+DISTVERSION= 0.9.8
+PORTREVISION= 1
+CATEGORIES= astro graphics
+MASTER_SITES= https://free-astro.org/download/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Astronomical image processing software
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BROKEN_i386= undefined reference to `__atomic_load' and `__atomic_compare_exchange'
+
+LIB_DEPENDS= libavformat.so:multimedia/ffmpeg \
+ libcfitsio.so:astro/cfitsio \
+ libconfig.so:devel/libconfig \
+ libffms2.so:multimedia/ffms2 \
+ libfftw3.so:math/fftw3 \
+ libgsl.so:math/gsl \
+ liblcms2.so:graphics/lcms2 \
+ libopencv_core.so:graphics/opencv-core \
+ libpng.so:graphics/png \
+ libraw.so:graphics/libraw \
+ libtiff.so:graphics/tiff
+LIB_DEPENDS+= libopencv_photo.so:graphics/opencv # for some reason, configure fails without opencv, but executable only links to opencv-core
+
+USES= autoreconf desktop-file-utils gettext gmake localbase pkgconfig jpeg shared-mime-info tar:bz2
+GNU_CONFIGURE= yes
+USE_GNOME= atk cairo gdkpixbuf2 gtk30 intltool pango
+INSTALLS_ICONS= yes
+
+OPTIONS_DEFINE= OPENMP
+OPTIONS_DEFAULT= OPENMP
+
+OPENMP_CONFIGURE_ENABLE= openmp
+OPENMP_LIB_DEPENDS= libomp.so:devel/openmp
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/appdata ${STAGEDIR}${PREFIX}/share/mime/packages
+ ${INSTALL_DATA} ${WRKSRC}/platform-specific/linux/org.free-astro.siril.desktop ${STAGEDIR}${PREFIX}/share/applications/${PORTNAME}.desktop
+ ${INSTALL_DATA} ${WRKSRC}/platform-specific/linux/org.free-astro.siril.appdata.xml ${STAGEDIR}${PREFIX}/share/appdata/${PORTNAME}.appdata.xml
+ ${INSTALL_DATA} ${WRKSRC}/platform-specific/linux/siril.xml ${STAGEDIR}${PREFIX}/share/mime/packages/
+ cd ${WRKSRC}/pixmaps && ${COPYTREE_SHARE} icons ${STAGEDIR}${PREFIX}/share/
+
+.include <bsd.port.mk>
diff --git a/astro/siril/distinfo b/astro/siril/distinfo
new file mode 100644
index 000000000000..ef77993c2dc7
--- /dev/null
+++ b/astro/siril/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1517713559
+SHA256 (siril-0.9.8.tar.bz2) = ecb5477937afc02cc89cb07f4a7b99d2d0ab4cc5e715ec536e9be5c92a187170
+SIZE (siril-0.9.8.tar.bz2) = 882068
diff --git a/astro/siril/files/patch-Makefile.am b/astro/siril/files/patch-Makefile.am
new file mode 100644
index 000000000000..bdc78fd24541
--- /dev/null
+++ b/astro/siril/files/patch-Makefile.am
@@ -0,0 +1,16 @@
+--- Makefile.am.orig 2017-11-13 22:13:16 UTC
++++ Makefile.am
+@@ -17,11 +17,9 @@ install-data-local:
+ $(INSTALL_DATA) src/gui/siril3.glade $(DESTDIR)$(pkgdatadir)
+ $(INSTALL_DATA) src/gui/gtk_old.css $(DESTDIR)$(pkgdatadir)
+ $(INSTALL_DATA) src/gui/gtk.css $(DESTDIR)$(pkgdatadir)
+- $(mkinstalldirs) $(DESTDIR)$(docdir)
+- $(INSTALL_DATA) AUTHORS LICENSE.md $(DESTDIR)$(docdir)
+ $(mkinstalldirs) $(DESTDIR)$(mandir)/man1
+ $(INSTALL_DATA) siril.1.gz $(DESTDIR)$(mandir)/man1
+
+ ACLOCAL_AMFLAGS = -I m4
+ EXTRA_DIST = config.rpath
+-AUTOMAKE_OPTIONS = foreign
+\ No newline at end of file
++AUTOMAKE_OPTIONS = foreign
diff --git a/astro/siril/pkg-descr b/astro/siril/pkg-descr
new file mode 100644
index 000000000000..bc9f2effc9f7
--- /dev/null
+++ b/astro/siril/pkg-descr
@@ -0,0 +1,11 @@
+Siril is an astronomical image processing tool, able to convert, pre-process
+images, help aligning them automatically or manually, stack them and enhance
+final images.
+
+Siril is targeted to amateur astronomers having acquired images and wanting
+to process them in a semi-automatic way. It provides a more user-friendly
+interface than Iris' command line as well as more modern and powerful processing
+algorithms, but it is not yet as automated as DeepSkyStacker or Registax. It
+also provides a basic command line to access various processing functions.
+
+WWW: https://free-astro.org/index.php/Siril
diff --git a/astro/siril/pkg-plist b/astro/siril/pkg-plist
new file mode 100644
index 000000000000..a54ee3ea9383
--- /dev/null
+++ b/astro/siril/pkg-plist
@@ -0,0 +1,42 @@
+bin/siril
+man/man1/siril.1.gz
+share/appdata/siril.appdata.xml
+share/applications/siril.desktop
+share/icons/hicolor/16x16/apps/siril.png
+share/icons/hicolor/24x24/apps/siril.png
+share/icons/hicolor/256x256/apps/siril.png
+share/icons/hicolor/32x32/apps/siril.png
+share/icons/hicolor/48x48/apps/siril.png
+share/locale/ar_DZ/LC_MESSAGES/siril.mo
+share/locale/el/LC_MESSAGES/siril.mo
+share/locale/es_ES/LC_MESSAGES/siril.mo
+share/locale/fr/LC_MESSAGES/siril.mo
+share/locale/it_IT/LC_MESSAGES/siril.mo
+share/locale/nl_BE/LC_MESSAGES/siril.mo
+share/locale/zh_CN/LC_MESSAGES/siril.mo
+share/mime/packages/siril.xml
+%%DATADIR%%/gtk.css
+%%DATADIR%%/gtk_old.css
+%%DATADIR%%/pixmaps/chain.png
+%%DATADIR%%/pixmaps/cm.png
+%%DATADIR%%/pixmaps/export.png
+%%DATADIR%%/pixmaps/grid.png
+%%DATADIR%%/pixmaps/histo.png
+%%DATADIR%%/pixmaps/histo_dark.png
+%%DATADIR%%/pixmaps/list.png
+%%DATADIR%%/pixmaps/list_dark.png
+%%DATADIR%%/pixmaps/mirrorx.png
+%%DATADIR%%/pixmaps/mirrorx_dark.png
+%%DATADIR%%/pixmaps/mirrory.png
+%%DATADIR%%/pixmaps/mirrory_dark.png
+%%DATADIR%%/pixmaps/neg.png
+%%DATADIR%%/pixmaps/remove1.png
+%%DATADIR%%/pixmaps/rotate-acw.png
+%%DATADIR%%/pixmaps/rotate-acw_dark.png
+%%DATADIR%%/pixmaps/rotate-cw.png
+%%DATADIR%%/pixmaps/rotate-cw_dark.png
+%%DATADIR%%/pixmaps/siril_1.svg
+%%DATADIR%%/pixmaps/siril_logo.svg
+%%DATADIR%%/pixmaps/starfinder.png
+%%DATADIR%%/pixmaps/sum.png
+%%DATADIR%%/siril3.glade