aboutsummaryrefslogtreecommitdiff
path: root/astro/sofa/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-26 02:40:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-26 02:40:15 +0000
commit7c7f0b82414409ecb168a5ffb52370fe341a476a (patch)
tree04f41de2541af9946da12baea0fe6b2d7ec28277 /astro/sofa/Makefile
parent4ac0d6981419ebbf6fc49e275ecee3ab70849883 (diff)
downloadports-7c7f0b82414409ecb168a5ffb52370fe341a476a.tar.gz
ports-7c7f0b82414409ecb168a5ffb52370fe341a476a.zip
Notes
Diffstat (limited to 'astro/sofa/Makefile')
-rw-r--r--astro/sofa/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/astro/sofa/Makefile b/astro/sofa/Makefile
new file mode 100644
index 000000000000..97b800f59b9e
--- /dev/null
+++ b/astro/sofa/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= sofa
+DISTVERSION= 20180130
+CATEGORIES= astro devel
+MASTER_SITES= http://www.iausofa.org/${DISTVERSION:C/(....)(....)/\\1_\\2/}_C/
+DISTNAME= ${PORTNAME}_c-${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Set of algorithms and procedures used in fundamental astronomy
+
+LICENSE= SOFA
+LICENSE_NAME= SOFA Software License
+LICENSE_FILE= ${WRKDIR}/sofa/20180130/c/doc/copyr.lis
+LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
+
+MAKEFILE= makefile
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/${DISTVERSION}/c/src
+BINARY_ALIAS= gcc=cc
+MAKE_ARGS= CFLAGF="-c ${CFLAGS} -fPIC" INSTALL_DIR=${STAGEDIR}${PREFIX}
+
+PLIST_FILES= include/sofa.h \
+ include/sofam.h \
+ lib/libsofa_c.so
+
+.include <bsd.port.mk>