aboutsummaryrefslogtreecommitdiff
path: root/astro/sscalc
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-19 13:36:31 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-19 13:36:31 +0000
commitae65d62fa3aa2cedc4bdbc470af484373e48f2f1 (patch)
tree71109aa10b36b5e53cf31ab1fecba5d16d6793ca /astro/sscalc
parentd7f33247bc24353a9ad7a1d0bb8132a823a55e29 (diff)
downloadports-ae65d62fa3aa2cedc4bdbc470af484373e48f2f1.tar.gz
ports-ae65d62fa3aa2cedc4bdbc470af484373e48f2f1.zip
Add sscalc 1.0, a sunrise/sunset time calculator ported to C from
Javascript (uh, yeah). Too bad you have to hardcode your long/lat into the program, perhaps some kind soul will inflict getopt() on this prog. PR: 23245 Submitted by: Keith Walker <kew@icehouse.net>
Notes
Notes: svn path=/head/; revision=36122
Diffstat (limited to 'astro/sscalc')
-rw-r--r--astro/sscalc/Makefile28
-rw-r--r--astro/sscalc/distinfo1
-rw-r--r--astro/sscalc/pkg-comment1
-rw-r--r--astro/sscalc/pkg-descr9
-rw-r--r--astro/sscalc/pkg-plist4
5 files changed, 43 insertions, 0 deletions
diff --git a/astro/sscalc/Makefile b/astro/sscalc/Makefile
new file mode 100644
index 000000000000..40c633d6b58b
--- /dev/null
+++ b/astro/sscalc/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: sscalc
+# Date created: Wed Nov 29 15:08:00 PST 2000
+# Whom: Keith Walker <kew@icehouse.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sscalc
+PORTVERSION= 1.0
+CATEGORIES= astro
+MASTER_SITES= http://www.icehouse.net/kew/
+
+MAINTAINER= kew@icehouse.net
+
+pre-fetch:
+.if !defined(LAT)
+ @${ECHO_MSG} "Type \"make LAT=<nnn.nn> LON=<nnn.nn>\" to hardwire your site"
+.else
+ @${ECHO_MSG} "Compiling in lat/longs"
+.endif
+
+post-install:
+ @strip ${PREFIX}/bin/sscalc
+ @${MKDIR} ${PREFIX}/share/doc/sscalc
+ ${INSTALL_DATA} ${WRKSRC}/cities.txt ${PREFIX}/share/doc/sscalc
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/sscalc
+
+.include <bsd.port.mk>
diff --git a/astro/sscalc/distinfo b/astro/sscalc/distinfo
new file mode 100644
index 000000000000..3ba8967b724c
--- /dev/null
+++ b/astro/sscalc/distinfo
@@ -0,0 +1 @@
+MD5 (sscalc-1.0.tar.gz) = e3777b9b3031af7215c514fc3c0665b3
diff --git a/astro/sscalc/pkg-comment b/astro/sscalc/pkg-comment
new file mode 100644
index 000000000000..0338ad9387ec
--- /dev/null
+++ b/astro/sscalc/pkg-comment
@@ -0,0 +1 @@
+A sunrise/sunset time calculator
diff --git a/astro/sscalc/pkg-descr b/astro/sscalc/pkg-descr
new file mode 100644
index 000000000000..4edd1a41492f
--- /dev/null
+++ b/astro/sscalc/pkg-descr
@@ -0,0 +1,9 @@
+This is sscalc, a sunrise/sunset time calculator, ported to C.
+You can find the sunrise and sunset times for anywhere in the world
+as long as you know the latitude and longitude of the location.
+
+The program is a port of the Javascript program located at
+http://www.srrb.noaa.gov/highlights/sunrise/gen.html
+
+The page was written by Aaron Horiuchi, Chris Lehman and Chris
+Cornwall.
diff --git a/astro/sscalc/pkg-plist b/astro/sscalc/pkg-plist
new file mode 100644
index 000000000000..4570016fd999
--- /dev/null
+++ b/astro/sscalc/pkg-plist
@@ -0,0 +1,4 @@
+bin/sscalc
+share/doc/sscalc/cities.txt
+share/doc/sscalc/README
+@dirrm share/doc/sscalc