aboutsummaryrefslogtreecommitdiff
path: root/astro/stellarium
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-08-05 07:49:18 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-08-05 07:49:18 +0000
commit66dd5b05c711ffde564c47c90ff890e3ec7c4d3a (patch)
treef621c17e0d51b2e8d983ada120d52a43b3f0cdec /astro/stellarium
parent4ec97f59dd4ad9e3b82243928ccf78778eea410a (diff)
downloadports-66dd5b05c711ffde564c47c90ff890e3ec7c4d3a.tar.gz
ports-66dd5b05c711ffde564c47c90ff890e3ec7c4d3a.zip
- Install official PDF User Guide as part of the documentation (version
number is hardcoded as it is not always in sync with the PORTVERSION) - Make telescope control plugin (and Qt5SerialPort dependency) optional - Remove enforced distfiles checksum recalculation added in r377577: it turned out that updating distinfo manually is easier and a lot faster - Replace some options imperative (explicit) handling with helper knobs - Do not install high resolution textures by default, since they do not have their prime meridians recalibrated yet while stock textures have Discussed with: Alexander Wolf (upstream)
Notes
Notes: svn path=/head/; revision=419670
Diffstat (limited to 'astro/stellarium')
-rw-r--r--astro/stellarium/Makefile43
-rw-r--r--astro/stellarium/distinfo2
2 files changed, 27 insertions, 18 deletions
diff --git a/astro/stellarium/Makefile b/astro/stellarium/Makefile
index b84f51e36392..9b3be361eaff 100644
--- a/astro/stellarium/Makefile
+++ b/astro/stellarium/Makefile
@@ -3,10 +3,11 @@
PORTNAME= stellarium
PORTVERSION= 0.15.0
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= SF/${PORTNAME}/Stellarium-sources/${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
-EXTRACT_ONLY= ${_DISTFILES:Nstars_*.cat}
+EXTRACT_ONLY= ${_DISTFILES:Nstars_*.cat:N*.pdf}
MAINTAINER= danfe@FreeBSD.org
COMMENT= 3D photo-realistic sky renderer (planetarium)
@@ -17,21 +18,35 @@ CONFLICTS_INSTALL= ${PORTNAME}-qt4-0.12.*
USES= cmake gettext
USE_QT5= qmake_build buildtools_build linguisttools_build \
- concurrent core gui network opengl printsupport \
- serialport widgets
+ concurrent core gui network opengl printsupport widgets
-PORTDOCS= AUTHORS ChangeLog README
+PORTDOCS= AUTHORS ChangeLog README stellarium_user_guide-0.15.0-1.pdf
+
+OPTIONS_DEFINE= DOCS MORE_STARS MULTIMEDIA SCRIPTING TEXTURES \
+ TELESCOPE
+OPTIONS_DEFAULT= MULTIMEDIA SCRIPTING TELESCOPE
-OPTIONS_DEFINE= DOCS MORE_STARS MULTIMEDIA SCRIPTING TEXTURES
-OPTIONS_DEFAULT= MULTIMEDIA SCRIPTING TEXTURES
MORE_STARS_DESC= Install extra star catalogs (1.0GB)
TEXTURES_DESC= Install better quality textures
MULTIMEDIA_DESC= Sound and video support
SCRIPTING_DESC= Scripting support
+TELESCOPE_DESC= Telescope control plugin
+
+DOCS_MASTER_SITES= SF/${PORTNAME}/Stellarium-user-guide/0.15.0-1:ug
+DOCS_DISTFILES= stellarium_user_guide-0.15.0-1.pdf:ug
+
+TEXTURES_MASTER_SITES= SF/${PORTNAME}/Extra-data-files/textures:gfx
+TEXTURES_DISTFILES= textures-1K.zip:gfx
+
+MULTIMEDIA_USE= QT5=multimedia
+MULTIMEDIA_CMAKE_OFF= -DENABLE_MEDIA:BOOL=OFF
+
+TELESCOPE_USE= QT5=serialport
+TELESCOPE_CMAKE_OFF= -DUSE_PLUGIN_TELESCOPECONTROL:BOOL=OFF
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MMORE_STARS} || ${.TARGETS:Mmakesum}
+.if ${PORT_OPTIONS:MMORE_STARS}
. for i in 4 5 6 7 8
MASTER_SITES+= SF/${PORTNAME}/Extra-data-files/stars${i}:stars${i}
. endfor
@@ -43,17 +58,6 @@ PLIST_SUB+= MORE_STARS=""
PLIST_SUB+= MORE_STARS="@comment "
.endif
-.if ${PORT_OPTIONS:MTEXTURES} || ${.TARGETS:Mmakesum}
-MASTER_SITES+= SF/${PORTNAME}/Extra-data-files/textures:gfx
-DISTFILES+= textures-1K.zip:gfx
-.endif
-
-.if ${PORT_OPTIONS:MMULTIMEDIA}
-USE_QT5+= multimedia
-.else
-CMAKE_ARGS+= -DENABLE_MEDIA:BOOL=OFF
-.endif
-
.if ${PORT_OPTIONS:MSCRIPTING}
USE_QT5+= script
PLIST_SUB+= SCRIPTS=""
@@ -62,6 +66,9 @@ CMAKE_ARGS+= -DENABLE_SCRIPTING:BOOL=OFF
PLIST_SUB+= SCRIPTS="@comment "
.endif
+post-extract-DOCS-on:
+ @${LN} -sf ${_DISTDIR}/stellarium_user_guide-0.15.0-1.pdf ${WRKSRC}
+
post-patch:
@${REINPLACE_CMD} -e 's, -Wno-unused-result,,' ${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e 's,-Testscene,&_ground,' \
diff --git a/astro/stellarium/distinfo b/astro/stellarium/distinfo
index 79befa984e8d..e475762732a1 100644
--- a/astro/stellarium/distinfo
+++ b/astro/stellarium/distinfo
@@ -1,5 +1,7 @@
SHA256 (stellarium-0.15.0.tar.gz) = 74d0e3a69fcbaf1c6278f601a44497fd3e9f2de7dfa11a60197d3afb68288746
SIZE (stellarium-0.15.0.tar.gz) = 147160785
+SHA256 (stellarium_user_guide-0.15.0-1.pdf) = 264d437a1afc0742f5bbadf37115d8cd2b41ac462daf1516657c091955c9217e
+SIZE (stellarium_user_guide-0.15.0-1.pdf) = 16155822
SHA256 (stars_4_1v0_1.cat) = 7a2084e5e45610bbffae9448d9552d8a8dd191e5b1a07b0e47d27622fab4a979
SIZE (stars_4_1v0_1.cat) = 17040932
SHA256 (stars_5_2v0_1.cat) = c4ebd18d05a805308cfac85fe224e3f0a75db6579cae65c935a0954da13f4164