aboutsummaryrefslogtreecommitdiff
path: root/astro/sunclock
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-06 06:29:02 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-06 06:29:02 +0000
commit5b13a6298ff0b6b17a548b4db2af9866582bfcca (patch)
tree5b7d32786a9c747f809c64153e00745509697847 /astro/sunclock
parentbe8e3ce17cbb6bbf9d258f938bcfc1ec97567e42 (diff)
downloadports-5b13a6298ff0b6b17a548b4db2af9866582bfcca.tar.gz
ports-5b13a6298ff0b6b17a548b4db2af9866582bfcca.zip
- Fix pointyhat building (it strange, but it doesn't build there. Fixed
by adding includepaths explicitly) - Fix permissions by replacing 'cp's and 'install's by BSD_INSTALL_XXX equivalents PR: ports/101362 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=169799
Diffstat (limited to 'astro/sunclock')
-rw-r--r--astro/sunclock/Makefile4
-rw-r--r--astro/sunclock/files/patch-Imakefile31
-rw-r--r--astro/sunclock/files/patch-editkit_Imakefile35
-rw-r--r--astro/sunclock/files/patch-sunclock.c34
4 files changed, 80 insertions, 24 deletions
diff --git a/astro/sunclock/Makefile b/astro/sunclock/Makefile
index 3cd8a36a6557..ad7dec6b5839 100644
--- a/astro/sunclock/Makefile
+++ b/astro/sunclock/Makefile
@@ -8,6 +8,7 @@
PORTNAME= sunclock
PORTVERSION= 3.55
+PORTREVISION= 1
CATEGORIES= astro x11-clocks
MASTER_SITES= ftp://ftp.ac-grenoble.fr/ge/geosciences/sunclock/ \
http://mbsd.msk.ru/dist/
@@ -21,7 +22,8 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
USE_BZIP2= yes
USE_XPM= yes
USE_IMAKE= yes
-CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
MAN1= sunclock.1
diff --git a/astro/sunclock/files/patch-Imakefile b/astro/sunclock/files/patch-Imakefile
index 16d095369c03..894fa1bb12a1 100644
--- a/astro/sunclock/files/patch-Imakefile
+++ b/astro/sunclock/files/patch-Imakefile
@@ -1,5 +1,5 @@
--- Imakefile.orig Sun Jun 18 23:58:50 2006
-+++ Imakefile Wed Jul 26 14:47:03 2006
++++ Imakefile Fri Aug 4 19:11:06 2006
@@ -1,18 +1,18 @@
XCOMM Should install to /usr or /usr/local ??
-DESTDIR=/usr
@@ -23,7 +23,7 @@
XCOMM
XCOMM Compile options:
-@@ -42,13 +42,13 @@
+@@ -42,13 +42,12 @@
#CCOPTIONS=-O -DZLIB -DNEW_CTIME -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\"
# Solaris, Linux
@@ -39,12 +39,11 @@
+JLIBDIR=-L${LOCALBASE}/lib
+ZLIBDIR=-L${LOCALBASE}/lib
+JINC=-I${LOCALBASE}/include
-+CCOPTIONS=-O -DZLIB -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\" -DNEW_CTIME -I${LOCALBASE}/include
-+INCLUDES+= -I${LOCALBASE}/include
++CCOPTIONS=-DZLIB -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\" -DNEW_CTIME -I${LOCALBASE}/include -I${X11BASE}/include -L${LOCALBASE}/lib -L${X11BASE}/lib
#endif
SRCS=sunclock.c astro.c widgets.c tildepath.c dirlist.c \
-@@ -56,7 +56,7 @@
+@@ -56,7 +55,7 @@
OBJS=sunclock.o astro.o widgets.o tildepath.o dirlist.o \
readvmf.o readxpm.o readgif.o readjpeg.o readpng.o
LOCAL_LIBRARIES=$(XLIB) $(XPMLIBDIR) -lXpm $(ZLIBDIR) -lz \
@@ -53,7 +52,7 @@
DEPLIBS= # I don't know what I'm doing, and I hate imake!
ComplexProgramTarget(sunclock)
-@@ -64,7 +64,7 @@
+@@ -64,7 +63,7 @@
all::
cd editkit ; xmkmf ; make emx \
DESTDIR=$(DESTDIR) \
@@ -62,13 +61,23 @@
MANDIR=$(SHAREDIR)/editkit \
SHAREDIR=$(DESTDIR)$(SHAREDIR)/editkit
-@@ -78,8 +78,7 @@
- cd i18n ; rm -f *~ ; cp -f Sunclock.* $(DESTDIR)$(SHAREDIR)/i18n
+@@ -74,14 +73,13 @@
+
+ install:: install.man
+ $(MKDIRHIER) $(DESTDIR)$(SHAREDIR)/i18n
+- cp -f Sunclockrc $(DESTDIR)$(SHAREDIR)
+- cd i18n ; rm -f *~ ; cp -f Sunclock.* $(DESTDIR)$(SHAREDIR)/i18n
++ ${BSD_INSTALL_DATA} Sunclockrc $(DESTDIR)$(SHAREDIR)
++ cd i18n ; rm -f *~ ; ${BSD_INSTALL_DATA} Sunclock.* $(DESTDIR)$(SHAREDIR)/i18n
$(MKDIRHIER) $(DESTDIR)$(SHAREDIR)/earthmaps/vmf
- cd vmf ; rm -f *~ ; cp -f * $(DESTDIR)$(SHAREDIR)/earthmaps/vmf
+- cd vmf ; rm -f *~ ; cp -f * $(DESTDIR)$(SHAREDIR)/earthmaps/vmf
- $(MKDIRHIER) $(DESTDIR)$(SHAREDIR)/bin
- install -c -s editkit/emx $(DESTDIR)$(SHAREDIR)/bin
-+ install -c -s editkit/emx $(DESTDIR)/bin
++ cd vmf ; rm -f *~ ; ${BSD_INSTALL_DATA} * $(DESTDIR)$(SHAREDIR)/earthmaps/vmf
++ ${BSD_INSTALL_PROGRAM} editkit/emx $(DESTDIR)/bin
$(MKDIRHIER) $(DESTDIR)$(SHAREDIR)/editkit
- cd editkit ; install -c -m 444 rc.example README MANUAL.emacs \
+- cd editkit ; install -c -m 444 rc.example README MANUAL.emacs \
++ cd editkit ; ${BSD_INSTALL_DATA} rc.example README MANUAL.emacs \
$(DESTDIR)$(SHAREDIR)/editkit
+ cd $(DESTDIR)$(SHAREDIR)/editkit ; mv -f rc.example emxrc
+ cat MESSAGE
diff --git a/astro/sunclock/files/patch-editkit_Imakefile b/astro/sunclock/files/patch-editkit_Imakefile
new file mode 100644
index 000000000000..00d1538a8f78
--- /dev/null
+++ b/astro/sunclock/files/patch-editkit_Imakefile
@@ -0,0 +1,35 @@
+--- editkit/Imakefile.orig Sat Mar 11 00:11:23 2006
++++ editkit/Imakefile Fri Aug 4 19:13:21 2006
+@@ -33,7 +33,9 @@
+ XCOMM Compile options:
+ XCOMM
+
+-CFLAGS = -O2 -fomit-frame-pointer -pipe -Wall -DTHREED -DGREEK -DJUSTIFY -DSHAREDIR="\"$(SHAREDIR)\""
++COPTS = -DTHREED -DGREEK -DJUSTIFY -DSHAREDIR="\"$(SHAREDIR)\"" -I${LOCALBASE}/include -I${X11BASE}/include -L${X11BASE}/lib -L${LOCALBASE}/lib
++
++CCOPTIONS=${COPTS}
+
+ LOCAL_LIBRARIES=$(XLIB)
+ DEPLIBS= # I don't know what I'm doing, and I hate imake!
+@@ -45,7 +47,7 @@
+
+ x11.o:
+ ln -sf MANUAL.emacs emx.man
+- $(CC) $(CFLAGS) -DEMACS -o x11.o -c x11.c
++ $(CC) $(COPTS) ${CFLAGS} -DEMACS -o x11.o -c x11.c
+
+ install.man::
+ if [ -r $(DESTDIR)$(MANDIR)/emx.1.gz ] ; \
+@@ -55,9 +57,9 @@
+
+ install::
+ mkdir -p $(SHAREDIR)
+- cp -f rc.example $(SHAREDIR)/rc.common
+- cd $(SHAREDIR); ln -sf rc.common emxrc
+- cp -f README $(SHAREDIR)
++ ${BSD_INSTALL_DATA} rc.example $(SHAREDIR)/rc.common
++ ${BSD_INSTALL_DATA} $(SHAREDIR); ln -sf rc.common emxrc
++ ${BSD_INSTALL_DATA} README $(SHAREDIR)
+
+ clean::
+ rm -f core *~ emx.man
diff --git a/astro/sunclock/files/patch-sunclock.c b/astro/sunclock/files/patch-sunclock.c
index 8bf572d0ebd4..abaed8890f9c 100644
--- a/astro/sunclock/files/patch-sunclock.c
+++ b/astro/sunclock/files/patch-sunclock.c
@@ -1,5 +1,5 @@
---- sunclock.c.orig Fri Oct 8 17:11:44 2004
-+++ sunclock.c Sun Nov 21 13:51:14 2004
+--- sunclock.c.orig Mon Jun 19 23:30:02 2006
++++ sunclock.c Sun Aug 6 09:55:41 2006
@@ -125,7 +125,6 @@
* external routines
*/
@@ -8,7 +8,7 @@
#ifdef NEW_CTIME
extern char * timezone();
#endif
-@@ -2164,8 +2163,8 @@
+@@ -2197,8 +2196,8 @@
if (!Context->mark1.city) return;
@@ -19,7 +19,7 @@
/* Get local time at given location */
setTZ(Context->mark1.city);
-@@ -2314,8 +2313,8 @@
+@@ -2347,8 +2346,8 @@
if (!Context->flags.mapped) return;
@@ -30,7 +30,7 @@
if (!Context->wintype) {
char num[80];
-@@ -2661,7 +2660,7 @@
+@@ -2696,7 +2695,7 @@
Context->bits = 0;
Context->flags.update = 4;
@@ -39,7 +39,17 @@
Context->projtime = -1L;
Context->roottime = -1L;
Context->animtime = -1L;
-@@ -3827,7 +3826,7 @@
+@@ -3133,8 +3132,8 @@
+ {
+ int ilon, ilat, width, dw = 0;
+ struct TextLabel * label;
+- if(!Context->wintype) return;
+ char *text, *text0, *ptr;
++ if(!Context->wintype) return;
+
+ label = Context->label;
+ while (label) if (label->text && *label->text) {
+@@ -3909,7 +3908,7 @@
if (button_pressed) return;
@@ -48,7 +58,7 @@
erase_obj = 1;
if (Context->flags.colorlevel == MONOCHROME ||
-@@ -3835,10 +3834,10 @@
+@@ -3917,10 +3916,10 @@
drawSunAndMoon(Context);
erase_obj = 0;
@@ -61,7 +71,7 @@
&Context->moondec, &Context->moonlon,
&junk, &junk, &junk, &junk, &junk, &junk );
Context->moonlon = fixangle(Context->moonlon+180.0) - 180.0;
-@@ -3855,10 +3854,10 @@
+@@ -3937,10 +3936,10 @@
update the illuminated area on the screen. */
if (Context->projtime < 0 ||
@@ -74,7 +84,7 @@
Context->noon = noon;
Context->fnoon = fnoon;
moveNightArea(Context);
-@@ -4466,8 +4465,8 @@
+@@ -4548,8 +4547,8 @@
hw = Context->geom.height;
if (do_root == 2) hw += Context->hstrip;
@@ -85,7 +95,7 @@
else
if (do_root == 2 && mode==0 && rootpix) update = 0;
-@@ -4478,7 +4477,7 @@
+@@ -4560,7 +4559,7 @@
XSetForeground(dpy, Context->gdata->wingc,
Context->gdata->pixel[ROOTCOLOR]);
XFillRectangle(dpy, rootpix, Context->gdata->wingc, 0, 0, wr, hr);
@@ -94,7 +104,7 @@
if (random_rootpos) {
rootdx = (double)(random() % 10001)/10000.0;
rootdy = (double)(random() % 10001)/10000.0;
-@@ -5434,7 +5433,7 @@
+@@ -5533,7 +5532,7 @@
Context->flags.update = 2;
break;
case XK_w:
@@ -103,7 +113,7 @@
if (do_menu) do_menu = -1;
if (do_filesel) do_filesel = -1;
if (do_zoom) do_zoom = -1;
-@@ -5825,9 +5824,9 @@
+@@ -5949,9 +5948,9 @@
drawImageToRootWindow(Context, 0);
XFlush(dpy);
if (Context->flags.animate) {