aboutsummaryrefslogtreecommitdiff
path: root/astro/sunclock
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-04 09:36:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-04 09:36:28 +0000
commit63a50f4df38055166891bbdf4170393cb7ff9fed (patch)
tree7e3797ebb6194c56966012ba88a3356895f06f9b /astro/sunclock
parent219658944f0e1f3e923f6f910c98bd77d552e3c4 (diff)
downloadports-63a50f4df38055166891bbdf4170393cb7ff9fed.tar.gz
ports-63a50f4df38055166891bbdf4170393cb7ff9fed.zip
- Update to 3.57
PR: 171956 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=311591
Diffstat (limited to 'astro/sunclock')
-rw-r--r--astro/sunclock/Makefile66
-rw-r--r--astro/sunclock/distinfo4
-rw-r--r--astro/sunclock/files/patch-Imakefile74
-rw-r--r--astro/sunclock/files/patch-editkit_Imakefile35
-rw-r--r--astro/sunclock/files/patch-sunclock.c10
-rw-r--r--astro/sunclock/files/patch-widgets.c9
-rw-r--r--astro/sunclock/pkg-descr26
-rw-r--r--astro/sunclock/pkg-plist18
8 files changed, 90 insertions, 152 deletions
diff --git a/astro/sunclock/Makefile b/astro/sunclock/Makefile
index 87fd53285647..f4a8af1d5644 100644
--- a/astro/sunclock/Makefile
+++ b/astro/sunclock/Makefile
@@ -1,30 +1,68 @@
-# ex:ts=8
-# New ports collection makefile for: sunclock
-# Date created: 15 September 1996
-# Whom: torstenb
-#
+# Created by: torstenb
# $FreeBSD$
-#
PORTNAME= sunclock
-PORTVERSION= 3.56
-PORTREVISION= 5
+PORTVERSION= 3.57
CATEGORIES= astro x11-clocks
-MASTER_SITES= ftp://ftp.ac-grenoble.fr/ge/geosciences/sunclock/ \
- http://mbsd.msk.ru/dist/
+MASTER_SITES= http://www.arvernes.com/files/jpd/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Shows which portion of the Earth's surface is illuminated by the Sun
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
+LICENSE= GPLv2
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
USE_BZIP2= yes
USE_XORG= xpm
-USE_IMAKE= yes
-CFLAGS+= -I${LOCALBASE}/include
-CPPFLAGS+= -I${LOCALBASE}/include
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= $$(libpng-config --I_opts) \
+ -I${LOCALBASE}/include \
+ -DEMXBINDIR=\\\"${PREFIX}/bin\\\" \
+ -DDOCDIR=\\\"${PREFIX}/lib/X11/doc\\\"
+LDFLAGS+= $$(libpng-config --L_opts) \
+ -L${LOCALBASE}/lib
MAN1= sunclock.1
+post-patch:
+ @cd ${WRKSRC} && ${SED} -e \
+ '/^DESTDIR/s|=.*|=${PREFIX}| ; \
+ s|/X11R6/man|$$(DESTDIR)/man| ; \
+ s|bin/X11|bin| ; \
+ s|^CC=|CC?=| ; \
+ s|^CFLAGS=|CFLAGS+=| ; \
+ s|-I/usr/include/X11|$${CPPFLAGS}| ; \
+ s|-L/usr/X11R6/lib|$${LDFLAGS}| ; \
+ s| make | $$(MAKE) | ; \
+ s|$$(SHAREDIR)/bin|$$(DESTDIR)/bin| ; \
+ s|$$(SHAREDIR)/editkit|$$(DESTDIR)/share/sunclock/editkit|' \
+ < Makefile.noimake > Makefile
+ @${LN} -sf sunclock.man ${WRKSRC}/sunclock.1
+ @${REINPLACE_CMD} -e \
+ 's|= -O2|+= $${CPPFLAGS}| ; \
+ s|-L/usr/X11R6/lib|$${LDFLAGS}| ; \
+ s|gcc |$$(CC) |' ${WRKSRC}/editkit/Makefile.kit
+ @${LN} -sf rc.example ${WRKSRC}/editkit/emxrc
+ @${REINPLACE_CMD} -e \
+ 's|gzFile \* fd;|gzFile fd;|' ${WRKSRC}/readvmf.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sunclock ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/sunclock.1 ${MANPREFIX}/man/man1
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Sunclockrc ${DATADIR}
+ @${MKDIR} ${DATADIR}/earthmaps/vmf
+ ${INSTALL_DATA} ${WRKSRC}/vmf/*.vmf ${DATADIR}/earthmaps/vmf
+ @${GZIP_CMD} ${DATADIR}/earthmaps/vmf/*.vmf
+ @${MKDIR} ${DATADIR}/i18n
+ ${INSTALL_DATA} ${WRKSRC}/i18n/Sunclock.?? ${DATADIR}/i18n
+ ${INSTALL_PROGRAM} ${WRKSRC}/editkit/emx ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}/editkit
+ ${INSTALL_DATA} ${WRKSRC}/editkit/MANUAL.emacs ${DATADIR}/editkit
+ ${INSTALL_DATA} ${WRKSRC}/editkit/README ${DATADIR}/editkit
+ ${INSTALL_DATA} ${WRKSRC}/editkit/emxrc ${DATADIR}/editkit
+
.include <bsd.port.mk>
diff --git a/astro/sunclock/distinfo b/astro/sunclock/distinfo
index 794e99454248..36574f384a29 100644
--- a/astro/sunclock/distinfo
+++ b/astro/sunclock/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sunclock-3.56.tar.bz2) = 27871a3f0d908e887dcbf128cc3722b9a62daa8748d21e241f7882b29c62a22f
-SIZE (sunclock-3.56.tar.bz2) = 1313390
+SHA256 (sunclock-3.57.tar.bz2) = 4328200ceaa31160e901fb855d664033566d72b26a90605acc5d0ed9365402be
+SIZE (sunclock-3.57.tar.bz2) = 1325138
diff --git a/astro/sunclock/files/patch-Imakefile b/astro/sunclock/files/patch-Imakefile
deleted file mode 100644
index ae6287c2a336..000000000000
--- a/astro/sunclock/files/patch-Imakefile
+++ /dev/null
@@ -1,74 +0,0 @@
---- Imakefile.orig Sun Jun 18 23:58:50 2006
-+++ Imakefile Fri Aug 4 19:11:06 2006
-@@ -1,18 +1,18 @@
- XCOMM Should install to /usr or /usr/local ??
--DESTDIR=/usr
-+DESTDIR=${PREFIX}
-
- XCOMM Name of man subdirectory of DESTDIR:
--MANDIR=/X11R6/man/man1
-+MANDIR=/man/man1
-
- XCOMM Name of bin subdirectory of DESTDIR: /X11R6/bin or maybe just /bin
--BINDIR=/X11R6/bin
-+BINDIR=/bin
-
- XCOMM Name of share subdirectory of DESTDIR:
- SHAREDIR=/share/sunclock
-
- XCOMM Name of DOCDIR's subdirectories of DESTDIR:
- DOCDIR=/X11R6/lib/X11/doc
--DOCHTMLDIR=/X11R6/lib/X11/doc/html
-+DOCHTMLDIR=/lib/X11/doc/html
-
- XCOMM
- XCOMM Compile options:
-@@ -42,13 +42,12 @@
- #CCOPTIONS=-O -DZLIB -DNEW_CTIME -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\"
-
- # Solaris, Linux
--#XPMLIBDIR=-L/usr/X11R6/lib
--#XPMINC=-I/usr/X11R6/include/X11
--#JLIBDIR=-L/usr/lib
--#ZLIBDIR=-L/usr/lib
--#JINC=-I/usr/include
--
--CCOPTIONS=-O -DZLIB -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\"
-+XPMLIBDIR=-L${LOCALBASE}/lib
-+XPMINC=-I${LOCALBASE}/include/X11
-+JLIBDIR=-L${LOCALBASE}/lib
-+ZLIBDIR=-L${LOCALBASE}/lib
-+JINC=-I${LOCALBASE}/include
-+CCOPTIONS=-DZLIB -DSHAREDIR=\"$(DESTDIR)$(SHAREDIR)\" -DNEW_CTIME -I${LOCALBASE}/include -L${LOCALBASE}/lib
- #endif
-
- SRCS=sunclock.c astro.c widgets.c tildepath.c dirlist.c \
-@@ -64,7 +63,7 @@
- all::
- cd editkit ; xmkmf ; make emx \
- DESTDIR=$(DESTDIR) \
-- BINDIR=$(SHAREDIR)/bin \
-+ BINDIR=/bin \
- MANDIR=$(SHAREDIR)/editkit \
- SHAREDIR=$(DESTDIR)$(SHAREDIR)/editkit
-
-@@ -74,14 +73,13 @@
-
- install:: install.man
- $(MKDIRHIER) $(DESTDIR)$(SHAREDIR)/i18n
-- cp -f Sunclockrc $(DESTDIR)$(SHAREDIR)
-- cd i18n ; rm -f *~ ; cp -f Sunclock.* $(DESTDIR)$(SHAREDIR)/i18n
-+ ${BSD_INSTALL_DATA} Sunclockrc $(DESTDIR)$(SHAREDIR)
-+ cd i18n ; rm -f *~ ; ${BSD_INSTALL_DATA} Sunclock.* $(DESTDIR)$(SHAREDIR)/i18n
- $(MKDIRHIER) $(DESTDIR)$(SHAREDIR)/earthmaps/vmf
-- cd vmf ; rm -f *~ ; cp -f * $(DESTDIR)$(SHAREDIR)/earthmaps/vmf
-- $(MKDIRHIER) $(DESTDIR)$(SHAREDIR)/bin
-- install -c -s editkit/emx $(DESTDIR)$(SHAREDIR)/bin
-+ cd vmf ; rm -f *~ ; ${BSD_INSTALL_DATA} * $(DESTDIR)$(SHAREDIR)/earthmaps/vmf
-+ ${BSD_INSTALL_PROGRAM} editkit/emx $(DESTDIR)/bin
- $(MKDIRHIER) $(DESTDIR)$(SHAREDIR)/editkit
-- cd editkit ; install -c -m 444 rc.example README MANUAL.emacs \
-+ cd editkit ; ${BSD_INSTALL_DATA} rc.example README MANUAL.emacs \
- $(DESTDIR)$(SHAREDIR)/editkit
- cd $(DESTDIR)$(SHAREDIR)/editkit ; mv -f rc.example emxrc
- cat MESSAGE
diff --git a/astro/sunclock/files/patch-editkit_Imakefile b/astro/sunclock/files/patch-editkit_Imakefile
deleted file mode 100644
index a73976658268..000000000000
--- a/astro/sunclock/files/patch-editkit_Imakefile
+++ /dev/null
@@ -1,35 +0,0 @@
---- editkit/Imakefile.orig Sat Mar 11 00:11:23 2006
-+++ editkit/Imakefile Fri Aug 4 19:13:21 2006
-@@ -33,7 +33,9 @@
- XCOMM Compile options:
- XCOMM
-
--CFLAGS = -O2 -fomit-frame-pointer -pipe -Wall -DTHREED -DGREEK -DJUSTIFY -DSHAREDIR="\"$(SHAREDIR)\""
-+COPTS = -DTHREED -DGREEK -DJUSTIFY -DSHAREDIR="\"$(SHAREDIR)\"" -I${LOCALBASE}/include -L${LOCALBASE}/lib
-+
-+CCOPTIONS=${COPTS}
-
- LOCAL_LIBRARIES=$(XLIB)
- DEPLIBS= # I don't know what I'm doing, and I hate imake!
-@@ -45,7 +47,7 @@
-
- x11.o:
- ln -sf MANUAL.emacs emx.man
-- $(CC) $(CFLAGS) -DEMACS -o x11.o -c x11.c
-+ $(CC) $(COPTS) ${CFLAGS} -DEMACS -o x11.o -c x11.c
-
- install.man::
- if [ -r $(DESTDIR)$(MANDIR)/emx.1.gz ] ; \
-@@ -55,9 +57,9 @@
-
- install::
- mkdir -p $(SHAREDIR)
-- cp -f rc.example $(SHAREDIR)/rc.common
-- cd $(SHAREDIR); ln -sf rc.common emxrc
-- cp -f README $(SHAREDIR)
-+ ${BSD_INSTALL_DATA} rc.example $(SHAREDIR)/rc.common
-+ ${BSD_INSTALL_DATA} $(SHAREDIR); ln -sf rc.common emxrc
-+ ${BSD_INSTALL_DATA} README $(SHAREDIR)
-
- clean::
- rm -f core *~ emx.man
diff --git a/astro/sunclock/files/patch-sunclock.c b/astro/sunclock/files/patch-sunclock.c
index 79ef078a2c40..c3e9135f0983 100644
--- a/astro/sunclock/files/patch-sunclock.c
+++ b/astro/sunclock/files/patch-sunclock.c
@@ -59,16 +59,6 @@
Context->projtime = -1L;
Context->roottime = -1L;
Context->animtime = -1L;
-@@ -3142,8 +3131,8 @@
- {
- int ilon, ilat, width, dw = 0;
- struct TextLabel * label;
-- if(!Context->wintype) return;
- char *text, *text0, *ptr;
-+ if(!Context->wintype) return;
-
- label = Context->label;
- while (label) if (label->text && *label->text) {
@@ -3918,7 +3907,7 @@
if (button_pressed) return;
diff --git a/astro/sunclock/files/patch-widgets.c b/astro/sunclock/files/patch-widgets.c
new file mode 100644
index 000000000000..e15c78a91f13
--- /dev/null
+++ b/astro/sunclock/files/patch-widgets.c
@@ -0,0 +1,9 @@
+--- widgets.c.orig 2011-07-09 18:51:18.000000000 +0900
++++ widgets.c 2012-08-14 04:13:36.000000000 +0900
+@@ -1,6 +1,5 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+-#include <sys/timeb.h>
+ #include <sys/stat.h>
+ #include <string.h>
+
diff --git a/astro/sunclock/pkg-descr b/astro/sunclock/pkg-descr
index 4f6935d6900e..bf67bf4f7d21 100644
--- a/astro/sunclock/pkg-descr
+++ b/astro/sunclock/pkg-descr
@@ -1,9 +1,19 @@
-This program is a clock that shows which portion of the Earth's surface is
-illuminated by the sun. It is designed to be usually iconic, but can be
-opened for a larger display with the time updated every second and both the
-local time zone and UTC displayed. The Suntools version had a menu that
-allowed you to speed up time, show different dates, etc., but I have
-never implemented any of that in the X version; there is some support
-for it in the code, however.
+Sunclock is an X11 application that displays a map of the Earth and
+shows the illuminated portion of the globe. In addition to providing
+local time for the default timezone, it also displays GMT time,
+legal and solar time of major cities, their latitude and longitude,
+the mutual distances of arbitrary locations on Earth, the position
+at zenith of Sun and Moon. Sunclock can display meridians, parallels,
+tropics and arctic circles. It has builtin functions that accelerate
+the speed of time and show the evolution of seasons. Sunclock can
+be internationalized for various western languages. It is possible
+to customize the app-default file and enter additional city entries.
-WWW: http://frmas.free.fr/li_1.htm
+Sunclock can commute between two states, the "clock window" and the
+"map window". The clock window displays a small map of the Earth
+and therefore occupies little space on the screen, while the "map
+window" displays a large map and offers more advanced functions.
+The Sunclock package includes a resizable and zoomable vector map.
+External Earth maps can also be loaded.
+
+WWW: http://www.arvernes.com/wiki/index.php/Sunclock
diff --git a/astro/sunclock/pkg-plist b/astro/sunclock/pkg-plist
index af584884fdfd..dc2638276b1c 100644
--- a/astro/sunclock/pkg-plist
+++ b/astro/sunclock/pkg-plist
@@ -1,9 +1,9 @@
bin/emx
bin/sunclock
%%DATADIR%%/Sunclockrc
-%%DATADIR%%/earthmaps/vmf/countries.vmf
-%%DATADIR%%/earthmaps/vmf/landwater.vmf
-%%DATADIR%%/earthmaps/vmf/timezones.vmf
+%%DATADIR%%/earthmaps/vmf/countries.vmf.gz
+%%DATADIR%%/earthmaps/vmf/landwater.vmf.gz
+%%DATADIR%%/earthmaps/vmf/timezones.vmf.gz
%%DATADIR%%/editkit/MANUAL.emacs
%%DATADIR%%/editkit/README
%%DATADIR%%/editkit/emxrc
@@ -15,9 +15,9 @@ bin/sunclock
%%DATADIR%%/i18n/Sunclock.nl
%%DATADIR%%/i18n/Sunclock.no
%%DATADIR%%/i18n/Sunclock.pl
-%%DATADIR%%/i18n/Sunclock.se
-@dirrmtry %%DATADIR%%/i18n
-@dirrmtry %%DATADIR%%/editkit
-@dirrmtry %%DATADIR%%/earthmaps/vmf
-@dirrmtry %%DATADIR%%/earthmaps
-@dirrmtry %%DATADIR%%
+%%DATADIR%%/i18n/Sunclock.sv
+@dirrm %%DATADIR%%/i18n
+@dirrm %%DATADIR%%/editkit
+@dirrm %%DATADIR%%/earthmaps/vmf
+@dirrm %%DATADIR%%/earthmaps
+@dirrm %%DATADIR%%