aboutsummaryrefslogtreecommitdiff
path: root/astro/wcslib
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-05-08 22:41:00 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-05-08 22:41:00 +0000
commit7bfa5cd376c56ce9c748c1721a31d78740663366 (patch)
tree1fb02e546c92b18cdc191f675c8206cbba79d0be /astro/wcslib
parent8656b71ea37721b65748a52c2638e667b5ed427e (diff)
downloadports-7bfa5cd376c56ce9c748c1721a31d78740663366.tar.gz
ports-7bfa5cd376c56ce9c748c1721a31d78740663366.zip
- Fix the plist when the CFITSIO option is on.
- Use the new OPTIONS helpers to simplify the Makefile. Related to both, also stop automatically turning the CFITSIO option on when libcfitsio.so is installed: wcslib has had proper --with{out}-cfitsio options since version 4.4.4. This will turn off CFITSIO support for most people and indirectly fix their builds with astro/cfitsio-3.360-1 [1]. If people do choose to have it on, ports/189487 needs to be committed, otherwise there will be plist errors because wcslib's configure script will not be able to detect that cfitsio is installed and can be used. [1] http://lists.freebsd.org/pipermail/freebsd-ports/2014-May/092070.html
Notes
Notes: svn path=/head/; revision=353362
Diffstat (limited to 'astro/wcslib')
-rw-r--r--astro/wcslib/Makefile22
-rw-r--r--astro/wcslib/pkg-plist5
2 files changed, 10 insertions, 17 deletions
diff --git a/astro/wcslib/Makefile b/astro/wcslib/Makefile
index 0f8376565f78..473aae0040cb 100644
--- a/astro/wcslib/Makefile
+++ b/astro/wcslib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wcslib
PORTVERSION= 4.13.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= astro
MASTER_SITES= ftp://ftp.atnf.csiro.au/pub/software/wcslib/
@@ -23,24 +23,14 @@ PLIST_SUB= VERSION="${PORTVERSION}"
# For most users it will not be required.
OPTIONS_DEFINE= CFITSIO PGPLOT
+OPTIONS_SUB= yes
CFITSIO_DESC= Add cfitsio support (for tests only)
PGPLOT_DESC= Add pgplot support (for tests only)
-.include <bsd.port.options.mk>
-
-# The configure script unconditionally searches for the cftisio library
-# and uses it if found.
-
-.if ${PORT_OPTIONS:MCFITSIO} || exists(${LOCALBASE}/lib/libcfitsio.so)
-PLIST_SUB+= HPXCVT=""
-LIB_DEPENDS+= libcfitsio.so:${PORTSDIR}/astro/cfitsio
-.else
-PLIST_SUB+= HPXCVT="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPGPLOT}
-LIB_DEPENDS+= libpgplot.so:${PORTSDIR}/graphics/pgplot
-.endif
+CFITSIO_CONFIGURE_WITH= cfitsio
+CFITSIO_LIB_DEPENDS= libcfitsio.so:${PORTSDIR}/astro/cfitsio
+PGPLOT_CONFIGURE_WITH= pgplot
+PGPLOT_LIB_DEPENDS= libpgplot.so:${PORTSDIR}/graphics/pgplot
post-patch:
@${REINPLACE_CMD} -e 's#%%PKGDIR%%#${STAGEDIR}${PREFIX}/libdata#g' \
diff --git a/astro/wcslib/pkg-plist b/astro/wcslib/pkg-plist
index 8008ddc7564e..34a1ab7f7213 100644
--- a/astro/wcslib/pkg-plist
+++ b/astro/wcslib/pkg-plist
@@ -1,4 +1,5 @@
-%%HPXCVT%%bin/HPXcvt
+%%CFITSIO%%bin/HPXcvt
+%%CFITSIO%%bin/wcsware
bin/fitshdr
include/wcslib
include/wcslib-%%VERSION%%/cel.h
@@ -29,7 +30,9 @@ lib/libwcs.so
lib/libwcs.so.%%VERSION%%
lib/libwcs.so.4
libdata/pkgconfig/wcslib.pc
+%%CFITSIO%%man/man1/HPXcvt.1.gz
man/man1/fitshdr.1.gz
+%%CFITSIO%%man/man1/wcsware.1.gz
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x73.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x62.html
%%PORTDOCS%%%%DOCSDIR%%/html/wcshdr_8h-source.html