aboutsummaryrefslogtreecommitdiff
path: root/astro/weather
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-12-31 12:47:51 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-12-31 12:47:51 +0000
commitf62dc6aa514cbdceb397b97a921d3f12f9a7f359 (patch)
tree5e65305b9b58b2a84df9c02cb8b083366a40c648 /astro/weather
parentd13e8fffa3fbaa46a4ed7bd2b5826f03f6aaaec2 (diff)
downloadports-f62dc6aa514cbdceb397b97a921d3f12f9a7f359.tar.gz
ports-f62dc6aa514cbdceb397b97a921d3f12f9a7f359.zip
- Merge post-install: to do-install:
- Support STAGEDIR
Notes
Notes: svn path=/head/; revision=338287
Diffstat (limited to 'astro/weather')
-rw-r--r--astro/weather/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/astro/weather/Makefile b/astro/weather/Makefile
index 63bab76e6e54..0d3f8a000bf8 100644
--- a/astro/weather/Makefile
+++ b/astro/weather/Makefile
@@ -15,17 +15,16 @@ LICENSE= ISCL
CONFLICTS_INSTALL= expect-[0-9]* expect-nox11-[0-9]*
-NO_STAGE= yes
USE_PYTHON= yes
USE_XZ= yes
USES= shebangfix
-MAN1= ${PORTNAME}.1
-MAN5= ${PORTNAME}rc.5
PLIST_FILES= bin/${PORTNAME} \
%%PYTHON_SITELIBDIR%%/${PORTNAME}.py \
%%PYTHON_SITELIBDIR%%/${PORTNAME}.pyc \
- %%PYTHON_SITELIBDIR%%/${PORTNAME}.pyo
+ %%PYTHON_SITELIBDIR%%/${PORTNAME}.pyo \
+ man/man1/${PORTNAME}.1.gz \
+ man/man5/${PORTNAME}rc.5.gz
PORTDATA= airports places stations zctas zones
SHEBANG_FILES= ${PORTNAME}
@@ -37,14 +36,13 @@ do-build:
@${PYTHON_CMD} -O -m compileall ${WRKSRC}/${PORTNAME}.py
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
- cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTNAME}.py ${PORTNAME}.pyc ${PORTNAME}.pyo ${PYTHON_SITELIBDIR}/
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1/${PORTNAME}.1
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}rc.5 ${MANPREFIX}/man/man5/${PORTNAME}rc.5
- ${MKDIR} ${DATADIR}/
- cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDATA} ${DATADIR}/
-
-post-install:
+ ${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTNAME}.py ${PORTNAME}.pyc ${PORTNAME}.pyo ${STAGEDIR}${PYTHON_SITELIBDIR}/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1/${PORTNAME}.1
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}rc.5 ${STAGEDIR}${MANPREFIX}/man/man5/${PORTNAME}rc.5
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDATA} ${STAGEDIR}${DATADIR}/
@${ECHO_MSG} ""
@${ECHO_MSG} "Please add the following to your .weatherrc in order to use installed data files:"
@${ECHO_MSG} ""